Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

my E1 line displays wrong number

Hi I have a new CCME installation. Incoming and outgoing calls are fine. I have an odd problem where an outgoing call displays the wrong number. My local telecom provider in Bulgaria has given me a ddi range 2 810 82xx and 2 810 84xx however when i make a call from say extension 400 the number displays on my mobile as +359 281082

If i debug isdn q931 i can see my number being sent to the exchange. " Progress Ind i = 0x8183 - Origination address is non-ISDN

Calling Party Number i = 0x0180, '28108400'

Before i call Bulgaria telecom is there any further debug/testing i can do.

regards

colin

  • Other Collaboration Voice and Video Subjects
11 REPLIES
Blue

Re: my E1 line displays wrong number

Definately sounds like an issue with your carrier. Verify they have enabled outbound CLID on your trunk.

please rate posts.

andy dignan - berbee

New Member

Re: my E1 line displays wrong number

Hi Andy

Thanks for your reply, i am still working on this problem will let you know how i get on and will rate your reply.

colin

New Member

Re: my E1 line displays wrong number

Hi Colin

I have exactly the same problem with my E1 on a system that I'm currently commissioning in Spain. In my case I can demonsrate, using a completely seperate analgoue exchange, that CLID has been configured on the line. Although, when using CCME the caller ID always appears as 34 922 425400 for external calls.

Did you get any further identifying where the problem lay?

Regards

Carlos Abrams

New Member

Re: my E1 line displays wrong number

Hi Carlos

Not yet Bulgaria telecom changed something and now we have no incoming or outgoing calls so i have to go back and start again. Just out of interest are you using the telephony-service line dialplan-pattern 1 xxxx... extension-length 3 command because i was wondering if this is something that influences the CLID, but have not been able to test yet.

regards Colin

New Member

Re: my E1 line displays wrong number

Hi Colin

No we don't use the "dialplan-pattern" command.

I could include one and test it but this will have to wait until tomorrow morning.

Carlos

New Member

Re: my E1 line displays wrong number

Hi Carlos

Can you copy me part of you config i would be really interested in how you handle incoming calls if you dont use the dialplan-pattern command.

Dont worry about testing the dialplan-pattern i will play with config on mine the office is not in use yet so there is no impact on users.

colin

New Member

Re: my E1 line displays wrong number

Here it is Colin :

!

interface Serial0/0/0:15

no ip address

no logging event link-status

isdn switch-type primary-net5

isdn overlap-receiving

isdn not-end-to-end 64

isdn incoming-voice voice

isdn bchan-number-order ascending

no cdp enable

!

voice-port 0/0/0:15

translation-profile incoming add_0_to_local_calls

input gain -3

output attenuation 3

cptone ES

description PRIMARIO A PSTN

!

dial-peer voice 1 pots

description LLAMADAS A PSTN POR PRI

translation-profile outgoing prefix

destination-pattern 0T

progress_ind alert enable 8

translate-outgoing calling 1

direct-inward-dial

port 0/0/0:15

!

telephony-service

fxo hook-flash

load 7910 P00307020200

load 7935 P00503010100

load 7960-7940 P00303020214

load 7914 S00103020002

load ATA ATA030100SCCP040211A

load 7905 CP7902060000SCCP050124A

load 7902 CP7905060000SCCP050124A

load 7920 cmterm_7920.4.0-02-00

load 7971 TERM70.6-0-3SR1S

load 7970 TERM70.6-0-3SR1S

load 7936 cmterm_7936.3-3-5-0

load 7912 CP7912080001SCCP051117A

max-ephones 96

max-dn 192

ip source-address xxx.xxx.xxx.xxx port 2000

timeouts interdigit 3

timeouts busy 5

system message Isaac Newton Group

url services http://phone-xml.berbee.com/menu.xml

network-locale ES

time-format 24

date-format dd-mm-yy

create cnf-files version-stamp 7960 Feb 24 2006 08:31:53

keepalive 10

voicemail 800

max-conferences 8 gain -6

moh u2.wav

transfer-system full-consult

transfer-pattern 0T

New Member

Re: my E1 line displays wrong number

Thanks Carlos

very interesting looks like you are using translation rules, i have not tried these before. Looks like i need to do a little reading.

regards

Colin

New Member

Re: my E1 line displays wrong number

Hi Colin

Adding the following to the telephony-service section solved this problem for us :

dialplan-pattern 1 9224254.. extension-length 2

206
Views
3
Helpful
11
Replies
This widget could not be displayed.