Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Need help on VVID

I have a Catalyst 3524XL Inline Power. The default VLAN is 1 and that is the VLAN for the IP Phones and the CCM. VLAN 120 is the VLAN for the workstations.

I have been trying to configure the switch so i am able to use the same port for the phone and the workstation. I have followed the documentation on http://www.cisco.com/warp/public/cc/pd/si/casi/ca3500xl/prodlit/cfig3_an.htm

but with no luck

Here is the config of the port:

interface FastEthernet0/1

switchport trunk encapsulation dot1q

switchport multi vlan 1,120

switchport mode trunk

switchport voice vlan 1

Int fa0/24 is a trunk to another switch.

Here are the VLANS:

VLAN Name Status Ports

---- -------------------------------- --------- -------------------------------

1 default active Fa0/2, Fa0/3, Fa0/4, Fa0/5,

Fa0/6, Fa0/7, Fa0/8, Fa0/9,

Fa0/10, Fa0/11, Fa0/12, Fa0/13,

Fa0/14, Fa0/15, Fa0/16, Fa0/17,

Fa0/18, Fa0/19, Fa0/20, Fa0/21,

Fa0/22, Fa0/23, Gi0/1, Gi0/2

115 VLAN0115 active

120 VLAN0120 active

213 VLAN0213 active

255 VLAN0255 active

1002 fddi-default active

1003 token-ring-default active

1004 fddinet-default active

1005 trnet-default active

Thanks in advance

3 REPLIES
Community Member

Re: Need help on VVID

The example link you referenced assumes that you're going to use vlan 1 for data and something else for voice. So try this on your 3524 & see if it works...

int fa 0/1

switchport trunk encap dot1q

switchport access vlan 120

switchport voice vlan 1

switchport mode trunk

Community Member

Re: Need help on VVID

What you are missing is the native vlan. I have pasted a working example that I use:

VLAN1 is my management vlan (10.4.66.0/26)

VLAN4 is my voice vlan (10.40.4.0/22)

VLAN81 is my data vlan (10.4.81.0/24)

All 24 FE ports can be used for Phones with PC or just a PC. The GE ports are used for uplinks.

interface FastEthernet0/1

switchport trunk encapsulation dot1q

switchport trunk native vlan 81

switchport mode trunk

switchport voice vlan 4

switchport priority extend cos 0

spanning-tree portfast

interface GigabitEthernet0/1

description Uplink to PWAMatherW2SW3

switchport mode trunk

interface VLAN1

ip address 10.4.66.52 255.255.255.192

Tom.

Community Member

Re: Need help on VVID

Hi,

Thanks for your reply.

Thomas this was the line that was missing in my config. Now it´s working great.

'switchport trunk native vlan 120'

Thank you very much for your help :-)

316
Views
0
Helpful
3
Replies
CreatePlease to create content