Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Need to reset MGCP everytime the WAN connection goes down

Folks,

We have 2 callmanagers (Pub & sub) at a centralized location. Recently we have noticed after the upgrade to 4.1(3) that if the wan connection goes down we have to telnet to the WAN router at the remote site and type in "no mgcp" and then "mgcp" for it to work, by default it does not register with the callmanager. Also when it does register with the callmanager, under "show mgcp statistics", I only see one callmanager (sub) and not the publisgers IP address, any help would ne highly appreciate. I have pasted the complete config. I can ping both the callmanagers from the WAN router.

!

clock timezone zone 12

clock summer-time EST recurring

no network-clock-participate slot 1

no network-clock-participate wic 1

voice-card 0

no dspfarm

!

voice-card 1

no dspfarm

!

ip subnet-zero

no ip source-route

no ip gratuitous-arps

ip cef

!

isdn switch-type primary-4ess

!

!

!

!

voice class codec 10

codec preference 1 g729br8

codec preference 2 g729r8

codec preference 3 g711ulaw

!

!

!

!

!

!

!

!

voice translation-rule 10

rule 1 /\(.*\)/ /6590/

!

!

voice translation-profile voice

translate called 10

!

!

application

global

service alternate DEFAULT

!

!

!

controller T1 0/1/0

framing esf

linecode b8zs

channel-group 0 timeslots 1-24

detect v54 channel-group 0

!

controller T1 1/0/0

framing esf

linecode b8zs

pri-group timeslots 1-24 service mgcp

!

!

!

!

interface GigabitEthernet0/0

description VLAN 1 Connection

ip address 172.20.31.30 255.255.255.0

duplex full

speed 100

media-type rj45

negotiation auto

!

interface GigabitEthernet0/1

description Voice VLAN

ip address 172.20.231.30 255.255.255.0

duplex full

speed 100

media-type rj45

negotiation auto

!

!

interface Serial0/1/0:0

no ip address

encapsulation frame-relay IETF

no fair-queue

frame-relay traffic-shaping

!

interface Serial0/1/0:0.3 point-to-point

description AT&T ePVC to IPFR

bandwidth 1024

ip address 172.20.150.129 255.255.255.252

frame-relay interface-dlci 777

class qosT1

!

interface Serial1/0/0:23

no ip address

no logging event link-status

isdn switch-type primary-ni

isdn incoming-voice voice

isdn send-alerting

no cdp enable

!

route-map Internet permit 10

match ip address Internet

set ip next-hop verify-availability 172.20.110.2 10 track 101

set ip next-hop verify-availability 172.20.109.2 20 track 100

!

!

!

!

control-plane

!

!

!

voice-port 0/2/0

!

voice-port 0/2/1

!

voice-port 0/2/2

!

voice-port 0/2/3

!

voice-port 0/3/0

signal groundStart

timing hookflash-out 50

connection plar 6590

description FXO Hunt Group

!

voice-port 0/3/1

signal groundStart

timing hookflash-out 50

connection plar 6590

description FXO Hunt Group

!

voice-port 0/3/2

signal groundStart

timing hookflash-out 50

connection plar 6590

description FXO Hunt Group

!

voice-port 0/3/3

signal groundStart

timing hookflash-out 50

connection plar 6590

description FXO Hunt Group

!

voice-port 1/0/0:23

input gain 2

!

ccm-manager fallback-mgcp

ccm-manager redundant-host 172.20.104.5

ccm-manager mgcp

ccm-manager music-on-hold

ccm-manager config server 172.20.104.5

ccm-manager config

!

mgcp call-agent 172.20.104.7 2427 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

no mgcp package-capability res-package

mgcp package-capability sst-package

no mgcp package-capability fxr-package

mgcp package-capability pre-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp fax t38 inhibit

mgcp rtp payload-type g726r16 static

mgcp bind control source-interface Serial0/1/0:0.3

mgcp bind media source-interface Serial0/1/0:0.3

!

mgcp profile default

!

!

dial-peer cor custom

!

!

!

dial-peer voice 999020 pots

service mgcpapp

port 0/2/0

6 REPLIES
New Member

Re: Need to reset MGCP everytime the WAN connection goes down

!

interface Serial1/0/0:23

no ip address

no logging event link-status

isdn switch-type primary-ni

isdn incoming-voice voice

isdn send-alerting

no cdp enable

!

dial-peer voice 999020 pots

service mgcpapp

port 0/2/0

!

dial-peer voice 999030 pots

preference 2

service mgcpapp

destination-pattern 9T

port 0/3/0

!

dial-peer voice 999031 pots

preference 3

service mgcpapp

destination-pattern 9T

port 0/3/1

!

dial-peer voice 999032 pots

preference 4

service mgcpapp

destination-pattern 9T

port 0/3/2

!

dial-peer voice 999033 pots

preference 5

service mgcpapp

port 0/3/3

!

dial-peer voice 999021 pots

service mgcpapp

port 0/2/1

!

dial-peer voice 999022 pots

service mgcpapp

port 0/2/2

!

dial-peer voice 999023 pots

service mgcpapp

port 0/2/3

!

dial-peer voice 99999 pots

service mgcpapp

destination-pattern 9T

incoming called-number .

direct-inward-dial

port 1/0/0:23

Green

Re: Need to reset MGCP everytime the WAN connection goes down

Hi parwal,

Which IOS version and platform you are running.

If u can simulate the problem and paste the:

debug mgcp packet

and detailed CCM|SDL trace will be great.

Re: Need to reset MGCP everytime the WAN connection goes down

You may be running into a issue with the mgcp bind command perhaps. Don't have the bug id offhand, but next time this happens gather the debugs as gogasca said and try to re-enter the mgcp bind commands as they are.

IOS version looks like 12.3(14)T or higher, which one exactly?

New Member

Re: Need to reset MGCP everytime the WAN connection goes down

Folks,

Very greatful for your response. I am taking over this router from someone else who was managing it. If you notice that the bind command is missing under the serial interface, do you this this might be an issue, i will surely post the debug mgcp output.

New Member

Re: Need to reset MGCP everytime the WAN connection goes down

interface Serial1/0/0:23

no ip address

no logging event link-status

isdn switch-type primary-ni

isdn incoming-voice voice

isdn send-alerting

no cdp enable

The isdn bind-l3 ccm-manager command is missing, what effect does that have?

Green

Re: Need to reset MGCP everytime the WAN connection goes down

This command is used to bind Layer 3 of the ISDN PRI interface of the Media Gateway Control Protocol (MGCP) voice gateway to the Cisco CallManager for PRI Q.931 signaling backhaul support,

Does your T1 PRI calls work fine?

What is the sh isdn status output?

Regarding the GW try to play with this command:

ccm-manager switchback

http://www.cisco.com/univercd/cc/td/doc/product/software/ios123/123tcr/123tvr/vrht_c4.htm#wp1062119

HTH

258
Views
0
Helpful
6
Replies
CreatePlease login to create content