Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

No audio when connected to Unity

Hello Cisco,

I have a question, Our customer is running Unity 3.1 Build 3.1(5) When connected to Unity I show a connection on the phone with no audio from the attendent. I checked port status and notice my connection. The features on my phone work normal with no problems. I'm able to leave a message also. Any suggestions would be appreciated. Thanks!

Brian DeLuca

Redrock Communications

5 REPLIES
Community Member

Re: No audio when connected to Unity

Here's an update while I'm connected to Unity I noticed on the call statistics I have a TxCnt but no RxCnt. Thanks!

Brian

Cisco Employee

Re: No audio when connected to Unity

sounds like a classic one way audio issue... here's a couple of tech tips that may help:

http://www.cisco.com/warp/customer/788/AVVID/fix_1way_voice.html

http://www.cisco.com/warp/customer/788/AVVID/1way_audio.html

Community Member

Re: No audio when connected to Unity

Hello Cisco,

I wanted to inform you the problem was When Cisco Unity transcodes wave formats, it uses Microsoft Windows ACM (Audio Compression

Manager) to call into the third-party G.729a codec. When multiple threads call into the Windows ACM

function AcmStreamConvert() at the same time, they can conflict with one another and generate errors,

causing callers to hear dead air or the reorder tone. Restarting the Cisco Unity server clears the

corruption in Windows ACM temporarily, but it does not prevent the problem from reoccurring.

An application-level workaround, an optional registry setting, makes Windows ACM globally

thread-safe. To enable the registry setting, do the procedure, To enable the

ForceGlobalAcmThreadSafety registry setting.

A good indication are errors logged in the Application log in the Event Viewer listing Component Miu: Thread 0x had a Failure on Port X in AvWav.

Thanks again for your help!

Brian DeLuca

Redrock Communications

Las Vegas

Gold

Re: No audio when connected to Unity

Yeah there is a defect in 3.1(5) where ACM thread safety is disabled:

http://www.cisco.com/cgi-bin/bugtool/onebug.pl?bugid=CSCdz15442

There was a field alert on it a while back:

http://www.cisco.com/en/US/products/hw/voiceapp/ps967/products_field_notice09186a008010a6dc.shtml

It's fixed and will be in 3.1(6) code. Also in 3.1(6) and 4.0(1) we move to a new g.729a codec all together which adds stability.

Thanks,

Keith

Gold

Re: No audio when connected to Unity

This is most likely a routing issue of some sort. The voice is transported using RTP/UDP. Since it is not connect oriented it is possible to have one-way voice. Do you have a router between the phone and Unity? Do all phones have the problem? Can you ping the phone from Unity?

A sniffer trace is your best tool to get to the root of these types of issues.

Hope that helps,

Keith

132
Views
5
Helpful
5
Replies
CreatePlease to create content