Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

No dialer command under ISDN BRI interface

Hi all,

I have a 2901 router voice bundle with 4 ISDN BRI ports and would like to have them bundled under Dialer1 interface. Unfortunately it doesn't give me option for Dialer command under BRI interface as expected. 

router(config-if)#int bri0/0/0
router(config-if)#dia
router(config-if)#dia
                         ^
% Invalid input detected at '^' marker.

router(config-if)#dialer
                         ^
% Invalid input detected at '^' marker.

router(config-if)#

 

I assume it's down to the UC license installed on the device but not sure. Does the ISDN BRI interface behave in different way under this license?

Pasting portion of "show ver" as well.

Cisco CISCO2901/K9 (revision 1.0) with 479232K/45056K bytes of memory.
Processor board ID 
2 Gigabit Ethernet interfaces
4 ISDN Basic Rate interfaces
1 terminal line
DRAM configuration is 64 bits wide with parity enabled.
255K bytes of non-volatile configuration memory.
250880K bytes of ATA System CompactFlash 0 (Read/Write)


License Info:

License UDI:

-------------------------------------------------
Device#   PID                   SN
-------------------------------------------------
*0        CISCO2901/K9          

 

Technology Package License Information for Module:'c2900'

-----------------------------------------------------------------
Technology    Technology-package           Technology-package
              Current       Type           Next reboot
------------------------------------------------------------------
ipbase        ipbasek9      Permanent      ipbasek9
security      None          None           None
uc            uck9          Permanent      uck9
data          None          None           None

Configuration register is 0x2102

Everyone's tags (1)
7 REPLIES
VIP Purple

Hi,  I do not think there is

Hi, 

 

I do not think there is any related to licnese.

 

Can u try creating interface Dialer first and then, issue the command under bri interface?

 

regds,

aman

New Member

Hi Aman,     There's Dialer1

Hi Aman,

     There's Dialer1 interface already created , see the config below.

 

service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
!
aaa new-model
!
!
aaa authentication login no-auth none
!
aaa session-id common
network-clock-participate wic 0
network-clock-participate wic 1
!
ip cef
!
no ipv6 cef
multilink bundle-name authenticated
!
isdn switch-type basic-net3
isdn voice-call-failure 0
!
voice-card 0
!
hw-module pvdm 0/0
!
redundancy
!
interface Embedded-Service-Engine0/0
 no ip address
 shutdown
!
interface GigabitEthernet0/0
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 ip address 10.1.1.1 255.255.255.252
 duplex auto
 speed auto
!
interface BRI0/0/0
 no ip address
 isdn switch-type basic-net3
 isdn point-to-point-setup
!
interface BRI0/0/1
 no ip address
 isdn switch-type basic-net3
 isdn point-to-point-setup
!
interface BRI0/1/0
 no ip address
 isdn switch-type basic-net3
 isdn point-to-point-setup
!
interface BRI0/1/1
 no ip address
 isdn switch-type basic-net3
 isdn point-to-point-setup
!
interface Dialer1
 description ISDN Dialer inband
 no ip address
 encapsulation ppp
 dialer in-band
 dialer-group 1
 no cdp enable
!
ip forward-protocol nd
!
no ip http server
ip http authentication local
no ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/1 10.1.1.2
!
control-plane
!
!
voice-port 0/0/0
!
voice-port 0/0/1
!
voice-port 0/1/0
!
voice-port 0/1/1
 !
 !
 !
!
!
!
mgcp profile default
!
!
!
!
!
gatekeeper
 shutdown
!
line con 0
 exec-timeout 15 0
line aux 0
 exec-timeout 15 0
line 2
 exec-timeout 15 0
 no activation-character
 no exec
 transport preferred none
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
 stopbits 1
line vty 0 4
 transport input ssh
line vty 5 15
 transport input ssh
!
scheduler allocate 20000 1000
!
end

VIP Purple

Hi, can u share the exact IOS

Hi,

 

can u share the exact IOS version along with ouput by doing ? under int bri 0/0/0?

 

regds,

aman

New Member

Hi,          Snippet of "sh

Hi,

          Snippet of "sh ver" with IOS version is below:

router#show ver
Cisco IOS Software, C2900 Software (C2900-UNIVERSALK9-M), Version 15.2(4)M5, RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2013 by Cisco Systems, Inc.
Compiled Fri 13-Sep-13 14:59 by prod_rel_team

ROM: System Bootstrap, Version 15.0(1r)M16, RELEASE SOFTWARE (fc1)

router uptime is 2 days, 21 hours, 47 minutes
System returned to ROM by reload at 16:48:03 UTC Mon Aug 18 2014
System restarted at 16:50:01 UTC Mon Aug 18 2014
System image file is "flash0:c2900-universalk9-mz.SPA.152-4.M5.bin"
Last reload type: Normal Reload
Last reload reason: Reload Command

 

The output of trying to type dialer command is in the initial post, I'm also pasting all available commands under bri0/0/0.

 

router(config-if)#int bri0/0/0
router(config-if)#?
Interface configuration commands:
  aaa                     Authentication, Authorization and Accounting.
  access-expression       Build a bridge boolean access expression
  arp                     Set arp type (arpa, probe, snap), timeout, log
                          options or packet priority
  authentication          Auth Manager Interface Configuration Commands
  autodetect              Autodetect Encapsulations on Serial interface
  bandwidth               Set bandwidth informational parameter
  bgp-policy              Apply policy propagated by bgp community string
  bridge-group            Transparent bridging interface parameters
  carrier-delay           Specify delay for interface transitions
  cdp                     CDP interface subcommands
  clns                    CLNS interface subcommands
  clock                   Configure serial interface clock
  cwmp                    Configure CPE WAN Management Protocol(CWMP) on this
                          interface
  dampening               Enable event dampening
  default                 Set a command to its defaults
  delay                   Specify interface throughput delay
  description             Interface specific description
  dot1q                   dot1q interface configuration commands
  dot1x                   Interface Config Commands for IEEE 802.1X
  down-when-looped        Force looped serial interface down
  encapsulation           Set encapsulation type for an interface
  ethernet                Ethernet interface parameters
  exit                    Exit from interface configuration mode
  flow-sampler            Attach flow sampler to the interface
  full-duplex             Configure full-duplex operational mode
  h323-gateway            Configure H323 Gateway
  half-duplex             Configure half-duplex and related commands
  help                    Description of the interactive help system
  history                 Interface history histograms - 60 second, 60 minute
                          and 72 hour
  hold-queue              Set hold queue depth
  ip                      Interface Internet Protocol config commands
  iphc-profile            Configure IPHC profile
  ipv6                    IPv6 interface subcommands
  isdn                    ISDN Interface configuration commands
  isis                    IS-IS commands
  iso-igrp                ISO-IGRP interface subcommands
  keepalive               Enable keepalive
  line-power              Provide power on the line.
  llc2                    LLC2 Interface Subcommands
  load-interval           Specify interval for load calculation for an
                          interface
  logging                 Configure logging for interface
  loopback                Configure internal loopback on an interface
  mab                     MAC Authentication Bypass Interface Config Commands
  mac-address             Manually set interface MAC address
  macro                   Command macro
  metadata                Metadata Application
  mop                     DEC MOP server commands
  mtu                     Set the interface Maximum Transmission Unit (MTU)
  netbios                 Use a defined NETBIOS access list or enable
                          name-caching
  network-clock-priority  Configure clock source priority
  no                      Negate a command or set its defaults
  ntp                     Configure NTP
  ospfv3                  OSPFv3 interface commands
  pulse-time              Force DTR low during resets
  rate-limit              Rate Limit
  redundancy              RG redundancy interface config
  routing                 Per-interface routing configuration
  sdllc                   Configure SDLC to LLC2 translation
  serial                  serial interface commands
  service-policy          Configure CPL Service Policy
  shutdown                Shutdown the selected interface
  smds                    Modify SMDS parameters
  snapshot                Configure snapshot support on the interface
  snmp                    Modify SNMP interface parameters
  source                  Get config from another source
  tarp                    TARP interface subcommands
  timeout                 Define timeout values for this interface
  topology                Configure routing topology on the interface
  transmit-interface      Assign a transmit interface to a receive-only
                          interface
  trunk-group             Configure interface to be in a trunk group
  tx-ring-limit           Configure PA level transmit ring limit
  vpdn                    Virtual Private Dialup Network
  vrf                     VPN Routing/Forwarding parameters on the interface
  waas                    WAN Optimization

router(config-if)#

 

VIP Purple

Hi, I tired to find out if

Hi,

 

I tired to find out if any bug is associated withexisting  IOS but could not get anything.

 

Suggest opening TAC case for further help.

 

regds,

aman

New Member

Hi,        Thanks, will try.

Hi, 

       Thanks, will try. Let's see what Cisco says.

Regards

Jozef

VIP Purple

Hi, I tried searching on

Hi,

 

I tried searching on different ISR G2 routers but could not find dialer command.

definitely,we are missing something .

 

Please do update if u open TAC case.

regds,

aman

92
Views
0
Helpful
7
Replies