Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

no ring-back tone

CCM 4.1.3SR1 and voice gateway PRI to PSTN.

1. Can make outbound calls, working fine

2. can make inbound did calls, but outside caller couldn't hear ringback tone. and if answer the call, can't hear each other.

3. Telco said that telco is expecting ringback from B channel. CM/VG needs to give out ringback through B channel. I don't quite believe that.

Any clues, thanks!!

5 REPLIES
Green

Re: no ring-back tone

Which protocol you are using between CCM and GW?

"Can make inbound did calls, but outside caller couldn't hear ringback tone. and if answer the call, can't hear each other"

Check MGCP CRCX message if using MGCP| Check OLC messages for H245 if using H323 to see which IP address the GW is using to stream audio, and try an extended ping from the interface.

Try using bind commands.

Check this good reference:

http://www.cisco.com/en/US/tech/tk652/tk653/technologies_tech_note09186a0080111b80.shtml

http://www.cisco.com/en/US/tech/tk1077/technologies_tech_note09186a0080094c33.shtml

Gonzalo

New Member

Re: no ring-back tone

Is there a firewall between the voice gateway and your callmanagers?

Add this command on your voice gateway:

ip tcp path-mtu-discovery

This will allow the call to connect end to end.

For your ringback only use 'progress_ind setup enable 3'. If you have 'progress_ind alert enable 8' configured on your Voip peer remove it.

Let me know if this works for you.

New Member

Re: no ring-back tone

1.there is no firewall in between

2.since it is mgcp there is no voip peer, where do I configure 'progress_ind setup enable 3'

3. MGCP CRCX, where is that?

Thanks

New Member

Re: no ring-back tone

I had exact same problem at one of my customers. They were using H323 and there was a FWSM between CCM and the voice gateway.

If you are using MGCP then what I posted previous will not be what you looking for.

New Member

Re: no ring-back tone

update,

Bring the telco guy in to test PRIs, and then everything is working.

off course telco guy keep saying "he didn't change anything"

Thanks!!

365
Views
0
Helpful
5
Replies