Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

no SOAPAction header - RisPort Issues

Hi,

I am trying to extract phone details using SelectCmDevice but i am getting response as:

<soapenv:Fault>

<faultcode xmlns:ns1="http://xml.apache.org/axis/">ns1:Client.NoSOAPAction</faultcode>

<faultstring>no SOAPAction header!</faultstring>

</soapenv:Fault>

I tried including Soap Action in Soap Header of Soap Envelope and tried including Soap Action in HTTP request too, but in vain.

My request is as follows :

POST /axl/ HTTP/1.0

Host:20.152.16.66

Authorization: Basic Y2NtYWRtaW5pc3RyYXRvcjpub3Q0dTJj

Accept: application/soap+xml, text/*

Content-type: text/xml;charset=utf-8

SOAPAction: "http://schemas.cisco.com/ast/soap/action/#RisPort#SelectCmDevice"

Expect: 100-continue

Content-length:1422

<?xml version="1.0" encoding="utf-8"?><soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/" xmlns:soapenc="http://schemas.xmlsoap.org/soap/encoding/" xmlns:tns="http://schemas.cisco.com/ast/soap/" xmlns:types="http://schemas.cisco.com/ast/soap/encodedTypes" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema"><soap:Header> <soap:Action>"http://schemas.cisco.com/ast/soap/action/#RisPort#SelectCmDevices"</soap:Action><tns:AstHeader id="id1"> <SessionId xsi:type="xsd:string">1234-20060201020721</SessionId></tns:AstHeader></soap:Header> <soap:Body soap:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"><tns:SelectCmDevice> <CmSelectionCriteria href="#id1"/></tns:SelectCmDevice><tns:CmSelectionCriteria id="id1" xsi:type="tns:CmSelectionCriteria"> <MaxReturnedDevices xsi:type="xsd:unsignedInt">10</MaxReturnedDevices> <Class xsi:type="tns:DeviceClass">Phone</Class> <Model xsi:type="xsd:unsignedInt">255</Model> <Status xsi:type="tns:CmDevRegStat">Any</Status> <SelectBy xsi:type="tns:CmSelectBy">Name</SelectBy> <SelectItems href="#id2"/> </tns:CmSelectionCriteria><soapenc:Array id="id2" soapenc:arrayType="tns:SelectItem[1]"> <Item href="#id3"/><Item xsi:null="1"/></soapenc:Array><tns:SelectItem id="id3" xsi:type="tns:SelectItem"> <Item xsi:type="xsd:string"></Item></tns:SelectItem> </soap:Body></soap:Envelope>

Please help me how to resolve this problem.

1 REPLY
New Member

Re: no SOAPAction header - RisPort Issues

589
Views
0
Helpful
1
Replies
CreatePlease to create content