Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Not sending out "Calling" digit number in full

When a VoIP extention of 29350401 calling a public number of 0162200700, I was told that I did not send out the full digit number of the calling number, ie "29350401".

May I know why ? This is because I need to send out the full digit to my PSTN departmentfor CDR purpose. Can you please help how I can send out all the full digit number ?

Below is the ISDN q921 and q931 debug:

Feb 11 16:31:23.963: ISDN Se0:15: TX -> RRp sapi = 0 tei = 0 nr = 32

Feb 11 16:31:23.967: ISDN Se0:15: RX <- RRf sapi = 0 tei = 0 nr = 101

Feb 11 16:31:33.963: ISDN Se0:15: RX <- RRp sapi = 0 tei = 0 nr = 101

Feb 11 16:31:33.963: ISDN Se0:15: TX -> RRf sapi = 0 tei = 0 nr = 32

Feb 11 16:31:39.607: ISDN Se0:15: overriding plan/type for 0162200700, isdn/unkn

own to isdn/subscriber

Feb 11 16:31:39.607: ISDN Se0:15: overriding plan/type for 29350401, unknown/unk

nown to isdn/subscriber

Feb 11 16:31:39.607: ISDN Se0:15: overriding plan/type for 0162200700, unknown/u

nknown to isdn/subscriber

Feb 11 16:31:39.611: ISDN Se0:15: TX -> INFOc sapi = 0 tei = 0 ns = 101 nr =

32 i = 0x0802021505A104038090A31803A983816C0A00C13239333530343031700BC13031363

2323030373030

Feb 11 16:31:39.611: SETUP pd = 8 callref = 0x0215

Feb 11 16:31:39.611: Sending Complete

Feb 11 16:31:39.611: Bearer Capability i = 0x8090A3

Feb 11 16:31:39.611: Channel ID i = 0xA98381

Feb 11 16:31:39.611: Calling Party Number i = 0x00C1, '29350401', Plan:U

nknown, Type:Unknown

Feb 11 16:31:39.611: Called Party Number i = 0xC1, '0162200700', Plan:IS

DN, Type:Subscriber(local)

Feb 11 16:31:39.623: ISDN Se0:15: RX <- RRr sapi = 0 tei = 0 nr = 102

Feb 11 16:31:39.639: ISDN Se0:15: RX <- INFOc sapi = 0 tei = 0 ns = 32 nr =

102 i = 0x08028215021803A98381

Feb 11 16:31:39.639: CALL_PROC pd = 8 callref = 0x8215

Feb 11 16:31:39.639: Channel ID i = 0xA98381

Feb 11 16:31:39.643: ISDN Se0:15: TX -> RRr sapi = 0 tei = 0 nr = 33

Feb 11 16:31:44.159: ISDN Se0:15: RX <- INFOc sapi = 0 tei = 0 ns = 33 nr =

102 i = 0x08028215011E028488

Feb 11 16:31:44.159: ALERTING pd = 8 callref = 0x8215

Feb 11 16:31:44.159: Progress Ind i = 0x8488 - In-band info or appropria

te now available

Feb 11 16:31:44.163: ISDN Se0:15: TX -> RRr sapi = 0 tei = 0 nr = 34

Feb 11 16:31:47.143: ISDN Se0:15: TX -> INFOc sapi = 0 tei = 0 ns = 102 nr =

34 i = 0x080202154508028090

Feb 11 16:31:47.143: DISCONNECT pd = 8 callref = 0x0215

Feb 11 16:31:47.143: Cause i = 0x8090 - Normal call clearing

Feb 11 16:31:47.151: ISDN Se0:15: RX <- RRr sapi = 0 tei = 0 nr = 103

Feb 11 16:31:47.183: ISDN Se0:15: RX <- INFOc sapi = 0 tei = 0 ns = 34 nr =

103 i = 0x080282154D

Feb 11 16:31:47.183: RELEASE pd = 8 callref = 0x8215

Feb 11 16:31:47.183: ISDN Se0:15: TX -> RRr sapi = 0 tei = 0 nr = 35

Feb 11 16:31:47.187: ISDN Se0:15: TX -> INFOc sapi = 0 tei = 0 ns = 103 nr =

35 i = 0x080202155A

Feb 11 16:31:47.187: RELEASE_COMP pd = 8 callref = 0x0215

Below is the configuration on the PSTN gateway:

AS5300#sh run

Building configuration...

Current configuration:

!

! NVRAM config last updated at 15:45:03 UTC Wed Feb 11 2004

!

version 12.1

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname AS5300

!

enable password xxxxx

!

username all

!

!

resource-pool disable

!

!

!

!

!

ip subnet-zero

no ip domain-lookup

!

mgcp package-capability trunk-package

mgcp default-package trunk-package

isdn switch-type primary-net5

mta receive maximum-recipients 0

!

!

controller E1 0

clock source line primary

pri-group timeslots 1-31

!

controller E1 1

clock source line secondary 1

!

controller E1 2

clock source line secondary 2

!

controller E1 3

clock source line secondary 3

!

!

voice-port 0:D

cptone MY

timeouts interdigit 2

!

!

dial-peer voice 4 pots

destination-pattern .T

direct-inward-dial

port 0:D

!

dial-peer voice 6 voip

destination-pattern 7118031.

session target ipv4:192.100.98.70

ip precedence 5

!

dial-peer voice 5 voip

destination-pattern 293504..

session target ipv4:192.100.98.70

ip precedence 5

!

num-exp 4.. 293504..

!

!

interface Loopback0

ip address 192.100.254.3 255.255.255.0

!

interface Ethernet0

no ip address

shutdown

!

interface Serial0

no ip address

shutdown

no fair-queue

clockrate 2015232

!

interface Serial1

no ip address

shutdown

no fair-queue

clockrate 2015232

!

interface Serial2

no ip address

shutdown

no fair-queue

clockrate 2015232

!

interface Serial3

no ip address

shutdown

no fair-queue

clockrate 2015232

!

interface Serial0:15

no ip address

ip mroute-cache

isdn switch-type primary-net5

isdn incoming-voice modem

isdn map address . plan isdn type subscriber

isdn bchan-number-order ascending

isdn sending-complete

no cdp enable

!

interface FastEthernet0

ip address 192.100.98.71 255.255.255.0

duplex auto

speed auto

!

router ospf 1

log-adjacency-changes

network 0.0.0.0 255.255.255.255 area 0

!

ip classless

no ip http server

!

!

!

line con 0

transport input none

line aux 0

line vty 0 4

exec-timeout 60 0

password xxxx

login

!

end

AS5300#

1 REPLY

Re: Not sending out "Calling" digit number in full

You ARE sending out the full number.

Feb 11 16:31:39.611: Calling Party Number i = 0x00C1, '29350401', Plan:Unknown, Type:Unknown

Tells me that the call made out by the gateway sent exactly what you thought you were sending. DO they want you to send the whole number including Area (STD). If so then apply the a mask to the gateway configuration to prefix the Area (STD) code to outgoing calls. Something like 01XXXXXXXX

I used both Area and STD to mean the same thing as I'm not sure which term you would use.

Paul

110
Views
0
Helpful
1
Replies
CreatePlease to create content