Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

ONE WAY AUDIO WITH A CISCO 2800

I have a Cisco 2800 like a voice GW, making a Trunk SIP with a Asterisk PBX. I don't know the Asterisk configuration. My GW is used only to external calls, using a PRI port.  We have problems with calls since 10 days ago:  I can make a call but the called can't hear me and I hear him.

I need some help about this problem. I attach logs with differents debugs
.

This is the 2800 configuration:

_CAT_CONTAC_CENTER#sh run
Building configuration...


Current configuration : 8823 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname _CAT_CONTAC_CENTER
!
boot-start-marker
boot-end-marker
!
card type e1 0 0
logging buffered 51200 warnings

no aaa new-model
network-clock-participate wic 0
network-clock-select 1 E1 0/0/0
network-clock-select 2 E1 0/0/1
dot11 syslog
!
!
ip cef
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
isdn switch-type primary-net5
!
!
trunk group  E1-0/0/0-1
!
voice-card 0
dspfarm
dsp services dspfarm
!
!
voice rtp send-recv
!
voice service pots
!
voice service voip
allow-connections sip to sip
sip
  bind control source-interface GigabitEthernet0/0
  bind media source-interface GigabitEthernet0/0
!
!
voice class codec 1

codec preference 1 gsmamr-nb
codec preference 2 g711ulaw
codec preference 3 g729br8
codec preference 4 ilbc
codec preference 5 g723ar53

!
!
!
!
!
!
controller E1 0/0/0
pri-group timeslots 1-31
!
controller E1 0/0/1
pri-group timeslots 1-31
!
!
!
!
!
interface GigabitEthernet0/0
description Conexion al Switch

ip address XXXXX 255.255.255.0
ip access-group Control-Sip-desde-Asteriskin
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0:15
no ip address
encapsulation hdlc
isdn switch-type primary-net5
isdn incoming-voice voice
no isdn outgoing display-ie
trunk-group E1-0/0/0-1
no cdp enable
!
interface Serial0/0/1:15
no ip address
encapsulation hdlc
isdn switch-type primary-net5
isdn incoming-voice voice
no isdn outgoing display-ie
trunk-group E1-0/0/0-1
no cdp enable
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 XXXX
!
!
no ip http server
no ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip access-list extended Control
permit udp host XXXX host xxxx eq 5060
permit udp host XXXX host xxxx eq 80
permit ip any any
ip access-list extended Control-Sip-desde-Asterisk-Nuevo-acceso
remark Permitir Trafico SIP desde la centralita Asterisk
permit udp host XXXX host XXXX eq 5060
permit udp host XXXX host XXXX eq 5060
permit udp host XXXX host XXXX eq 80

remark Denegar Otros Intentos de Conexion SIP
deny   udp any host xxxx eq 5060 log
deny   udp any xxxx 0.0.0.3 eq 5060 log
remark Permitir Acceso Gestion
permit ip any any log
!
access-list 80 permit XXXX
!
!
!
!
!
!
control-plane
!
!
!
voice-port 0/0/0:15
cptone ES
timeouts call-disconnect 0
timeouts wait-release 1
!
voice-port 0/0/1:15
cptone ES
timeouts call-disconnect 0
timeouts wait-release 1
!
!
!
!
!
dial-peer voice 1 pots
trunkgroup E1-0/0/0-1
voice cut-through alert
description XX
destination-pattern .........
progress_ind alert enable 8
progress_ind progress enable 8
incoming called-number .
clid strip
direct-inward-dial
forward-digits all
!
dial-peer voice 2 voip
description Llamadas internas VOIP Asterisk
shutdown
destination-pattern ....
voice-class codec 1
session protocol sipv2
session target ipv4:XXXXX:5060
session transport udp
no vad
!
!

Everyone's tags (3)
1 REPLY
Cisco Employee

Re: ONE WAY AUDIO WITH A CISCO 2800

Issue is being troubleshot via:

https://supportforums.cisco.com/message/3211360#3211360

Locking this thread as a duplicate.

2743
Views
0
Helpful
1
Replies
CreatePlease to create content