Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

one way conversation problem

Hi I have a problem with a VoIP point to point network.I have 2 3600 each side connecting into a PBX over E1 PRI and qsig.I have least call routing working so that if either site initiate a call to one another the call goes over the leased line and breaks out at the E1 PRI (sites located internationally)The problem is when someone calls from an external location to a phone which is forwarded over the leased line to the other site, I can hear them but they can't hear me.This only happens one way ie when the call is initiated from a forwarded phone from the other site the conversation is fine.I have LLQ configured on the 256k link.I don't have PPP interleaving configured.Can anyone please shed some light on this for me please.Thanks in advance.

9 REPLIES
Silver

Re: one way conversation problem

Would need to see the configs and Q931 debugs to confirm, but generally one way voice is caused by an inconsistent source or destination IP address. First thing to try is to bind the H323 source to a specific interface - use the interface command 'h323-gateway voip bind srcaddr ' command to force the router to source all signalling and RTP from this interface. Point your dial peers to these addresses.

I'm not sure why you would only one way voice on certain calls but doing the above is the first step in making the configs consistent. If this does not help post the configs and debug isdn q931 traces.

New Member

Re: one way conversation problem

Hi, yes I'm thinking that way too but the 'h323-gaetway voip bind' command is not working I'm afraid.I'm working on those debugs but here are the configs.

ROUTER 1

version 12.2

service timestamps debug datetime msec localtime

service timestamps log datetime msec localtime

service password-encryption

!

hostname DL_HOW_3640

!

enable secret xxxxxx

enable password xxxxx

!

clock timezone gmt 0

clock summer-time IRL recurring last Sun Mar 2:00 last Sun Oct 2:00

voice-card 1

!

ip subnet-zero

!

!

!

!class-map match-all VOIP

match access-group 100

class-map match-all VOIP_Control

match access-group 101

!

!

policy-map LLQ

class VOIP

priority 160

class VOIP_Control

bandwidth 8

class class-default

fair-queue

!

isdn switch-type primary-qsig

isdn voice-call-failure 0

call rsvp-sync

voice rtp send-recv

!

!

!

voice class h323 1

!

!

!

!

controller E1 1/0

framing NO-CRC4

pri-group timeslots 1-31

!

!

!

interface Ethernet0/0

ip address 10.160.254.249 255.255.0.0

no ip unreachables

ip nat outside

half-duplex

!

interface Serial0/0

no ip address

no ip mroute-cache

shutdown

no fair-queue

!

interface Serial0/1

description ###### Leased Line To ######

bandwidth 256

ip address 172.16.2.1 255.255.255.0

ip nat inside

no ip mroute-cache

service-policy output LLQ

!

interface Serial1/0:15

no ip address

no logging event link-status

isdn switch-type primary-qsig

isdn protocol-emulate network

isdn incoming-voice voice

no isdn T309-enable

no cdp enable

!

ip nat inside source static 10.170.1.12 10.160.254.1 extendable

ip classless

ip route 0.0.0.0 0.0.0.0 10.160.1.190

ip route 10.170.0.0 255.255.0.0 10.160.1.190 240

ip route x.x.x.x 255.255.255.0 10.160.254.2

ip route x.x.x.x 255.255.0.0 172.16.2.2

ip route x.x.x.x 255.255.255.0 10.160.1.190

no ip http server

ip pim bidir-enable

!

access-list 100 permit udp any any range 16384 32776

access-list 101 permit tcp any eq 1720 any

access-list 101 permit tcp any any eq 1720

access-list 115 deny udp any any eq tftp

access-list 115 permit tcp any host 10.160.1.182 eq 135

access-list 115 permit tcp any host 10.253.1.2 eq 135

access-list 115 permit tcp any host 10.170.1.23 eq 135

access-list 115 deny tcp any any eq 135

access-list 115 permit udp any host 10.160.1.182 eq 135

access-list 115 permit udp any host 10.253.1.2 eq 135

access-list 115 permit udp any host 10.170.1.23 eq 135

access-list 115 deny udp any any eq 135

access-list 115 deny tcp any any eq 139

access-list 115 deny tcp any any eq 445

access-list 115 deny tcp any any eq 593

access-list 115 deny tcp any any eq 4444

access-list 115 permit ip any any

arp 10.160.1.190 0000.0102.0300 ARPA

snmp-server community public RO

!

voice-port 1/0:15

cptone IE

timeouts interdigit 2

!

dial-peer cor custom

!

!

!

dial-peer voice 1000 pots

destination-pattern 35..

direct-inward-dial

port 1/0:15

forward-digits all

!

dial-peer voice 1001 pots

destination-pattern 36..

direct-inward-dial

port 1/0:15

forward-digits all

!

dial-peer voice 900 voip

destination-pattern 7...

progress_ind setup enable 3

session target ipv4:172.16.2.2

!

dial-peer voice 908 voip

destination-pattern 18...........

progress_ind setup enable 3

session target ipv4:172.16.2.2

!

dial-peer voice 1016 pots

destination-pattern 16

port 1/0:15

forward-digits extra

prefix 90

!

dial-peer voice 10003 pots

!

dial-peer voice 90044 voip

destination-pattern 8T

progress_ind setup enable 3

session target ipv4:172.16.2.2

!

dial-peer voice 8888 voip

destination-pattern 87...

session target ipv4:172.16.2.2

!

banner exec ^C

****************************************************************************************************************************

UNAUTHORISED ACCESS STRICTLY PROHIBITED

****************************************************************************************************************************

^C

!

line con 0

exec-timeout 5 0

password xxxx

login

line aux 0

exec-timeout 5 0

password xxxxx

login

line vty 0 4

exec-timeout 0 0

password xxxxx

login

ROUTER 2

Current configuration : 4081 bytes

!

version 12.2

service timestamps debug datetime msec localtime

service timestamps log datetime msec localtime

service password-encryption

!

hostname DL_MAN_3640

!

enable secret 5

enable password 7

!

clock timezone gmt 0

clock summer-time IRL recurring last Sun Mar 2:00 last Sun Oct 2:00

voice-card 1

!

ip subnet-zero

!

!

!

!

class-map match-all VOIP

match access-group 100

class-map match-all VOIP_Control

match access-group 101

!

!

policy-map LLQ

class VOIP

priority 160

class VOIP_Control

bandwidth 8

class class-default

fair-queue

!

isdn switch-type primary-qsig

isdn voice-call-failure 0

call rsvp-sync

voice rtp send-recv

!

!

!

voice class h323 1

call start slow

!

!

!

!

controller E1 1/0

framing NO-CRC4

pri-group timeslots 1-31

!

controller E1 2/0

!

!

!

interface Ethernet0/0

ip address 10.170.1.1 255.255.0.0

half-duplex

!

interface Serial0/0

description ###### Leased Line To ######

bandwidth 256

ip address 172.16.2.2 255.255.255.0

no ip mroute-cache

service-policy output LLQ

!

interface Serial1/0:15

no ip address

no logging event link-status

isdn switch-type primary-qsig

isdn incoming-voice voice

isdn T309-enable

isdn bchan-number-order ascending

no cdp enable

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.170.1.73

ip route 10.10.10.0 255.255.255.0 10.170.1.3

ip route 10.40.0.0 255.255.0.0 10.170.1.6

ip route 10.153.0.0 255.255.0.0 10.170.1.73

ip route 10.160.0.0 255.255.0.0 10.170.1.73 240

ip route 10.161.0.0 255.255.0.0 172.16.2.1

ip route 10.161.0.0 255.255.0.0 10.170.1.73 240

ip route 10.230.0.0 255.255.0.0 10.170.1.73

ip route 57.12.244.33 255.255.255.255 10.160.254.2

ip route 57.12.244.34 255.255.255.255 10.160.254.2

ip route 57.202.0.0 255.255.0.0 10.170.1.4

ip route 172.31.0.0 255.255.0.0 10.170.1.5

ip route 192.168.110.204 255.255.255.255 10.160.254.249

no ip http server

ip pim bidir-enable

!

access-list 100 permit udp any any range 16384 32776

access-list 101 permit tcp any eq 1720 any

access-list 101 permit tcp any any eq 1720

access-list 115 deny udp any any eq tftp

access-list 115 permit tcp any host 10.160.1.182 eq 135

access-list 115 permit tcp any host 10.253.1.2 eq 135

access-list 115 permit tcp any host 10.170.1.23 eq 135

access-list 115 deny tcp any any eq 135

access-list 115 permit udp any host 10.160.1.182 eq 135

access-list 115 permit udp any host 10.253.1.2 eq 135

access-list 115 permit udp any host 10.170.1.23 eq 135

access-list 115 deny udp any any eq 135

access-list 115 deny tcp any any eq 139

access-list 115 deny tcp any any eq 445

access-list 115 deny tcp any any eq 593

access-list 115 deny tcp any any eq 4444

access-list 115 permit ip any any

arp 10.170.1.73 0008.0901.0200 ARPA

!

voice-port 1/0:15

cptone GB

timeouts interdigit 2

!

dial-peer cor custom

!

!

!

dial-peer voice 10 pots

destination-pattern 7...

direct-inward-dial

port 1/0:15

forward-digits all

!

dial-peer voice 100 voip

destination-pattern 35..

progress_ind setup enable 3

session target ipv4:172.16.2.1

!

dial-peer voice 101 voip

destination-pattern 36..

progress_ind setup enable 3

session target ipv4:172.16.2.1

!

dial-peer voice 18 pots

destination-pattern 18

port 1/0:15

forward-digits extra

prefix 9

!

dial-peer voice 116 voip

destination-pattern 16.T

progress_ind setup enable 3

session target ipv4:172.16.2.1

!

dial-peer voice 90044 pots

destination-pattern 8

port 1/0:15

forward-digits extra

prefix 90044

!

dial-peer voice 8888 pots

destination-pattern 87...

direct-inward-dial

port 1/0:15

forward-digits 4

!

banner exec ^CC

****************************************************************************************************************************

UNAUTHORISED ACCESS STRICTLY PROHIBITED

****************************************************************************************************************************

^C

!

line con 0

exec-timeout 5 0

password 7

login

line aux 0

exec-timeout 5 0

password 7

login

line vty 0 4

exec-timeout 0 0

password 7

login

!

end

Thanks

Silver

Re: one way conversation problem

configs look OK, you should be able to use the H323 bind command on the serial interfaces - did it give any error messages when you entered it ?

The router will by default use the IP address of the interface traffic leaves from as the source address of the voice traffic, so the NAT should not be affecting things here as well.

Will wait for the Q931 traces

New Member

Re: one way conversation problem

hi, no I didn't get any error messages when entering that command.I went and put loopbacks on each router and used the bind command but still no luck.here are the q931 outputs.I noticed a disconnect cause beginning with 82 in the debugs if that hints at something.thanks

*Mar 4 23:04:57.032: ISDN Se1/0:15: RX <- SETUP pd = 8 callref = 0x00FB

*Mar 4 23:04:57.032: Sending Complete

*Mar 4 23:04:57.032: Bearer Capability i = 0x8090A3

*Mar 4 23:04:57.036: Channel ID i = 0xA9839D

*Mar 4 23:04:57.036: Calling Party Number i = 0x01, 0x80, '0863833935', Plan:ISDN, Type:Unknown

*Mar 4 23:04:57.036: Called Party Number i = 0x80, '7325', Plan:Unknown, Type:Unknown

*Mar 4 23:04:57.040: High Layer Compat i = 0x9181

*Mar 4 23:04:57.056: ISDN Se1/0:15: TX -> CALL_PROC pd = 8 callref = 0x80FB

*Mar 4 23:04:57.056: Channel ID i = 0xA9839D

*Mar 4 23:04:57.800: ISDN Se1/0:15: TX -> ALERTING pd = 8 callref = 0x80FB

*Mar 4 23:04:57.800: Progress Ind i = 0x8188 - In-band info or appropriate now available

*Mar 4 23:05:06.068: ISDN Se1/0:15: TX -> DISCONNECT pd = 8 callref = 0x80FB

*Mar 4 23:05:06.068: Cause i = 0x8290 - Normal call clearing

*Mar 4 23:05:06.108: ISDN Se1/0:15: RX <- RELEASE pd = 8 callref = 0x00FB

*Mar 4 23:05:06.112: ISDN Se1/0:15: TX -> RELEASE_COMP pd = 8 callref = 0x80FB

*Mar 4 23:05:31.516: ISDN Se1/0:15: TX -> DISCONNECT pd = 8 callref = 0x80F9

*Mar 4 23:05:31.516: Cause i = 0x8290 - Normal call clearing

*Mar 4 23:05:31.536: ISDN Se1/0:15: RX <- RELEASE pd = 8 callref = 0x00F9

*Mar 4 23:05:31.540: ISDN Se1/0:15: TX -> RELEASE_COMP pd = 8 callref = 0x80F9

****************************************************

*Mar 4 23:00:43.704: ISDN Se1/0:15: RX <- SETUP pd = 8 callref = 0x00FA

*Mar 4 23:00:43.708: Sending Complete

*Mar 4 23:00:43.708: Bearer Capability i = 0x8090A3

*Mar 4 23:00:43.708: Channel ID i = 0xA9839D

*Mar 4 23:00:43.708: Calling Party Number i = 0x01, 0x80, '0863833935', Plan:ISDN, Type:Unknown

*Mar 4 23:00:43.712: Called Party Number i = 0x80, '7325', Plan:Unknown, Type:Unknown

*Mar 4 23:00:43.712: High Layer Compat i = 0x9181

*Mar 4 23:00:43.728: ISDN Se1/0:15: TX -> CALL_PROC pd = 8 callref = 0x80FA

*Mar 4 23:00:43.732: Channel ID i = 0xA9839D

*Mar 4 23:00:44.412: ISDN Se1/0:15: TX -> ALERTING pd = 8 callref = 0x80FA

*Mar 4 23:00:44.412: Progress Ind i = 0x8188 - In-band info or appropriate now available

*Mar 4 23:00:47.440: ISDN Se1/0:15: TX -> CONNECT pd = 8 callref = 0x80FA

*Mar 4 23:00:47.452: ISDN Se1/0:15: RX <- CONNECT_ACK pd = 8 callref = 0x00FA

*Mar 4 23:00:54.592: ISDN Se1/0:15: RX <- DISCONNECT pd = 8 callref = 0x00FA

*Mar 4 23:00:54.596: Cause i = 0x8090 - Normal call clearing

*Mar 4 23:00:54.604: ISDN Se1/0:15: TX -> RELEASE pd = 8 callref = 0x80FA

*Mar 4 23:00:54.616: ISDN Se1/0:15: RX <- RELEASE_COMP pd = 8 callref = 0x00FA

could it be possibly a problem with the pbx? we were having problems with one side in that when trying to call over the leased line and break out on the far side the router wasnt forwarding all the numbers and the pbx had to be configured to throw out a speed dial. is the router stripping some of the call forwarding info the pbx is putting in for external calls perhaps?as far as I know the pbx isnt using En bloc feature

Silver

Re: one way conversation problem

Debugs look OK, as far as I can tell this is for the same call (called number is the same) so if one was from a forwarded phone there is nothing different between the 2 traces. Both calls are enbloc as the sending complete flag is set in the setup message.

Are you able to open a TAC case? This one looks a bit difficult for a daily mail exchange !

New Member

Re: one way conversation problem

yeah I agree unfortunatley I can't open a TAC case.I've tried it also with isdn overlapping etc and all the digits are being sent one by one but still no joy.is there any higher layer debugs I can do during the call? thanks

New Member

Re: one way conversation problem

Let me see if I get this straight: User A, off of router 1, can call User B off of router 2. User B can hear User A, but User A cannot hear User B, correct?

I gotta think it's the NAT configuration. First, it looks like the static mapping is misconfigured. The static mapping maps an address that belongs on the other router's subnet, so the router would never see it. Also, having that NAT there explains the problem. RTP packets from User A get through fine to router 2's ethernet interface, but there is no mechanism to translate User B's RTP back to router 1's ethernet interface.

Setting the H323 source address would fix that. What command have you tried exactly and where in the configuration. The commands you need are..

h323-gateway voip interface

h323-gateway voip bind srcaddr

and these commands should be in the interface configurtation mode on the serial interface. And the ip address should be the ip address on the serial interface you are setting it up on.

The ISDN Q931 is only going to show the connection between the phone (or in this case, the PBX) and the local router. This problem is between the routers. One-way audio problems just about always occur in the IP network. Instead, you should take a look at debug voice rtp packet. This will likely show only Tx messages on router 1 and will show the address that router 2 is trying to reach.

New Member

Re: one way conversation problem

yes but it's only from an external number and when forwarded.also I have created 2 loopbacks(one on each router) and configured the bind command and also added static routes on each router to each loopback network.from the h.323 debugs I can see the source and destination as being these loopback addresses therefore I dont think it's a routing issue.the phones aren't IP phones so the ethernet interfaces shouldn't enter the equation.

New Member

Re: one way conversation problem

When I refered to the ethernet addresses, I was assuming that the H323 was binding to the ethernet interface.

If it is a RTP reachability issue, the easiest way to test it is to run a ping with the extended options from each route. Use the far loopback as the destination and the near loopback as the source. If that works, then RTP sould be going through OK and the problem is somewhere else.

186
Views
0
Helpful
9
Replies
CreatePlease to create content