Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Outgoing calls disconnects on first attempt - MGCP setup

Hi,

I need some help or insight on the ff please:

1. Some of my outgoing calls disconnects on first attempt - this however doesn't happen on all calls (Happens unexpectectedly).

2. I can't hear called party's respond to the call for the first few seconds = this happens on some of the succesfull calls.

3. I at times fail to hear called party at all, even though they claim they could hear me when i retry calling them.

This issue started few weeks ago, everything used to be okay. I have tried the ff with no luck:

- mgcp reset

- shut and unshut the serial port

Below is my site configs (remember, this used to work just fine until few weeks back - no changes were made):

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname RTR1

!

boot-start-marker

boot-end-marker

!

logging message-counter syslog

logging buffered 16384

!

no aaa new-model

memory-size iomem 10

clock timezone SAST 2

network-clock-participate wic 1

network-clock-select 1 E1 0/1/0

!

dot11 syslog

ip source-route

ip cef

!

ip domain name xxxx.net

ip name-server 10.0.0.57

ip name-server 10.0.8.4

no ipv6 cef

multilink bundle-name authenticated

!

!

!

!

isdn switch-type primary-net5

!

voice-card 0

dspfarm

dsp services dspfarm

!

!

voice call send-alert

voice rtp send-recv

!

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

fax protocol cisco

h323

!

!

!

voice class codec 1

codec preference 1 g711ulaw

codec preference 2 g729r8

!

!

controller E1 0/1/0

pri-group timeslots 1-31 service mgcp

!

!

class-map match-any qos_CS2

match ip precedence 2

class-map match-any qos_mail

match access-group 122

class-map match-any qos_voice

match  dscp ef

match protocol rtp

class-map match-any qos_sce

match access-group 125

class-map match-any qos_rdp

match access-group 121

class-map match-any VOICE-SIGNALLING

match protocol mgcp

match protocol skinny

match protocol h323

!

!

policy-map xx-QoS

class qos_voice

    priority 112

   compress header ip rtp

class class-default

    fair-queue

     random-detect

policy-map yy-QoS

class qos_voice

    priority 240

   compress header ip rtp

class VOICE-SIGNALLING

    bandwidth 10

class qos_CS2

    bandwidth 100

   compress header ip tcp

class class-default

    fair-queue

     random-detect

policy-map LS-QoS

class qos_voice

   drop

class class-default

    fair-queue

     random-detect

policy-map Bothas-QoS

class qos_voice

    priority 48

   compress header ip rtp

class VOICE-SIGNALLING

    bandwidth 10

class class-default

    fair-queue

     random-detect

policy-map FB-Qos

class qos_CS2

    bandwidth 100

!

!

interface Serial0/1/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn overlap-receiving

isdn incoming-voice voice

isdn bind-l3 ccm-manager

isdn send-alerting

isdn sending-complete

no cdp enable

!

!

p http server

no ip http secure-server

ip flow-cache timeout active 1

ip flow-export source GigabitEthernet0/0

ip flow-export version 5

ip flow-export destination 10.0.0.224 9996

!

!

access-list 121 permit tcp any any eq 3389

access-list 122 permit tcp any any eq smtp

access-list 125 permit tcp host 10.0.0.54 any time-range Peak

dialer-list 1 protocol ip permit

!

!

voice-port 0/1/0:15

echo-cancel coverage 24

cptone ZA

!

ccm-manager fallback-mgcp

ccm-manager redundant-host 10.x.1.2

ccm-manager mgcp

no ccm-manager fax protocol cisco

ccm-manager music-on-hold

ccm-manager config server 10.0.x.x

ccm-manager config

!

mgcp

mgcp call-agent 10.x.x.x 2427 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp modem passthrough voip mode nse

mgcp ip qos dscp cs3 signaling

mgcp package-capability rtp-package

mgcp package-capability sst-package

mgcp package-capability pre-package

mgcp default-package mt-package

no mgcp package-capability fxr-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp fax t38 inhibit

mgcp rtp payload-type g726r16 static

mgcp bind control source-interface Loopback0

mgcp bind media source-interface Loopback0

!

mgcp profile default

!

sccp local GigabitEthernet0/0

sccp ccm 10.x.x.x identifier 2 priority 2 version 4.1

sccp ccm 10.x.x.x identifier 1 priority 1 version 4.1

sccp

!

sccp ccm group 1

associate ccm 1 priority 1

associate ccm 2 priority 2

associate profile 1 register TRN0013192d73a0

associate profile 2 register MTP0013192d73a0

associate profile 3 register CFB0013192d73a0

!

dspfarm profile 1 transcode

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

codec g729r8

maximum sessions 8

associate application SCCP

!

dspfarm profile 3 conference

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

codec g729r8

codec g729br8

maximum sessions 2

associate application SCCP

!

dspfarm profile 2 mtp

codec g711ulaw

maximum sessions hardware 8

maximum sessions software 250

associate application SCCP

!

!

!

gateway

timer receive-rtp 600

!

!

line con 0

line aux 0

line 66

no activation-character

no exec

transport preferred none

transport input all

transport output all

line vty 0 4

login local

!

scheduler allocate 20000 1000

ntp master 10

ntp update-calendar

time-range Peak

periodic weekdays 6:00 to 17:59

periodic Saturday 7:00 to 15:59

!

end

2 REPLIES

Outgoing calls disconnects on first attempt - MGCP setup

If there's any post relating to this - please attach it hear because i've been searching for over a week with no luck.

Super Bronze

Outgoing calls disconnects on first attempt - MGCP setup

Hi

If there's no change to this gateway then there may be something in between you and the gateway that has changed.

When on a call, pull up the call stats (on a 794x or 796x or similar, press ? twice quickly). If you have lost rx packets, then something is interrupting the RTP stream. Think firewalls, ACLs, etc.

Aaron

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!
523
Views
0
Helpful
2
Replies
CreatePlease to create content