Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Users might experience few discrepancies in Search results. We are working on this on our side. We apologize for the inconvenience it may have caused.
New Member

Phone Behind 831 No Register w/ CM

Interesting situation.

I have a 7940 IP Phone behind a 831 Router. This phone obtains DHCP from a centralized server just fine. It then obtains, via TFTP, it's config file, but it will not register with the primary Subscriber CM. It will only register with the secondary Publisher CM.

KEY POINTS

The phone is on a private 10.x.x.x network, the CallManagers are on a 129.9.x.x network.

If I change the config on the 831 router and place the phone on it's own 129.9.x.x subnet behind the router, it works just fine.

The problem only occurs if all three are true:

1) The phone is on a non 129.9.x.x network

2) The phone is sending TCP packets (UDP works fine)

3) The phone is behind a 831 router

If any of those are not true, the phone registers just fine.

Please note that when the phone does not register, it keeps "retransmitting" the packet. SYN.. SYN.. SYN.. the CallManager keeps sending back ACK's but the phone never sees them.

2 REPLIES
New Member

Re: Phone Behind 831 No Register w/ CM

I have stripped down the config on the 831 router. Here it is. Very basic.

service config

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

enable secret xxxx.

enable password xxxx

!

username all

ip subnet-zero

ip dhcp excluded-address 129.9.99.1

ip dhcp excluded-address 172.16.16.1

!

ip dhcp pool CLIENT

import all

network 172.16.16.0 255.255.255.252

dns-server 129.9.1.238 129.9.145.204 4.2.2.1

netbios-name-server 129.9.1.238

netbios-node-type h-node

domain-name heidrick.hsi

option 150 ip 129.9.1.63

default-router 172.16.16.1

option 160 ip 129.9.1.63

lease 0 2

!

ip audit notify log

ip audit po max-events 100

!

!

!

!

interface Ethernet0

ip address 172.16.16.1 255.255.255.252

hold-queue 100 out

!

interface Ethernet1

ip address 129.9.11.253 255.255.255.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 129.9.11.254

ip http server

!

!

access-list 11 permit 129.9.99.0 0.0.0.255

access-list 100 deny ip any host 129.9.1.64

!

line con 0

exec-timeout 120 0

no modem enable

stopbits 1

line aux 0

stopbits 1

line vty 0 4

exec-timeout 120 0

password xxx

no login

length 0

!

scheduler max-task-time 5000

end

Anonymous
N/A

Re: Phone Behind 831 No Register w/ CM

hi,

Are you able to ping from CM 1 to the phone?

what shows a traceroute?

96
Views
0
Helpful
2
Replies
CreatePlease to create content