Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Phone Trunk

I have a 3845 router with the NM-16ESW module in it. I have the router configured with the subinterfaces for the 3 VLANS. My phone connects, registers with CME and works fine but the workstations that are connected to the Phone go into VLAN 1 in stead of the Data VLAN i built VLAN 2.

interface FastEthernet2/7

switchport access vlan 2

switchport mode trunk

switchport voice vlan 3

mls qos trust dscp

spanning-tree portfast

Any thoughts on why???

5 REPLIES

Re: Phone Trunk

Remove the switchport mode trunk command.

Hope this helps. If so, please rate the post.

Brandon

New Member

Re: Phone Trunk

That didn't work but thanks for the post. I may not have been clear enough. The phone registers and works and the pc that is connected to it trys to attach to VLAN 1 which is my Management VLAN in stead of VLAN 2 which is my DATA network.

Re: Phone Trunk

Is the VLAN configured on the switch?

Brandon

Re: Phone Trunk

Bob,

NM-16ESW should be configured very similar to a 3524 switch.

int fa2/7

switchport mode trunk

switchport trunk encap dot1q

switchport voice vlan 3

switchport trunk native vlan 2

mls qos trust cos

switchport priority extend cos 0

spanning-tree portfast

HTH

New Member

Re: Phone Trunk

That was the right solution I found it last night also thanks man you hit it right on it was a perfect solution

130
Views
0
Helpful
5
Replies
CreatePlease login to create content