Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Popping on Telco POTS line when plugged into a router.

Good day,

I am looking for input on the following problem:

In the beginning everything worked just fine for the last year. Then we moved our corporate offices to a new building.

We immediately had a problem after the move. My Multicast voice setup would now have a loud pop, then silence for a couple of seconds, then a return of the voice feed. This does not occur on a specific time length, but it does occur several times in any 5 minute period. The voice feed is continuous talking, so these pops and silences occur right in the middle of the person speaking. The configurations on the Network equipment had not been modified. In fact we were able to test the situation with two completely different equipment setups. The setup was as follows:

Path A

PLAR ANALOG from TELCO CO --> C2600 FXS Input -->

C2600 Ethernet Output --> C3550 L3 Switch -->

C2600 Ethernet Input --> C2600 FXS Output --> Analog Telephone

Path B

PLAR ANALOG from TELCO CO --> C2600 FXS Input -->

C2600 Serial Output --> C2600 Serial Input -->

C2600 FXS Output --> Analog Telephone

On both paths A and B there is no congestion. In fact I really feel like it is not a network or configuration problem at all. Here is why:

If I unplug the Telco Line and plug straight into a phone there is no popping.

If I use a splitter and plug the Telco line into a shutdown FXS port on Router A or a backup Router B and then plug the other split into an Anolog phone, it begins to pop.

If I power off the router while still set up with the split, the popping goes away.

If I plug the Telco line into an FXO port the popping goes away on the Split off Analog telephone, however we can't get the FXO to pass voice to the multicast group.

In the very beginning we attempted to connect the Telco line into a FXO port. However we were unable to get the port to pass audio to the Multicast group. The trunk showed an active connection, but a show voice dsp was enough to see that for some reason the configuration was not passing track (only 5 packet increment every couple of seconds). Changing to an FXS port solved the problem. Now at this new location we get voice, but the poppong is starting to drive people crazy.

The telco line works as follows. We connect a analog phone to the line and pick up. The phone immediately rings without us dialing anything. A person at the other end picks up and the connection stays up all day. We then inserted the routers into the mix so we could multicast the audio link to several different sites.

Any Ideas? I have pasted some of the config information below.

Matthew

hostname Voice-Input-Router

! This router is configured with the Telco POTS lines plugged into a FXS

! We could also plug them into a FXO if there is a way to get that to work

!

ip subnet-zero

!

no ip domain-lookup

!

ip multicast-routing

call rsvp-sync

!

voice class permanent 1

signal timing oos timeout disabled

signal keepalive 65535

!

interface Loopback0

ip address 172.16.101.1 255.255.255.255

ip pim sparse-dense-mode

!

interface Vif1

ip address 172.16.102.1 255.255.255.0

ip pim sparse-dense-mode

ip igmp static-group 239.100.0.2

ip igmp static-group 239.100.0.3

ip igmp static-group 239.100.0.5

ip igmp static-group 239.100.0.1

!

interface FastEthernet0/0

ip address 172.16.1.10 255.255.255.0

ip pim sparse-dense-mode

speed 100

full-duplex

fair-queue

arp snap

!

interface Serial0/0

shutdown

!

interface Serial0/1

description WAN voice feed

ip address 172.30.0.5 255.255.255.252

ip pim sparse-dense-mode

!

router ospf

!

ip classless

ip pim rp-address 172.16.101.1

!

voice-port 1/0/0

input gain 10

timeouts call-disconnect 3

timeouts wait-release 3

connection trunk 1000

description Voice Channel A

music-threshold -60

!

voice-port 1/0/1

timeouts call-disconnect 3

timeouts wait-release 3

connection trunk 1001

description Voice Channel B

music-threshold -60

!

dial-peer voice 1001 voip

destination-pattern 1001

voice-class permanent 1

session protocol multicast

session target ipv4:239.100.0.2:22222

codec g711alaw

vad aggressive

!

dial-peer voice 1000 voip

destination-pattern 1000

voice-class permanent 1

session protocol multicast

session target ipv4:239.100.0.1:22222

codec g711alaw

vad aggressive

3 REPLIES
New Member

Re: Popping on Telco POTS line when plugged into a router.

I only suspect the basic cabling. Since there is no change in config before and after moving to a different location. The issue seems to be with the cabling.

New Member

Re: Popping on Telco POTS line when plugged into a router.

Hi.I'm trying to figure out what analog interface I need to use to connect to my analog PLAR circuits from trading companies such as Morgan and Merrill. From your post, it seems like you used FXO and FXS. Which one was the eventual interface you used? I suppose it's FXS? Thanks!

New Member

Re: Popping on Telco POTS line when plugged into a router.

Check out these 2 bugs, although i appreciate that nothing has changed since the move and all was working ok. Might be of some help:

Bug ID CSCec48568

A popping sound might be heard when answering an incoming call.

The Cisco IP Phone 7960/7940 might generate an audible popping sound when an incoming call is answered by pressing the Answer softkey or the line button.

Workaround: None.

Bug ID CSCed13862

A very low speaker pop might be audible when the Answer softkey is pressed.

When a call is made from one IP Phone to another IP Phone and the Answer softkey is used to answer the incoming call, a low speaker popping sound might be heard on an intermittent basis.

Workaround: Answer calls using the handset to avoid the low speaker popping sound.

275
Views
0
Helpful
3
Replies
CreatePlease to create content