Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

POTS Configuration Fails - Busy - All Ports

I have a 3620 router, 1 voice module, 2-port FXS card.

The 2 ports are configured for POTS, no busyout, all other options are the same.

Dial-Peers set and DID is not used.

Both phones give a busy signal when off-hook, can't dial, router shows everything has "up"

I just got the router out-of-the-box, and I followed the sample setup documentation on the website. What's going on?

12 REPLIES
New Member

Re: POTS Configuration Fails - Busy - All Ports

I found the error. After debugging the voice port I saw that the when the phone was picked up (off-hook), an error occured stating that the dial-peer was not found - i.e. no dest-pat existed for a num-exp.

Removing that num-exp opened the lines. I would think that the OPR should be listed as DOWN when this sort of error occurs.

New Member

Re: POTS Configuration Fails - Busy - All Ports

Hello hotzelj.

How did you find this error cause i have a similar problem, when i'm trying to connect to PSTN through my FXO i can't get a tone from the phone that i have attached to my FXS...

And i don't know what's wrong, it seems that my dial-peer statements are correct...

New Member

Re: POTS Configuration Fails - Busy - All Ports

I found the error by looking at the show voice ... debugging, picked up one of the phones, and saw that an error occured without ever having typed a number in.

The error is very easy to read "No dest-pattern found for num-exp 'xxxx'"

Obviously, I had a num-exp command that translated a shortcut 'xxxx' into a dest-pattern that was not associated with any of the voice ports.

I don't have an FXO card, but look at weather or not you have setup DTMF (or is that DMTF) relay options or what for that card.

http://www.cisco.com/univercd/cc/td/doc/product/access/acs_mod/cis3600/voice/4936vqsg.htm#xtocid13951

That website has a simple config for both FXO and FXS and E&M interfaces - thats what I followed.

New Member

Re: POTS Configuration Fails - Busy - All Ports

Thanks a lot man... This !@#$!@#% wildcards...

I'm trying to connect to PSTN (through FXO)but not directly, I have to dial 0 first to connect to a PBX and afterwards dial the number I wish to call and I don't know how to configure the destination-pattern to my dial peer statement. I have set it like this

0,..........(10 dots total the 3 left dots after the comma are the area code) but when i'm trying to call through an analog phone attached to my FXS card it's not working... I can't find what's wrong man... What do you think?

New Member

Re: POTS Configuration Fails - Busy - All Ports

Your config should look like this:

router(config)# dial-peer voice [xxx] pots

router(config-dial-peer)# dest-pat +0..........

router(config-dial-peer)# port [x]/[x]/[x]

That is right off of the Cisco VoIP Quick Start Guide I refered you to.

Now, you may also set a num-exp that will pattern down the dest-pattern to a 10-digit only number.

router(config)# num-exp .......... +0..........

That, I think should work, but I am no expert at voice.

The way this should work is: User at phone 1234 calls a 10-digit outside line by dialing only the 10-required digits, the router's FXS port gets the outbound call, looks at the num-exp which translates that into the dest-pattern of +0 and the 10-digits, the router checks which slot/port is defined with that dest-pattern and then sends out the 11-digit number to that port which is then handled by your PBX system, which then strips off the +0 and sends out the call of 10-digits to the PSTN.

If that does not work, try looking at "show num-exp" to see if it is correct.

What is on the phone when you dial? Dial-tone/none, off-hook, busy - standard or fast-busy/busy-out?

New Member

Re: POTS Configuration Fails - Busy - All Ports

First of all I want to thank you for replying so fast. The problem is that I don't have a dial tone (no dial tone at all :-( ). The first entity you describe above is not working for me I've tested it in the past. I'll have to check your suggestion "router(config)# num-exp .......... +0.........." but the lab is closed now due to Christmas period... Your description has a point, so I'll check it and I'll inform you as soon as possible. Thanks again man!!!

New Member

Re: POTS Configuration Fails - Busy - All Ports

I had the same problem once. I don't remember exactly what was wrong.

1. Check your physical connections, are they tight and the correct type RJ-11?

2. Check the router voice module and card status - they need to be installed and status as up/good.

3. Clear ALL of the voice commands in the config.

Once that is complete, you should be able to pick up any phone and hear the dial-tone. Just because you get a dial-tone does not mean everything is configured - it just means that the VIC is sending a -48 volt signal on the POTS wires.

Now, you'd think that they'd have put the standard so NO tone is generated when the config is not setup wouldn't you think?

4. Enter the following commands (for now forget about the FXO side), I assume card slot of 0/0/0:

router# config term

router(config)# voice-port 0/0/0

router(config-voice-port)# no shutdown

router(config-voice-port)# exit

router(config)# dial-peer voice 1 pots

router(config-dial-peer)# destination-pattern 5555553333

router(config-dial-peer)# port 0/0/0

router(config-dial-peer)# exit

router(config)# exit

router# copy running-config startup-config

** So, we have now configured the FXS port from VIC 0 on slot 0 so it is not in any shutdown administratively. We also setup a dial-peer (in other words - the phone number) and assigned it to port 0/0/0. **

You should now be able to pickup and hear a dial-tone, if not - something is either wrong with the router, network module, voice card, phone line, phone, or your ears.

New Member

Re: POTS Configuration Fails - Busy - All Ports

Post your configuration if it does not work.

Are you a student then?

New Member

Re: POTS Configuration Fails - Busy - All Ports

Yes I'm studing electronic engineering and this implementation is the practical part of my dissertation (the last thing I have to do before taking my degree). Unfortunatelly the university is closed until 01/05/2006 due to Christmas period, so I'll have to wait until then in order to try out the interesting things you've mentioned above... I have to thank you once again for replying immediately... In a previous post you write "I'm not a VoIP expert"... Maybe not an expert but at least quite familiar with the subject... I'll inform you about the progress of the implementation as soon as possible! I'm really looking forward to check & deploy... So thank you man!!!

New Member

Re: POTS Configuration Fails - Busy - All Ports

What is your thesis?

As an Electrical Engineer, why is the practical implementation of your thesis focusing on VoIP?

I assume that it is more in-line with the usage and capabilities of the switched cirucit pathways that networks use and the electrical signals therein.

To tell you the truth, I said I was not an expert because I am not in the least. I have been working with networks and computer systems since I was 5 years old. I understand the basic, intermediate, and advanced topics and theory. However, my experiance with voice communications networks goes only to this point: I work for a fiber Cable TV company which provides VoIP services over our hybrid fiber-coaxial network architecture (fiber feeds around 500 homes, inside is coax, so it is majority fiber in terms of number of links, while the milage is higher for every single feeder, express, and drop line).

I also went through the Cisco Academy and have worked as a consultant and contractor for major F-100 and F-500 companies in two major metro areas.

New concepts are easy to understand when you know alot of the foundation and have practical experiance.

My personal skills in voice come from purchasing a Cisco 3620 router, 1-port voice module, and 2-port FXS interface card about 5 days ago.

So, in 5 days, I have gotten to be "quiet familiar with the subject" acording to you.

I thank you, but you should do just fine by youself. There's no better teacher yourself - try-and-fail - try again!

I think my solution will work for you, let me know what happends when you get back to class.

New Member

Re: POTS Configuration Fails - Busy - All Ports

In the last 2 semesters at my university you have to choose among 3 technologies; these are Networks & Communications, Telecommunications and VLSI Designing. I choose the first one because I was higly interested for digital systems and computers in particular and despite the fact that I first started practicing with a pc four years ago (yes I had an Amiga 500 when I was young but since then and until 4 years ago that was just about it concercing my computer knowledge & experience)... About my dissertation work, its subject is VoIP the technology, the signaling, the protocols involned, prons & cons versus the conventional PSTN, the cost benefits, the drawbacks, transmission issues, QoS features and so on... That's the theoritical part. The practical part is to implement VoIP in a lab for demonstrating the capabalities that packet telephony can provide by making calls using computer platform - appropriate software & analog devices connected to the router. I' ve read at least 4 books about VoIP (3 of them published by Ciscopress - Cisco rules) and several other documentation which I found on the net so I've learned a lot of stuff concerning IP telephony in a theoritical basis but the practical implementation is a different thing at all. It demands a lots of experience which unfortunatelly don't have but I'm trying to gain... These last months that I'm "playing" with the router I found that the most difficult thing is probably debugging your configs. Of course you are totally right about the best thing for me to do is practice, practice and more practice and I'm working really hard on it.

But thank you once again for sharing your knowledge and experience that makes me easier comprehend simple configuration technicalties that a newbie eye can't catch... So I'll let you know as soon as possible.

New Member

Re: POTS Configuration Fails - Busy - All Ports

Hello hotzell and happy new year!!! May it be creative & productive, with good

health above all! It's been a while since our last discussion...

I'm really happy to inform you that i found why I couldn't get no tone to the phone

attached to my FXS card. Desparate because I had create so many entities

(dial-peer statements) without getting an efficient result, I started checking the cables

as you had advise me to do in the close past... And I found that the RJ-11 cable which I

used for connecting the phone to the FXS was not working at all... I unplugged it and

replaced it with another cable and now I'm getting a tone... Quite an improvement I can

say :).

Afterwards I tried to call but the calls were terminated unexpectedly. I believe

that the reason that this happened is because I have create too many dial peers

correlating with each voice port (FXS 2/0/0 & FXO 2/1/0 more spesifically). So I want to

ask you this; how do we delete the voice configuration? I've searched the IOS commands and

I can't recall which command I wrote exactly that prompted me to delete the file "voice"

which I didn't delete it, cause I wasn't sure if it's the right thing to do.Do I have to

delete all the voice configs including the voice port associative, or just the dial-peer

statements? And how we delete them eventually? I was quite confused about that, I've

downloaded the IOS command reference for the specific installed version of the router but

didn't found the proper commands...

In a nutshell here is what I want to do. First I want to be able to make

calls & sessions in general using Netmeeting from the computer 10.251.77.185. The ISA

server between the router and the switch is using DHCP but I have configured a static

"inside" IP (10.251.77.185) and a listener for 10.251.77.185 to 195.251.77.185. I also

want to make calls through a softphone program to regular PSTN phones. Furthermore I want

to use an analog phone plugged to my 2/0/0 FXS for making calls to regular PSTN phones

(for example 210(area code) 5910554(my house) that means 210xxxxxxx calls). But I have to

dial 0 first in order to connect to university's PBX and afterwards dial the number I wish

to call. The last and apparently most difficult thing to do is to properly configure the

router so to be able to receive incoming calls from England and the router attend the

calls to either the analog phone plugged to the 2/0/0 FXS or to the H.323 compatible

10.251.77.185 computer (by using an appropriate softphone program of course).

I will attach below my latest configs and an off-hand drawing...

So, I think I should better delete all my voice configs (don't know how though),

:-( and afterwards reconfigure the necessary entities. Until now my first thoughts are:

/* For Netmeeting calls */

dial-peer voice 901 voip

session target ipv4:195.251.77.185

codec g711ulaw

destination-pattern +100

!

/* For the analog phone plugged to FXS 2/0/0 */

dial-peer voice 902 pots

destination-pattern +200

port 2/0/0

!

/* Outcoming calls to the PSTN through the FXO 2/1/0 */

a) dial-peer voice 903 pots

destination-pattern 9..........

prefix 0,

port 2/1/0

!

or b) dial-peer voice 903 pots

destination-pattern +0..........

port 2/1/0

num-exp .......... +0..........

!

/* To accept calls from England and the router attend the calls to the phone or the pc */

I haven't figure a solution for this yet...

PS: I hope you have the patience to read the topic...

262
Views
0
Helpful
12
Replies
CreatePlease to create content