Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

PRI with NI2 between a 1760 and MRP-300

I have a lab setup with a 1760 and an MRP-300. I am trying to setup a PRI between them using NI2 protocol. I have the 1760 setup as the Network and the MRP as the User with a T1 Crossover cable between them. I have the 1760 setup with this config:

tdm clock T1 0/0 both import onboard internal

tdm clock T1 0/1 both import onboard internal

voice-card 0

!

isdn switch-type primary-ni

!

controller T1 0/1

framing esf

linecode b8zs

cablelength short 133

pri-group timeslots 1-24 service mgcp

!

!

interface Serial0/1:23

no ip address

no logging event link-status

isdn switch-type primary-ni

isdn incoming-voice voice

no cdp enable

!

The MRP-300 is setup like this:

!

tdm clock T1 0/0 both export line

tdm clock T1 0/1 both import T1 0/0 line

voice-card 0

!

isdn switch-type primary-ni

!

!

!

controller T1 0/0

framing esf

linecode b8zs

cablelength short 133

pri-group timeslots 1-24 service mgcp

!

controller T1 0/1

framing esf

linecode b8zs

cablelength short 133

pri-group timeslots 1-24 service mgcp

!

!

interface Serial0/0:23

no ip address

no logging event link-status

isdn switch-type primary-ni

no cdp enable

!

interface Serial0/1:23

no ip address

no logging event link-status

isdn switch-type primary-ni

no cdp enable

voice-port 0/0:23

!

voice-port 0/1:23

!

I have the routers connect on 0/1 of the 1760 and 0/0 of the MRP-300

My problem is that I keep getting User RX <- BAD FRAME(0x00017F) on both sides of the circuit. I think the clocking is setup correctly but would like to get a second option.

2 REPLIES
Blue

Re: PRI with NI2 between a 1760 and MRP-300

Under the Serial interface of the router you want as network side you need the following command:

isdn protocol-emulate network

If that doesn't work make sure your cabling is ok.

New Member

Re: PRI with NI2 between a 1760 and MRP-300

That did it. Thanks.

199
Views
5
Helpful
2
Replies