Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

priority-queue out not working on 3750

Not sure what I am missing but I can't enable priority-queuing on cisco 3750

int gigabitEthernet 1/0/27
xxxxxxxxxxxxxxxx(config-if)#priority-queue out
                             ^
% Invalid input detected at '^' marker.

show version
Cisco Internetwork Operating System Software
IOS (tm) C3750 Software (C3750-I5-M), Version 12.1(14)EA1a, RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2003 by cisco Systems, Inc.
Compiled Tue 02-Sep-03 04:39 by antonino
Image text-base: 0x00003000, data-base: 0x008F14A0

ROM: Bootstrap program is C3750 boot loader
BOOTLDR: C3750 Boot Loader (C3750-HBOOT-M) Version 12.1(11r)AX, RELEASE SOFTWARE (fc1)

sun-radiorm-3750 uptime is 6 years, 36 weeks, 1 day, 15 hours, 13 minutes
System returned to ROM by power-on
System restarted at 19:18:57 MST Wed Mar 10 2004
System image file is "flash:c3750-i5-mz.121.14-EA1a/c3750-i5-mz.121.14-EA1a.bin"

cisco WS-C3750G-24TS (PowerPC405) processor (revision C0) with 118774K/12288K bytes of memory.
Processor board ID CAT0745R0W3
Last reset from power-on
Bridging software.
4 Virtual Ethernet/IEEE 802.3  interface(s)
28 Gigabit Ethernet/IEEE 802.3 interface(s)
The password-recovery mechanism is enabled.

512K bytes of flash-simulated non-volatile configuration memory.
Base ethernet MAC Address       : 00:0E:38:D7:DE:00
Motherboard assembly number     : 73-7058-09
Power supply part number        : 341-0045-01
Motherboard serial number       : CAT074302BZ
Power supply serial number      : PHI073600D3
Model revision number           : C0
Motherboard revision number     : A0
Model number                    : WS-C3750G-24TS-E
System serial number            : CAT0745R0W3


Switch   Ports  Model              SW Version              SW Image
------   -----  -----              ----------              ----------
*    1   28     WS-C3750G-24TS     12.1(14)EA1a            C3750-I5-M


Configuration register is 0xF

Any suggestions....

1 REPLY

Re: priority-queue out not working on 3750

Can you try an IOS upgrade?
I've many 3750 with priority queue configured without problem.

Cisco IOS Software, C3750 Software (C3750-IPSERVICES-M), Version 12.2(25)SEE2, RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2006 by Cisco Systems, Inc.
Compiled Fri 28-Jul-06 08:46 by yenanh
Image text-base: 0x00003000, data-base: 0x010CE290

ROM: Bootstrap program is C3750 boot loader
BOOTLDR: C3750 Boot Loader (C3750-HBOOT-M) Version 12.2(25r)SEC, RELEASE SOFTWARE (fc4)

WIFI-CASALECR uptime is 1 year, 8 weeks, 6 days, 19 hours, 48 minutes
System returned to ROM by power-on
System restarted at 00:46:15 METDST Mon Sep 21 2009
System image file is "flash:c3750-ipservices-mz.122-25.SEE2/c3750-ipservices-mz.122-25.SEE2.bin"

cisco WS-C3750-24TS (PowerPC405) processor (revision M0) with 118784K/12280K bytes of memory.
Processor board ID CAT1051RKQ1
Last reset from power-on
9 Virtual Ethernet interfaces
24 FastEthernet interfaces
2 Gigabit Ethernet interfaces
The password-recovery mechanism is enabled.

512K bytes of flash-simulated non-volatile configuration memory.
Base ethernet MAC Address       : 00:1A:A2:1A:A0:00
Motherboard assembly number     : 73-9677-10
Power supply part number        : 341-0034-01
Motherboard serial number       : CAT10515CH7
Power supply serial number      : DTH1047121C
Model revision number           : M0
Motherboard revision number     : A0
Model number                    : WS-C3750-24TS-E
System serial number            : CAT1051RKQ1
Top Assembly Part Number        : 800-26382-02
Top Assembly Revision Number    : D0
Version ID                      : V05
CLEI Code Number                : CNMV200CRE
Hardware Board Revision Number  : 0x01


Switch   Ports  Model              SW Version              SW Image           
------   -----  -----              ----------              ----------         
*    1   26     WS-C3750-24TS      12.2(25)SEE2            C3750-IPSERVICES-M

This is my config:

###GLOBAL LEVEL

errdisable recovery cause all

mls qos srr-queue input priority-queue 2 bandwidth 20
mls qos srr-queue input cos-map queue 1 threshold 3  0 1 2 3 4
mls qos srr-queue input cos-map queue 2 threshold 3  5 6 7
mls qos srr-queue output cos-map queue 1 threshold 3  5 6 7
mls qos srr-queue output cos-map queue 2 threshold 3  4
mls qos srr-queue output cos-map queue 3 threshold 3  2 3
mls qos srr-queue output cos-map queue 4 threshold 3  0 1
mls qos

access-list 102 (etc.)

class-map match-all voip
  match access-group 102

policy-map voip
  class voip
   set dscp cs5
  class class-default
   set dscp default

interface FastEthernet1/0/1
description ***
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2240,2260,2270
switchport mode trunk
service-policy input voip
priority-queue out

spanning-tree portfast trunk
spanning-tree bpdufilter disable
spanning-tree bpduguard enable

1264
Views
0
Helpful
1
Replies