Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Problem between SIP to H323

Hi,

I am trying to configure interconnection between gateway which is using SIP and H323. Look at the diagram

non-ciscoGW------SIP--------ciscoGW1--------H323--------CiscoGW2-------PSTN

For the nonciscoGW is the SIP server. All the IP Phone will register to the SIP server. I want to enable all the IP Phones which are registerred to the SIP server to call PSTN. I was able to make it work, somehow. But after I did some changes It doesn't work anymore.FYI, all devices are in the same subnet.

Here are the configs

ciscoGW1

voice rtp send-recv

!

voice service voip

sip

bind all source-interface FastEthernet0

!

voice class codec 1

codec preference 1 g729br8

codec preference 2 g729r8

codec preference 3 g711alaw

codec preference 4 g711ulaw

!

!

!

!

!

!

!

no voice hpi capture buffer

no voice hpi capture destination

!

!

fax interface-type fax-mail

!

!

controller E1 0

pri-group timeslots 1-31

!

controller E1 1

clock source line secondary 1

!

controller E1 2

clock source line secondary 2

!

controller E1 3

clock source line secondary 3

pri-group timeslots 1-31

gw-accounting aaa

!

!

!

interface Ethernet0

no ip address

shutdown

!

interface Serial0

no ip address

shutdown

clockrate 2015232

no fair-queue

!

interface Serial1

no ip address

shutdown

clockrate 2015232

no fair-queue

!

interface Serial2

no ip address

shutdown

clockrate 2015232

no fair-queue

!

interface Serial3

no ip address

shutdown

clockrate 2015232

no fair-queue

!

interface Serial0:15

no ip address

isdn switch-type primary-net5

isdn overlap-receiving T302 2000

isdn protocol-emulate network

isdn incoming-voice modem

isdn send-alerting

no isdn outgoing display-ie

no cdp enable

!

interface Serial3:15

no ip address

isdn switch-type primary-5ess

isdn incoming-voice modem

no cdp enable

!

interface FastEthernet0

ip address 192.168.0.159 255.255.255.0

duplex auto

speed auto

!

ip classless

no ip http server

!

!

!

!

voice-port 0:D

cptone SG

!

voice-port 3:D

!

!

!

dial-peer voice 2 voip

destination-pattern 9T

voice-class codec 1

session target ipv4:192.168.0.160

dtmf-relay h245-alphanumeric

no vad

!

sip-ua

ciscoGW2

no voice hpi capture buffer

no voice hpi capture destination

!

!

mta receive maximum-recipients 0

!

!

!

interface FastEthernet0/0

ip address 192.168.0.160 255.255.255.0

speed auto

!

ip classless

no ip http server

!

!

!

!

call rsvp-sync

!

voice-port 2/0

cptone SG

!

voice-port 2/1

!

!

mgcp profile default

!

dial-peer cor custom

!

!

!

dial-peer voice 10 pots

destination-pattern 9T

port 2/0

!

!

line con 0

line aux 0

line vty 0 4

no login

!

end

If I do a simulation call from GW1 to GW2/PSTN. I am able to by using csim sta 9XXXXXX. But when I call from IP Phone to PSTN it doesn't work. It looks like the GW1 is unable forward the call to GW2. because when I do any debug about voice. I did not get anything..ter mon has been enabled.

.Apr 15 03:34:50.899: //82/AFBCBFE68058/CCAPI/ccCallCanGateway: cannot gateway iftype 3 to 1 for cid(82)

.Apr 15 03:34:50.899: //82/AFBCBFE68058/SSAPP:0:-1/ssaSetupPeer: setup failed rc(0)

.Apr 15 03:34:50.907: //82/AFBCBFE68058/CCAPI/cc_api_call_disconnect_done: cause=3,retry=0,vcCauseCode=0

Thanks

6 REPLIES
New Member

Re: Problem between SIP to H323

It won't work. ciscoGW1 cannot translate SIP-to-H323 protocol and wise-versa. You need a SIP/H23 Gateway in this case.

Thanks

SSng

New Member

Re: Problem between SIP to H323

Hi

I thought so before but even I change using SIP to SIP, it doesn't work either here are the changes

dial-peer voice 2 voip

destination-pattern 9T

voice-class codec 1

session protocol sipv2

session target ipv4:192.168.0.160

dtmf-relay h245-alphanumeric

no vad

But fyi I ever made it working but I can remember what I change.it should be the same as what I pasted b4.

anyway thanks alot

-santo-

New Member

Re: Problem between SIP to H323

You must have a good reason to use cisoGW1 and CiscoGW2 in your scenario. Is this going be to a real case or juts a test lab.

In any case, ciscoGW cannot become a transit.

Why don't you design in such a way that sip proxy send voip call directy to voicegw2 to pstn?

Or use another SIP proxy server to act as the Directory SIP Proxy.

Something like this

IPPhone->OutboutSIPProxy(OSP)->DirectorySIPProxy(DSP)->VGW->PSTN

You can have many OSP to serve different domains. A a pair of DSP for redundancy. And many VGW to serve other PSTN connections

Use the VGW only as VOIP-to-PSTN at edge of your network.

New Member

Re: Problem between SIP to H323

Hi

for some reasons the router must be setup like that. The protocol between the cisco gateways can be either sip or h323.

many thanks

-santo-

Cisco Employee

Re: Problem between SIP to H323

Santo,

Just curious. What is the purpose of such a setup?

-Naren

New Member

Re: Problem between SIP to H323

hi,

the diagram

SIP Server----ciscoGW1-------ciscoGW2------PSTN

SIP server only supports g711 codec. ciscogw2 is not under mycontrol and only supports g729. So I use ciscoGW1 to do transcodec. I hope that the voice path will be from sip server to ciscoGW1 then to ciscoGW2. is that posssible ?

thanks

264
Views
0
Helpful
6
Replies
CreatePlease to create content