Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Problem with 7940,7960 and DHCP requests

Hi,

i have a problem with the phones 7940 which are connected to an "older" switches as 3524XL, 2950-12 etc for a long time . I have two VLANs 830 voice and 810 LAN. There is a problem that in most of the time the phone GETs the address from LAN DHCP server with different range of IP addresses and no through VOICE VLAN from VOICE DHCP.

I haven't got this problem on newer switches like a 3750 or 3550..

I debuged on VOICE DHCP and I saw that there was a BROADCAST request and than a DHCP request but there wasn't DHCP response from VOICE DHCP yet.

My configuration:

interface FastEthernet0/20

switchport trunk encapsulation dot1q

switchport trunk native vlan 810

switchport mode trunk

switchport voice vlan 830

spanning-tree portfast

Phone type 7912 doesn't have this problem on the same switch.

Thank you for your help..

Best regards

6 REPLIES
Cisco Employee

Re: Problem with 7940,7960 and DHCP requests

Change your configs to:

interface FastEthernet0/20

switchport access vlan 810

switchport mode access

switchport voice vlan 830

spanning-tree portfast

That will fix your problem. Remove the trunk commands. The ports "acts" as a dot1q trunk as soon as you configure the voice vlan. But you should not configure it as a trunk

New Member

Re: Problem with 7940,7960 and DHCP requests

I think on XL series I have to use the trunk commands, haven't I?

By the documentation the access type of interface i can use on 3550, 3750 etc..

New Member

Re: Problem with 7940,7960 and DHCP requests

Just to be sure, i tried it. It doesn't work with access type of interface.

The phone didn't get any address from VOICE DHCP and from LAN DHCP too.

I think it realy have to be trunk. It works on Catalyst 3750,3550 and other newer types of switches without problems.

This type of problems we have only on type like a XL series..

On Cat3524XL i have 12.0(5)WC13 which is newest..

Thanks for our ideas..

David

New Member

Re: Problem with 7940,7960 and DHCP requests

We found that the problem is with older types of 7940 ONLY.

7940G is without troubles.

It looks, the combination of XL series and older types of 7940 is problematic. Newest firmware to 7940 doesn't resolve this..:-(

Any IDEA?

New Member

Re: Problem with 7940,7960 and DHCP requests

Make sure that the switchport configuration for the access/data vlan DHCP server doesn't have:

switchport voice vlan xxxx

I ran into a bug with FW7900 6.0(5) where the phone would obtain an IP from the access/data vlan. I ended up removing the voice vlan from the switchport to the access/data vlan DHCP server and now everything works.

New Member

Re: Problem with 7940,7960 and DHCP requests

I don't understand what do you mean.

Do you mean the port where the DHCP server is connected?

On that port is not the command switchport voice vlan..

We changed the phones to 7940G version and there is no problem now. The problem is realy only with 7940 without G.

I think there is probably problem of this type of phone with older switches..

299
Views
0
Helpful
6
Replies