Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Problem with the sip alg function in ios

Hi,

I have a problem to get the sip alg function to work correctly in our 7200 12.3(14)T4.

Our setup is as follows:

The sip server and the cisco_MGW are on the inside (private addresses).

The client is on the outside.

When the client send an INVITE to the outside interface, the alg change the destination address and forward it to the sip-server.

The problem is that when the sip server send 183 PROGRESS message, the alg doesn't change the private source ip address to a public source address.

The alg also miss to change the media part in the sdp body,but it change record-route parameter.

This is my configuration:

interface FastEthernet1/0

ip address x.x.x.x

no ip redirects

no ip unreachables

ip nat outside

ip virtual-reassembly

duplex full

interface FastEthernet4/0.10

encapsulation dot1Q 10

ip address 192.168.21.1 255.255.255.252

ip nat inside

ip virtual-reassembly

no snmp trap link-status

no cdp enable

ip nat inside source static tcp 192.168.101.6 53 x.x.x.x 53

ip nat inside source static udp 192.168.101.6 53 x.x.x.x 53

ip nat inside source static tcp 192.168.101.6 5060 x.x.x.x 5060

ip nat inside source static udp 192.168.101.6 5060 x.x.x.x 5060

Could somebody tell me if I have missed anything.

Regards Niklas

2 REPLIES
Bronze

Re: Problem with the sip alg function in ios

Try disabling the following commands

1. fixup protocol h323 ras 1718-1719

2. fixup protocol sip 5060

3. fixup protocol sip udp 5060

4. fixup protocol skinny 2000

New Member

Re: Problem with the sip alg function in ios

Hi,

It was not possible to add this commands.

I use following IOS release:

12.3(14)T4

/Niklas

207
Views
0
Helpful
2
Replies