Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Problems with DSP Gateway mgcp 2811

I've got a Callmanager 4.1(3), gateway with a ISDN Primary E1 and DSP PVDM2. But I don't archive enable the dsp's. I can make external call but I heard nothing. I don?t know where is the problem.

Here is the configuration:

MADRID_CC#sh run

Building configuration...

Current configuration : 2931 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname MADRID_CC

!

boot-start-marker

boot-end-marker

!

card type e1 0 0

!

no aaa new-model

!

resource policy

!

network-clock-participate wic 0

ip subnet-zero

!

!

ip cef

no ip dhcp use vrf connected

ip dhcp excluded-address 10.0.2.1 10.0.2.9

!

ip dhcp pool VOICE

network 10.0.2.0 255.255.255.0

option 150 ip 10.0.1.2

default-router 10.0.2.1

dns-server 10.0.1.2

!

!

ip host CALLMANAGER 10.0.1.2

isdn switch-type primary-net5

!

voice-card 0

dspfarm

dsp services dspfarm

!

!

!

voice service voip

!

!

!

!

!

!

!

!

!

!

!

!

!

!

controller E1 0/0/0

clock source internal

pri-group timeslots 1-31 service mgcp

!

!

!

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.1

encapsulation dot1Q 1 native

ip address 172.16.113.34 255.255.255.224

no snmp trap link-status

!

interface FastEthernet0/0.2

encapsulation dot1Q 2

ip address 10.0.2.1 255.255.255.0

no snmp trap link-status

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice voice

isdn bind-l3 ccm-manager

no cdp enable

!

ip classless

ip route 0.0.0.0 0.0.0.0 172.16.113.33

!

no ip http server

no ip http secure-server

!

!

!

!

control-plane

!

!

!

voice-port 0/0/0:15

cptone ES

!

ccm-manager fallback-mgcp

ccm-manager mgcp

ccm-manager music-on-hold

ccm-manager config server 10.0.1.2

ccm-manager config

!

mgcp

mgcp call-agent CALLMANAGER 2427 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

no mgcp package-capability res-package

mgcp package-capability sst-package

no mgcp package-capability fxr-package

mgcp package-capability pre-package

no mgcp timer receive-rtcp

mgcp sdp simple

no mgcp explicit hookstate

mgcp rtp payload-type g726r16 static

!

mgcp profile default

!

sccp local FastEthernet0/0.2

sccp ccm 10.0.1.2 identifier 1 version 4.1

sccp ip precedence 3

sccp

!

sccp ccm group 988

associate ccm 1 priority 1

associate profile 1 register 172.16.113.34

keepalive retries 5

switchover method immediate

switchback method immediate

switchback interval 15

!

dspfarm profile 1 transcode

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

codec gsmfr

maximum sessions 18

associate application SCCP

shutdown

!

!

!

call-manager-fallback

max-conferences 8 gain -6

limit-dn 7940 4

ip source-address 10.0.2.1 port 2002 strict-match

max-ephones 24

max-dn 15 dual-line preference 1

!

!

line con 0

line aux 0

line vty 0 4

!

scheduler allocate 20000 1000

!

end

MADRID_CC#

Thanks for your help.

See you.

9 REPLIES

Re: Problems with DSP Gateway mgcp 2811

Juan,

DSPs don't need to be enabled for voice calls. The router will try to use the available DSPs. To see if you are running out of DSPs then take a look at the router log buffer or syslog. You also have 18 transcoding sessions configured which equals 36 dsp channels on your router with a PVDM2 configuration. How many DSPs do you have in your router? You can determine this from a sh inventory or sh voice dsp detailed.

Please rate any helpful posts

Thanks

Fred

Community Member

Re: Problems with DSP Gateway mgcp 2811

MADRID_CC#sh inventory

NAME: "2811 chassis", DESCR: "2811 chassis"

PID: CISCO2811 , VID: V01 , SN: FCZ0949723J

NAME: "VWIC2-1MFT-T1/E1 - 1-Port RJ-48 Multiflex Trunk - T1/E1 on Slot 0 SubSlot 0", DESCR: "VWIC2-1MFT-T1/E1 - 1

-Port RJ-48 Multiflex Trunk - T1/E1"

PID: VWIC2-1MFT-T1/E1 , VID: V01 , SN: FOC0947377Q

NAME: "PVDMII DSP SIMM with four DSPs on Slot 0 SubSlot 4", DESCR: "PVDMII DSP SIMM with four DSPs"

PID: PVDM2-64 , VID: NA , SN: FOC10040Q6G

MADRID_CC#

MADRID_CC#sh voice dsp detailed

DSP DSP DSPWARE CURR BOOT PAK TX/RX

TYPE NUM CH CODEC VERSION STATE STATE RST AI VOICEPORT TS ABORT PACK COUNT

==== === == ======== ======= ===== ======= === == ========= == ===== ============

edsp 001 01 g729r8 p 0.1 IDLE 50/0/1.1

edsp 002 02 g729r8 p 0.1 IDLE 50/0/1.2

edsp 003 01 g729r8 p 0.1 IDLE 50/0/2.1

edsp 004 02 g729r8 p 0.1 IDLE 50/0/2.2

edsp 005 01 g729r8 p 0.1 IDLE 50/0/3.1

edsp 006 02 g729r8 p 0.1 IDLE 50/0/3.2

edsp 007 01 g729r8 p 0.1 IDLE 50/0/4.1

edsp 008 02 g729r8 p 0.1 IDLE 50/0/4.2

edsp 009 01 g729r8 p 0.1 IDLE 50/0/5.1

edsp 010 02 g729r8 p 0.1 IDLE 50/0/5.2

edsp 011 01 g729r8 p 0.1 IDLE 50/0/6.1

edsp 012 02 g729r8 p 0.1 IDLE 50/0/6.2

edsp 013 01 g729r8 p 0.1 IDLE 50/0/7.1

edsp 014 02 g729r8 p 0.1 IDLE 50/0/7.2

edsp 015 01 g729r8 p 0.1 IDLE 50/0/8.1

edsp 016 02 g729r8 p 0.1 IDLE 50/0/8.2

edsp 017 01 g729r8 p 0.1 IDLE 50/0/9.1

edsp 018 02 g729r8 p 0.1 IDLE 50/0/9.2

edsp 019 01 g729r8 p 0.1 IDLE 50/0/10.1

edsp 020 02 g729r8 p 0.1 IDLE 50/0/10.2

edsp 021 01 g729r8 p 0.1 IDLE 50/0/11.1

edsp 022 02 g729r8 p 0.1 IDLE 50/0/11.2

edsp 023 01 g729r8 p 0.1 IDLE 50/0/12.1

edsp 024 02 g729r8 p 0.1 IDLE 50/0/12.2

edsp 025 01 g729r8 p 0.1 IDLE 50/0/13.1

edsp 026 02 g729r8 p 0.1 IDLE 50/0/13.2

edsp 027 01 g729r8 p 0.1 IDLE 50/0/14.1

edsp 028 02 g729r8 p 0.1 IDLE 50/0/14.2

edsp 029 01 g729r8 p 0.1 IDLE 50/0/15.1

edsp 030 02 g729r8 p 0.1 IDLE 50/0/15.2

Firstly I tried with this configuration but It don't work:

-voice-card 0

dspfarm

dsp services dspfarm

Thanks

Juan

Community Member

Re: Problems with DSP Gateway mgcp 2811

Try this command:

voice-port 0/0/0:15

compand-type a-law

this is needed to use the european ISDN coded.

Let me know

Community Member

Re: Problems with DSP Gateway mgcp 2811

Hi,

Now I can detect some strange things.

With three phones (A, B, C)

I make a call from A to B. I can heard nothing.

I hold on the call (A-->B) and make a new call with the second line from A to C.

A-->B on hold

A-->C running

I can heard nothing between A and C but I can heard to A from B and B from A while the is on hold.

I hold on the call between A and C.

A-->B on hold

A-->C on hold

From B I can heard music on hold.

The dsp are actived.

MADRID_CC#sh voice dsp detailed

DSP DSP DSPWARE CURR BOOT PAK TX/RX

TYPE NUM CH CODEC VERSION STATE STATE RST AI VOICEPORT TS ABORT PACK COUNT

==== === == ======== ======= ===== ======= === == ========= == ===== ============

edsp 001 01 g729r8 p 0.1 IDLE 50/0/1.1

edsp 002 02 g729r8 p 0.1 IDLE 50/0/1.2

edsp 003 01 g729r8 p 0.1 IDLE 50/0/2.1

edsp 004 02 g729r8 p 0.1 IDLE 50/0/2.2

edsp 005 01 g729r8 p 0.1 IDLE 50/0/3.1

edsp 006 02 g729r8 p 0.1 IDLE 50/0/3.2

edsp 007 01 g729r8 p 0.1 IDLE 50/0/4.1

edsp 008 02 g729r8 p 0.1 IDLE 50/0/4.2

edsp 009 01 g729r8 p 0.1 IDLE 50/0/5.1

edsp 010 02 g729r8 p 0.1 IDLE 50/0/5.2

edsp 011 01 g729r8 p 0.1 IDLE 50/0/6.1

edsp 012 02 g729r8 p 0.1 IDLE 50/0/6.2

edsp 013 01 g729r8 p 0.1 IDLE 50/0/7.1

edsp 014 02 g729r8 p 0.1 IDLE 50/0/7.2

edsp 015 01 g729r8 p 0.1 IDLE 50/0/8.1

edsp 016 02 g729r8 p 0.1 IDLE 50/0/8.2

edsp 017 01 g729r8 p 0.1 IDLE 50/0/9.1

edsp 018 02 g729r8 p 0.1 IDLE 50/0/9.2

edsp 019 01 g729r8 p 0.1 IDLE 50/0/10.1

edsp 020 02 g729r8 p 0.1 IDLE 50/0/10.2

edsp 021 01 g729r8 p 0.1 IDLE 50/0/11.1

edsp 022 02 g729r8 p 0.1 IDLE 50/0/11.2

edsp 023 01 g729r8 p 0.1 IDLE 50/0/12.1

edsp 024 02 g729r8 p 0.1 IDLE 50/0/12.2

edsp 025 01 g729r8 p 0.1 IDLE 50/0/13.1

edsp 026 02 g729r8 p 0.1 IDLE 50/0/13.2

edsp 027 01 g729r8 p 0.1 IDLE 50/0/14.1

edsp 028 02 g729r8 p 0.1 IDLE 50/0/14.2

edsp 029 01 g729r8 p 0.1 IDLE 50/0/15.1

edsp 030 02 g729r8 p 0.1 IDLE 50/0/15.2

----------------------------FLEX VOICE CARD 0 ------------------------------

*DSP VOICE CHANNELS*

DSP DSP DSPWARE CURR BOOT PAK TX/RX

TYPE NUM CH CODEC VERSION STATE STATE RST AI VOICEPORT TS ABRT PACK COUNT

===== === == ======== ======= ===== ======= === == ========= == ==== ============

C5510 001 01 g711ulaw 6.3.2 busy idle 0 0 0/0/0:15 31 0 1681/1772

C5510 001 02 g711ulaw 6.3.2 busy idle 0 0 0/0/0:15 30 0 444/488

C5510 001 03 None 6.3.2 idle idle 0 0 0 0/0

C5510 001 04 None 6.3.2 idle idle 0 0 0 0/0

C5510 001 05 None 6.3.2 idle idle 0 0 0 0/0

C5510 001 06 None 6.3.2 idle idle 0 0 0 0/0

C5510 001 07 None 6.3.2 idle idle 0 0 0 0/0

Gold

Re: Problems with DSP Gateway mgcp 2811

Juan,

Check with the provider if the E1 is using CRC4 or not. Check this parameter in the MGCP cpnfiguration in CallManager too.

Why are you using the 'clock source internal' command? I have several configurations and I don?t use that command.

Hope this helps,

Juan Luis

Community Member

Re: Problems with DSP Gateway mgcp 2811

Hi Juan Luis,

I have tried CRC4 and NO-CRC4 with 'clock source internal' and 'clock source external'. It run the same way.

With three phones (A, B, C)

I make a call from A to B. I can heard nothing.

I hold on the call (A-->B) and make a new call with the second line from A to C.

A-->B on hold

A-->C running

I can heard nothing between A and C but I can heard to A from B and B from A while the is on hold.

I hold on the call between A and C.

A-->B on hold

A-->C on hold

From B I can heard music on hold.

The dsp are actived.

MADRID_CC#sh voice dsp detailed

DSP DSP DSPWARE CURR BOOT PAK TX/RX

TYPE NUM CH CODEC VERSION STATE STATE RST AI VOICEPORT TS ABORT PACK COUNT

==== === == ======== ======= ===== ======= === == ========= == ===== ============

edsp 001 01 g729r8 p 0.1 IDLE 50/0/1.1

edsp 002 02 g729r8 p 0.1 IDLE 50/0/1.2

edsp 003 01 g729r8 p 0.1 IDLE 50/0/2.1

edsp 004 02 g729r8 p 0.1 IDLE 50/0/2.2

edsp 005 01 g729r8 p 0.1 IDLE 50/0/3.1

edsp 006 02 g729r8 p 0.1 IDLE 50/0/3.2

edsp 007 01 g729r8 p 0.1 IDLE 50/0/4.1

edsp 008 02 g729r8 p 0.1 IDLE 50/0/4.2

edsp 009 01 g729r8 p 0.1 IDLE 50/0/5.1

edsp 010 02 g729r8 p 0.1 IDLE 50/0/5.2

edsp 011 01 g729r8 p 0.1 IDLE 50/0/6.1

edsp 012 02 g729r8 p 0.1 IDLE 50/0/6.2

edsp 013 01 g729r8 p 0.1 IDLE 50/0/7.1

edsp 014 02 g729r8 p 0.1 IDLE 50/0/7.2

edsp 015 01 g729r8 p 0.1 IDLE 50/0/8.1

edsp 016 02 g729r8 p 0.1 IDLE 50/0/8.2

edsp 017 01 g729r8 p 0.1 IDLE 50/0/9.1

edsp 018 02 g729r8 p 0.1 IDLE 50/0/9.2

edsp 019 01 g729r8 p 0.1 IDLE 50/0/10.1

edsp 020 02 g729r8 p 0.1 IDLE 50/0/10.2

edsp 021 01 g729r8 p 0.1 IDLE 50/0/11.1

edsp 022 02 g729r8 p 0.1 IDLE 50/0/11.2

edsp 023 01 g729r8 p 0.1 IDLE 50/0/12.1

edsp 024 02 g729r8 p 0.1 IDLE 50/0/12.2

edsp 025 01 g729r8 p 0.1 IDLE 50/0/13.1

edsp 026 02 g729r8 p 0.1 IDLE 50/0/13.2

edsp 027 01 g729r8 p 0.1 IDLE 50/0/14.1

edsp 028 02 g729r8 p 0.1 IDLE 50/0/14.2

edsp 029 01 g729r8 p 0.1 IDLE 50/0/15.1

edsp 030 02 g729r8 p 0.1 IDLE 50/0/15.2

----------------------------FLEX VOICE CARD 0 ------------------------------

*DSP VOICE CHANNELS*

DSP DSP DSPWARE CURR BOOT PAK TX/RX

TYPE NUM CH CODEC VERSION STATE STATE RST AI VOICEPORT TS ABRT PACK COUNT

===== === == ======== ======= ===== ======= === == ========= == ==== ============

C5510 001 01 g711ulaw 6.3.2 busy idle 0 0 0/0/0:15 31 0 1681/1772

C5510 001 02 g711ulaw 6.3.2 busy idle 0 0 0/0/0:15 30 0 444/488

C5510 001 03 None 6.3.2 idle idle 0 0 0 0/0

C5510 001 04 None 6.3.2 idle idle 0 0 0 0/0

C5510 001 05 None 6.3.2 idle idle 0 0 0 0/0

C5510 001 06 None 6.3.2 idle idle 0 0 0 0/0

C5510 001 07 None 6.3.2 idle idle 0 0 0 0/0

Gold

Re: Problems with DSP Gateway mgcp 2811

Juan,

Sometimes, I had problems with the way that CallManager got the channels. Try to change, in the CallManager gateway configuration page, the parameter 'Channel Selection Order' to check if this could be the problem.

Juan Luis

Community Member

Re: Problems with DSP Gateway mgcp 2811

That was the problem.

Thanks a lot for your help.

Nice to met you.

Bye.

Gold

Re: Problems with DSP Gateway mgcp 2811

Please, don?t forget to rate the posts.

Regards,

Juan Luis

313
Views
5
Helpful
9
Replies
CreatePlease to create content