Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Problems with HDA and FXS ports

We have a 2600 with a HDA (4 FXS and 8 FXO) running 12.2-11.T and configured for H323 at a remote site. The FXOs go to the PSTN and are working fine, but when I hook up to the FXS ports, it will give me a reorder tone after dialing the first digit. There is a CallManager at the Main site connected via a T1. We are running g711u everywhere.

I've placed analog phones on the FXS ports and created dial-peer pots statements for them, but could not call between the phone. When you press the first digit the reorder tone starts, like it doesn't know of the dial-peers. Has anyone run into this?

8 REPLIES
Bronze

Re: Problems with HDA and FXS ports

What do your dial-peers look like? You can put statements like "direct-inward-dial" on FXS dial peers that will cause re-order tones. The fact that you at least get dial tone sounds like something is messed up in them. Please post the config (take out all password statements, change IP addresses if they are public) and let us have a look.

Rick

New Member

Re: Problems with HDA and FXS ports

Here's the config. The only other thing I had tried was putting a station id on the voice-port, but that didn't help either.

Mark

version 12.2

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname knox2gv

!

logging buffered 20000 debugging

enable secret

enable password

!

voice-card 1

!

ip subnet-zero

!

!

no ip domain-lookup

ip host cisco 172.16.50.78

ip dhcp excluded-address 172.30.0.1 172.30.0.20

!

ip dhcp pool IPphones

network 172.30.0.0 255.255.0.0

option 150 ip 172.16.150.2

default-router 172.30.0.1

dns-server

!

ipx routing 0002.fd2c.4a00

!

!

!

!

!

!

fax interface-type fax-mail

mta receive maximum-recipients 0

ccm-manager switchback immediate

!

!

!

!

interface FastEthernet0/0

description interface FastEthernet0/0

ip address 172.30.0.1 255.255.0.0

speed auto

half-duplex

ipx encapsulation SAP

ipx network 10

h323-gateway voip interface

h323-gateway voip bind srcaddr 172.30.0.1

!

interface Serial0/0

ip address 192.168.0.2 255.255.255.252

ipx network B004

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.0.1

no ip http server

!

dialer-list 1 protocol ip permit

dialer-list 1 protocol ipx permit

!

!

!

!

call rsvp-sync

!

voice-port 1/0/0

!

voice-port 1/0/1

!

voice-port 1/0/2

!

voice-port 1/0/3

!

voice-port 1/0/4

connection plar 5001

!

voice-port 1/0/5

connection plar 5001

!

voice-port 1/0/6

connection plar 5001

!

voice-port 1/0/7

connection plar 5001

!

voice-port 1/0/14

connection plar 5001

!

voice-port 1/0/15

connection plar 5001

!

voice-port 1/0/16

connection plar 5001

!

voice-port 1/0/17

shutdown

!

!

mgcp profile default

!

dial-peer cor custom

!

!

!

dial-peer voice 1 pots

destination-pattern 49.

port 1/0/4

!

dial-peer voice 2 voip

destination-pattern .

session target ipv4:172.16.150.2

dtmf-relay h245-alphanumeric

codec g711ulaw

no vad

!

dial-peer voice 3 pots

preference 1

destination-pattern 49.

port 1/0/5

!

dial-peer voice 4 pots

preference 2

destination-pattern 49.

port 1/0/6

!

dial-peer voice 5 pots

preference 3

destination-pattern 49.

port 1/0/7

!

dial-peer voice 5080 pots

destination-pattern 5080

port 1/0/0

!

dial-peer voice 5081 pots

destination-pattern 5081

port 1/0/1

!

dial-peer voice 5082 pots

destination-pattern 5082

port 1/0/2

!

!

call-manager-fallback

ip source-address 172.30.0.1 port 2000 strict-match

max-ephones 24

max-dn 50

access-code fxo 9

!

alias exec sii show ip int brief

alias exec sdp show dial-peer voice summary

alias exec svp show voice port summary

!

line con 0

line aux 0

line vty 0 4

password

login

line vty 5 15

login

!

no scheduler allocate

!

end

New Member

Re: Problems with HDA and FXS ports

Did you check if the destination-pattern under the pots dial-peer is configured

properly?

New Member

Re: Problems with HDA and FXS ports

I don't understand the question. The FXS ports on the HDA are 1/0/0 - 1/0/3. The dial-peer 5050 pots is pointed to port 1/0/0 and 5051 is pointed to 1/0/1. Now correct me if I'm wrong, but with an analog phone connected to port 1/0/0 I should be able to dial 5051 since there is a dial-peer for that number pointed to port 1/0/1. As soon as I dial the "5" I get a reorder tone. The same goes for the "4" when I try to dial "49". I know the FXO ports work because the IP phones use them for incoming and outgoing calls. At first I thought it was a problem with the call manager not knowing about the DN number of the FXS port, but that shouldn't come into play when going from one FXS port to another FXS port. I'm at a loss.

Mark

New Member

Re: Problems with HDA and FXS ports

I would do a debug - debug voice ccapi inout - and watch what peer the calls match. It may be matching your VOIP peer since you have a "." (dot). Dial peers on H.323 gateways do not hit closest match necessarily - they grab the first match and go. I'm not sure what order they follow; maybe someone out there can elaborate.

New Member

Re: Problems with HDA and FXS ports

Can you please cut&paste the dial-peer configs - thanks

New Member

Re: Problems with HDA and FXS ports

dial-peer voice 1 pots

destination-pattern 49.

port 1/0/4

!

dial-peer voice 2 voip

destination-pattern .

session target ipv4:172.16.150.2

dtmf-relay h245-alphanumeric

codec g711ulaw

no vad

!

dial-peer voice 3 pots

preference 1

destination-pattern 49.

port 1/0/5

!

dial-peer voice 4 pots

preference 2

destination-pattern 49.

port 1/0/6

!

dial-peer voice 5 pots

preference 3

destination-pattern 49.

port 1/0/7

!

dial-peer voice 5080 pots

destination-pattern 5080

port 1/0/0

!

dial-peer voice 5081 pots

destination-pattern 5081

port 1/0/1

!

dial-peer voice 5082 pots

destination-pattern 5082

port 1/0/2

New Member

Re: Problems with HDA and FXS ports

I find it useful to do a

router# show dialplan number 5081

and see what dial-peers match the dial-pattern. If you have more than one matching, make sure the one you want has a better preference ...

110
Views
5
Helpful
8
Replies
CreatePlease to create content