Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Problems with outgoing Calls on E1 Gateway

Hi,

I am having a problem with making outside calls to the PSTN. I have a 2851 router with a VWIC-1MFT-E1 Card as a gateway. Below is my config:

version 12.4

!

!

ip cef

!

isdn switch-type primary-net5

!

voice-card 0

no dspfarm

!

!

!

controller E1 0/0/0

pri-group timeslots 1-31

description PRI Access Tel # 2609700

!

!

interface Loopback0

description Gestao

ip address 10.72.110.70 255.255.255.255

h323-gateway voip interface

h323-gateway voip id GK-PRA-PALJ ipaddr 10.0.110.2 1718 priority 100

h323-gateway voip h323-id PRA-PALJ

h323-gateway voip tech-prefix 7#

h323-gateway voip bind srcaddr 10.72.110.70

!

!

interface Serial0/0/0:15

no ip address

isdn switch-type primary-net5

isdn incoming-voice voice

no cdp enable

!

no ip http server

no ip http secure-server

!

!

!

voice-port 0/0/0:15

cptone PT

!

!

mgcp bind media source-interface Loopback0

!

!

!

dial-peer voice 1 pots

description *** Primary Line for PSTN Calling ***

destination-pattern 0T

progress_ind setup enable 3

progress_ind alert enable 8

progress_ind progress enable 8

progress_ind connect enable 8

direct-inward-dial

port 0/0/0:15

!

dial-peer voice 2 voip

description *** Primary Target for Incoming PSTN Calls ***

destination-pattern .T

session target ipv4:10.72.154.2

dtmf-relay h245-alphanumeric

!

!

end

when I try to make an outside call I get the following output from a q931 debug:

ST_PR_PALJ_RA_W1#csim start 02607999

csim: called number = 02607999, loop count = 1 ping count = 0

csim err:csim_do_test invalid major major(16) minor(0)

csim: loop = 1, failed = 0

csim: call attempted = 1, setup failed = 0, tone failed = 0

ST_PR_PALJ_RA_W1#

Oct 2 13:14:28.488: ISDN Se0/0/0:15 Q931: Applying typeplan for sw-type 0x12 is 0x0 0x0, Called num 2607999

Oct 2 13:14:28.488: ISDN Se0/0/0:15 Q931: TX -> SETUP pd = 8 callref = 0x0086

Bearer Capability i = 0x8090A3

Standard = CCITT

Transfer Capability = Speech

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA9839F

Exclusive, Channel 31

Called Party Number i = 0x80, '2607999'

Plan:Unknown, Type:Unknown

Oct 2 13:14:28.492: ISDN Se0/0/0:15 Q931: TX -> DISCONNECT pd = 8 callref = 0x0086

Cause i = 0x80AF - Resource unavailable, unspecified

Oct 2 13:14:28.524: ISDN Se0/0/0:15 Q931: RX <- CALL_PROC pd = 8 callref = 0x8086

Channel ID i = 0xA9839F

Exclusive, Channel 31

Oct 2 13:14:28.524: ISDN Se0/0/0:15 **ERROR**: Ux_BadMsg: Invalid Message for call state 11, call id 0x8014, call ref 0x86, event 0x2

Oct 2 13:14:28.524: ISDN Se0/0/0:15 Q931: TX -> STATUS pd = 8 callref = 0x0086

Cause i = 0x80E202 - Message not compatible with call state or not implemented

Call State i = 0x0B

Oct 2 13:14:28.564: ISDN Se0/0/0:15 Q931: RX <- RELEASE pd = 8 callref = 0x8086

Oct 2 13:14:28.564: ISDN Se0/0/0:15 Q931: TX -> RELEASE_COMP pd = 8 callref = 0x0086

Note that there is a TX -> DISCONNECT before the ANY response from the switch. What could be causing this?

I am not sure what is wrong here.

Thanks in advance,

Djassi

8 REPLIES
Silver

Re: Problems with outgoing Calls on E1 Gateway

You dialed 02607999, but the digits send to the PSTN are 2607999. Is the PSTN expecting the leading 0. If yes, then add the following command to dial-peer 1

dial-peer voice 1 pots

prefix 0

Regards,

Anup

New Member

Re: Problems with outgoing Calls on E1 Gateway

hi anup, thanks for your reply, but the intended numbers are without the leading 0. The dial peer is configured to drop the leading zero so that the only number that goes through is 2607999.

Thanks again for your help

Djassi

Silver

Re: Problems with outgoing Calls on E1 Gateway

It can be a problem with the channel selection order, as I can see at your debug there router can't complete the call because there is no resource available, it's trying to use the channel 31. You can configure the router to select the channel 0 first with the command "isdn bchan-number-order ascending" at the interface Serial0/0/0:15 level. Please, let me know if this works for you, if it doesn't works, would you mind to post the output of the "debug isdn q931"?

Regards

New Member

Re: Problems with outgoing Calls on E1 Gateway

Hi icabrera, thanks for your post I added the command as you can see here but the problem remained:

Serial 0/0/0:15 config:

ST_PR_PALJ_RA_W1#sh run int serial0/0/0:15

Building configuration...

Current configuration : 156 bytes

!

interface Serial0/0/0:15

no ip address

isdn switch-type primary-net5

isdn incoming-voice voice

isdn bchan-number-order ascending

no cdp enable

end

q931 debug:

Oct 2 17:52:03.301: ISDN Se0/0/0:15 Q931: Applying typeplan for sw-type 0x12 is 0x0 0x0, Called num 2607999

Oct 2 17:52:03.301: ISDN Se0/0/0:15 Q931: TX -> SETUP pd = 8 callref = 0x009F

Bearer Capability i = 0x8090A3

Standard = CCITT

Transfer Capability = Speech

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA98381

Exclusive, Channel 1

Called Party Number i = 0x80, '2607999'

Plan:Unknown, Type:Unknown

Oct 2 17:52:03.305: ISDN Se0/0/0:15 Q931: TX -> DISCONNECT pd = 8 callref = 0x009F

Cause i = 0x80AF - Resource unavailable, unspecified

Oct 2 17:52:03.333: ISDN Se0/0/0:15 Q931: RX <- SETUP_ACK pd = 8 callref = 0x809F

Channel ID i = 0xA98381

Exclusive, Channel 1

Oct 2 17:52:03.333: ISDN Se0/0/0:15 **ERROR**: Ux_BadMsg: Invalid Message for call state 11, call id 0x802D, call ref 0x9F, event 0xD

Oct 2 17:52:03.337: ISDN Se0/0/0:15 Q931: TX -> STATUS pd = 8 callref = 0x009F

Cause i = 0x80E20D - Message not compatible with call state or not implemented

Call State i = 0x0B

Oct 2 17:52:03.409: ISDN Se0/0/0:15 Q931: RX <- RELEASE pd = 8 callref = 0x809F

Oct 2 17:52:03.409: ISDN Se0/0/0:15 Q931: TX -> RELEASE_COMP pd = 8 callref = 0x009F

again note that my end sends a disconnect before any response from the isdn switch, doen't that seem strange to you?

Thanks again

Re: Problems with outgoing Calls on E1 Gateway

Hello,

Are you able to receive inbound calls just fine ? Did you try what Anup suggested ? Is the telco expecting a leading 0 ?

New Member

Re: Problems with outgoing Calls on E1 Gateway

Hi Shanky :)

The telco is not expecting the leading 0, the dial peer is correct, but I also cannot receive incoming calls, I am actually troubleshooting it as I am responding to you... I am starting to think that there is a problem with the telco's switch. because on the inbound calls the destination number is missing the first number... In Cape Verde where we are... the numbering starts with 2 for the land lines, and 9 for the cell numbers. Then 21-87 for the municipalities and then the local numbers... so it's composed by 7 numbers. Here is what I am getting from a isdn q931 debug on an incoming call

Oct 2 18:08:23.823: ISDN Se0/0/0:15 Q931: RX <- SETUP pd = 8 callref = 0x0014

Sending Complete

Bearer Capability i = 0x8090A3

Standard = CCITT

Transfer Capability = Speech

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA98381

Exclusive, Channel 1

Calling Party Number i = 0x0083, '9926379'

Plan:Unknown, Type:Unknown

Called Party Number i = 0x81, '609728'

Plan:ISDN, Type:Unknown

High Layer Compat i = 0x9181

Oct 2 18:08:23.835: ISDN Se0/0/0:15 SERROR: process_pri_simple: NO name in GTD

Oct 2 18:08:23.835: ISDN Se0/0/0:15 Q931: TX -> CALL_PROC pd = 8 callref = 0x8014

Channel ID i = 0xA98381

Exclusive, Channel 1

Oct 2 18:08:35.300: ISDN Se0/0/0:15 Q931: RX <- DISCONNECT pd = 8 callref = 0x0014

Cause i = 0x8090 - Normal call clearing

Oct 2 18:08:35.304: ISDN Se0/0/0:15 Q931: TX -> RELEASE pd = 8 callref = 0x8014

Oct 2 18:08:35.320: ISDN Se0/0/0:15 Q931: RX <- RELEASE_COMP pd = 8 callref = 0x0014

as you can see the called party number is only 6 digits. it should be 2609728.

Thanks again guys,

Djassi

New Member

Re: Problems with outgoing Calls on E1 Gateway

Hi Djassi,

could you send this commands:

sh e1 controll

sh isdn stat

sh isdn servi

just to see if the E1 is clear.

Greetings

Rodrigo

Silver

Re: Problems with outgoing Calls on E1 Gateway

Hi Djassi, I agree with you, I think it's a problem with the telco switch. With outbounds call the router is releasing the call because it's expecting some capabilities exchange with the switch that it doesn't happen and with inbound calls the problem is different. Try to check with your provider the setup.

982
Views
0
Helpful
8
Replies