Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Push2Phone ASP script issues

I implemented the Push2Phone asp script as part of the IP Services SDK. I was able to configure the script properly and was able to push text messages to phones, including my own. Recently, I accidently deleted my IP phone in CCM Admin. I have been able to reconfigure the phone and it works properly now as it did before, but Push2Phone will not work for my phone. When I try to send a message to it, I receive an HTTP 500 error. My phone's description does show up in the initial listing of phones, so it seems the script can communicate with the CCM. I can send messages to other phones, but not mine. Any ideas?

Thanks a bunch.

5 REPLIES
Silver

Re: Push2Phone ASP script issues

Did you make sure that you associated the user with the "new" phone definition? The link may have been lost when you deleted the IP phone definition from CCM Admin...

New Member

Re: Push2Phone ASP script issues

Yes, I did reassociate my user with the phone. I didn't think that was even an issue. I thought the script based it all on the description and MAC of the phone and not the user. Any other ideas? Thanks again.

Silver

Re: Push2Phone ASP script issues

In order to push anything to the phone, you must have permission to do so. You get this permission through a user account that is associated with the phone (i.e. is authorized to "use" the phone). That is what I meant there, sorry for any confusion.

Therefore, you need to ensure that the user account used by push2phone to push services to the phones is associated with that particular phone. The other phones are probably still linked correctly (which is why they still work in push2phone), while the "new" phone is not (which is my guess on why it does not work).

One further suggestion is to turn off "friendly http error messages" in IE's options dialog, which may return more detailed information on why the script is failing.

Sorry if this is just re-iterating something you already know.. it's just my guess based on your description of the events and the problem. Hope it's of some help!

New Member

Re: Push2Phone ASP script issues

It works. Now I understand what you meant about associating the user. Once I did that and thought about it, it now sends messages to my phone. Thanks alot for the help.

New Member

Re: Push2Phone ASP script issues

Hi Richard,

I have similar problem - almost similar problem. I am unable to push text to the phone - when i hit submit to send a text - the phone plays "ding-dong" sound but no text on the phone LCD. I am using 7960 and 7940 phones. Any idea?

152
Views
0
Helpful
5
Replies
CreatePlease to create content