Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Push2Phone Service: Plays an alert sound but no text

I am unable to push text to the phone - when i select the MAC address of an IP Phone and hit "Submit" to send a text - the phone plays "ding-dong" sound but no text on the IP phone LCD screen. I am using 7960 and 7940 phones.

Help Please!

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Re: Push2Phone Service: Plays an alert sound but no text

I forgot something, in addition I replaced one line in the push2phone.asp

I replaced this line:

phonePush2(ipAddr, thispage + "?action=get", "Play:chime.raw", pushuserid, pushpassword);

with this line:

phonePush2(ipAddr, "http://X.X.X.X/CiscoIPServices/push2phone/push2phone.asp" + "?action=get", "Play:chime.raw", pushuserid, pushpassword);

I replaced this line because I was having problems with the application to redirect to the correct address, you have to replace X.X.X.X with your server's ip.

If you notice, the second URI it is executed on the phone (the sound) but the first one isn't (the text) you can substitute the first URI with another URL that is working for you and then you can see if both command are executed fine. This was one of the first debugging tests I made.

Tell me if it works,

Manuel Torres

8 REPLIES
New Member

Re: Push2Phone Service: Plays an alert sound but no text

Can you post the XML you are sending? This might help.

New Member

Re: Push2Phone Service: Plays an alert sound but no text

I am using canned Cisco IP Phone Services SDK's "Push2Phone" service of course customized with right authentication parameters.

New Member

Re: Push2Phone Service: Plays an alert sound but no text

In your push2phone.asp file find the line:

alertCIP += xmlDoc.xml;

Now check your directory where your push2phone.asp file is located....i bet you don't have that file in there. Just rename the alertdetail.xml to xmlDoc.xml and you should be all set.

New Member

Re: Push2Phone Service: Plays an alert sound but no text

That did not help - are you willing to share your push2phone.asp and all .xml files with me? I just want to compare your file with mine to see if i missed anything.

sacharya@olivetcollege.edu

New Member

Re: Push2Phone Service: Plays an alert sound but no text

I spent many hours trying to figure out this and I solve it replacing 2 lines in the phonepush.asp.

----------------------------------------------------------------------------

Replace this line: located @ function phonePush

pushxml = "";

----------------------------------------------------------------------------

With this line:

pushxml = "\n\n" + "";

----------------------------------------------------------------------------

And also replace this line: located @ function phonePush2

pushxml = "";

----------------------------------------------------------------------------

With this one:

pushxml = "\n\n" + "\n" + "";

----------------------------------------------------------------------------

Let me know if it works for you.

Manuel Torres

New Member

Re: Push2Phone Service: Plays an alert sound but no text

Manuel,

I tried your suggestion, but still no success.

It sounds like the script is not even parsing the text that i entered.

I am running out of options.

thanks for your help in advance.

sa

New Member

Re: Push2Phone Service: Plays an alert sound but no text

I forgot something, in addition I replaced one line in the push2phone.asp

I replaced this line:

phonePush2(ipAddr, thispage + "?action=get", "Play:chime.raw", pushuserid, pushpassword);

with this line:

phonePush2(ipAddr, "http://X.X.X.X/CiscoIPServices/push2phone/push2phone.asp" + "?action=get", "Play:chime.raw", pushuserid, pushpassword);

I replaced this line because I was having problems with the application to redirect to the correct address, you have to replace X.X.X.X with your server's ip.

If you notice, the second URI it is executed on the phone (the sound) but the first one isn't (the text) you can substitute the first URI with another URL that is working for you and then you can see if both command are executed fine. This was one of the first debugging tests I made.

Tell me if it works,

Manuel Torres

New Member

Re: Push2Phone Service: Plays an alert sound but no text

It worked!! It worked!! Thank you Manuel - very very much. Thanks again for your help.

sa

245
Views
0
Helpful
8
Replies