Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Q931 alerting or progress on auto answered calls?

Hi,

We have issues with a no-audio path on some calls when the phone is forwarded to voicemail (CfWAll).

The PSTN guy (DMS-100) says that he needs to see alerting or progress, but we are no sending it as it answers immediately.

We have a MGCP gateway, but a TpCall voicemail which connects on H225 intercluster trunk...

This is the Q931, but is the same for calls with or without audio.

(calls from within the DMS-100 have audio, external don't)

Nov 12 12:54:16: ISDN Se1/0:15 Q931: RX <- SETUP pd = 8 callref = 0x0215

Bearer Capability i = 0x8090A3

Standard = CCITT

Transfer Capability = Speech

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA1839E

Preferred, Channel 30

Facility i = 0x91A12102018D02010F30190201010A0101A111A00FA10D0A010212083433383237333137

Protocol Profile = Remote Operations Protocol

0xA12102018D02010F30190201010A0101A111A00FA10D0A010212083433383237333137

Component = Invoke component

Invoke Id = 65421

Operation = Diversion Leg2

Calling Party Number i = 0x2180, '<removed>'

Plan:ISDN, Type:National

Called Party Number i = 0xC1, '<removed>'

Plan:ISDN, Type:Subscriber(local)

Sending Complete

Nov 12 12:54:16: ISDN Se1/0:15 Q931: TX -> CALL_PROC pd = 8 callref = 0x8215

Channel ID i = 0xA9839E

Exclusive, Channel 30

Nov 12 12:54:16: ISDN Se1/0:15 Q931: TX -> CONNECT pd = 8 callref = 0x8215

Nov 12 12:54:21: ISDN Se1/0:15 Q931: RX <- DISCONNECT pd = 8 callref = 0x0215

Cause i = 0x8090 - Normal call clearing

Nov 12 12:54:21: ISDN Se1/0:15 Q931: TX -> RELEASE pd = 8 callref = 0x8215

Nov 12 12:54:21: ISDN Se1/0:15 Q931: RX <- RELEASE_COMP pd = 8 callref = 0x0215

Anyone any ideas if the guy from PSTN is right?

thnx

1 REPLY
Bronze

Re: Q931 alerting or progress on auto answered calls?

sascha,

could you have a problem with DSPs ?

I had same problems (without tpcall) with some dsps

on the Gateway. After connect message we had dead air..

the only way to check this, is making a call on all b-channels and writing down the channel number to find the associated dsp..

good luck..

mehmet

141
Views
0
Helpful
1
Replies
CreatePlease login to create content