Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

QoS and voice signaling on TCCS interconnection

Hello,

I try to connect 2 PBX using Transparent Clear Channel Signaling. It works!! Now I want to implement Qos for it.

We use a frame-relay link. I want to know which way is the best to use: LLQ or frame relay ip rtp priority?

How can we match the voice-signaling in order to make a voice-signaling class?

Is it enough if we put the ip precedence 5 on the dial peer interface in order to tag the voice packets? (voice + signaling)

Thank you

2 REPLIES
New Member

Re: QoS and voice signaling on TCCS interconnection

QoS depends on your network setup and also on your IOS. LLQ works far better than IP RTP PRIORITY and gives you much more flexibility. IP precedence 5 on all voip peers should be added but is not sufficient to guarantee voice delivery prior to data so LLQ or some other method is a must along with FRTS (Frame Relay Traffic Shaping). Below is a URL with sample configs on LLQ and FR:

You can modify the class-maps to define any class of traffic to be prioritized and be sure not to allocate more than 75% of the link bandwidth at all times.

http://www.cisco.com/warp/customer/788/voice-qos/voip-ov-fr-qos.html

Look under LLQ (above)

------

You can add this CLI for voice signaling, define a new access-list 102 so you have:

access-list 102 permit udp any any range 16384 37276

access-list 102 permit tcp any any eq 1720

!

since signaling for H323 is on TCP port 1720 this should cover it. Rest of configs is the same as URL.

Hope this helps.

New Member

Re: QoS and voice signaling on TCCS interconnection

Actually, here is the configuration

______ _____ _____ _____

| PBX |---E1-----| 7200 |-----Frame Relay 2 Mbps-----| 7200 |--E1-----| PBX |

The voice packets come from the PBX , not from a LAN.

Why the "ip precedence 5" won't be sufficient?

What is the bandwidth necessary for the voice signaling? I calculate that I need:

30 x 12kbps (for voice channels with CRTP) + 80kbps (for voice sig)

Am I completely wrong?

Do you think a configuration like that will be good?

class-map voice

match access-group 101

!

access-list 101 permit udp any any range 16384 32767

access-list 101 permit tcp any any eq 1720

access-list 101 permit ip any any precedence 5

!

policy-map mypolicy

class voice

priority 440

class class-default

fair-queue

!

interface Serial1/0.1 point-to-point

ip address....

frame-relay ip rtp header-compression

frame-relay interface-dlci 100

class voipFR

!

map-class frame-relay voipFR

no frame-relay adaptive-shaping

frame-relay cir 1920000

frame-relay mincir 192000

frame-relay bc 1920

service-policy output mypolicy

dial-peer voice 2 voip

destination-pattern 6000

session target ipv4:192.168.10.1

ip precedence 5

....

Thank you for you help

280
Views
0
Helpful
2
Replies
CreatePlease login to create content