Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

QOS at Branch Router

We are deploying our first remote site and are experiencing problems with call quality. In reference to the document 78-11549 "Cisco IP Telephony QOS Design Guide" we implemented several QOS functions on layer 2 and are currently implementing them on layer 3. When we applied the Traffic Shapping (reference page 5-27 in document) we lost the ability to do almost everything including telnet to the router over the Serial Interface. Here is an example config from our router:

Current configuration : 3705 bytes

!

version 12.1

no service single-slot-reload-enable

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname router-wcm1

!

logging rate-limit console 10 except errors

enable secret 5 password

enable password 7 password

!

!

!

ip subnet-zero

!

!

no ip finger

ip host ccm1 10.x.1.252

ip host ccm2 10.x.1.253

!

!

class-map match-all VoIP-Control

match access-group 101

class-map match-all VoIP-RTP

match access-group 100

!

!

policy-map QoS-Policy-512k

class VoIP-RTP

priority 100

class VoIP-Control

bandwidth 8

class class-default

fair-queue

!

!

!

!

!

!

!

ccm-manager redundant-host ccm1

ccm-manager mgcp

!

!

!

!

interface Ethernet0/0

ip address 172.x.17.1 255.255.255.0

full-duplex

!

interface Serial0/0

no ip address

encapsulation frame-relay

frame-relay traffic-shaping

no ip mroute-cache

load-interval 30

no fair-queue

cdp enable

!

interface Serial0/0.195 point-to-point

ip address 10.x.16.2 255.255.255.252

no ip mroute-cache

frame-relay class VoIP-512kbs

frame-relay interface-dlci 195 CISCO

frame-relay ip rtp header-compression passive

!

router eigrp 15

network 10.x.0.0 0.0.255.255

network 172.x.17.0 0.0.0.255

no auto-summary

no eigrp log-neighbor-changes

!

ip default-gateway 10.x.16.1

ip classless

ip route 0.0.0.0 0.0.0.0 10.x.16.1

no ip http server

!

!

map-class frame-relay VoIP-512kbs

no frame-relay adaptive-shaping

frame-relay cir 512000

frame-relay bc 1000

frame-relay be 0

frame-relay mincir 512000

service-policy output QoS-Policy-512k

frame-relay fragment 128

logging 172.x.1.x

access-list 100 permit ip any any precedence critical

access-list 100 permit ip any any dscp ef

access-list 101 permit ip any any precedence flash

access-list 101 permit ip any any dscp af31

!

!

snmp-server engineID local

snmp-server community

snmp-server community

snmp-server packetsize 4096

call rsvp-sync

!

voice-port 1/0/0

!

voice-port 1/0/1

!

voice-port 1/1/0

!

voice-port 1/1/1

!

mgcp

mgcp call-agent ccm2 service-type mgcp version 0.1

no mgcp timer receive-rtcp

!

mgcp profile default

!

dial-peer cor custom

!

!

!

dial-peer voice 1 pots

application mgcpapp

port 1/0/0

!

dial-peer voice 2 pots

application mgcpapp

port 1/0/1

!

dial-peer voice 3 pots

application mgcpapp

port 1/1/0

!

dial-peer voice 4 pots

application mgcpapp

port 1/1/1

!

dial-peer voice 100 pots

destination-pattern 9.+

port 1/0/0

!

dial-peer voice 200 pots

destination-pattern 9.+

port 1/0/1

!

dial-peer voice 300 pots

destination-pattern 9.+

port 1/1/0

!

dial-peer voice 400 pots

destination-pattern 9.+

port 1/1/1

!

!

call-manager-fallback

ip source-address 172.x.17.1 port 2000

max-ephones 24

max-dn 48

!

banner motd ^C

*****************************************

* *

* All access is logged and monitored. *

* Any unauthorized access will be *

* prosecuted to the fullest extent *

* allowed by the laws of the *

* United States of America. *

* *

*****************************************

^C

!

line con 0

transport input none

line aux 0

line vty 0 4

password 7 password

login

!

no scheduler allocate

end

I assumed that the access lists may have had something to do with it so I attempted adding

access-list 10x permit ip any any

to the end of both access lists. This did not resolve the issue. Any assistance or pointers toward more documentation on QOS for AVVID is appreciated.

Matthew Pickens

  • Other Collaboration Voice and Video Subjects
2 REPLIES
Cisco Employee

Re: QOS at Branch Router

I assume that you configured frame-relay traffic-shaping on both ends of the connection, and that both map-classes were using the same fragment size of 128 ?

Also why did you choose a fragment size of 128? For a 512kbps PVC if that is really your true CIR then you should be able to use a fragment size of up to 480 bytes. (80 bytes per 64 kbps)

New Member

Re: QOS at Branch Router

Two errors I saw in the traffic shaping parameters, are Bc should be 5120 and fragmentation should be 640.

The formula for Bc is Bc=CIR(Tc/1000), where Tc is the desired serialization (shoot for 10ms in voice and 125ms in data).

The formula for fragmentation is 80k for every 64k in clock speed. So 512/64(80)=640k.

That will fix your problem.

Steve

181
Views
0
Helpful
2
Replies
This widget could not be displayed.