Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

QoS for Voice on an ADSL connection (Dialer interface)

1st of all sorry for crosspost, this is going to be more familliar with Voice people I think.

I have a lot of satelite sites with a simple ADSL cisco set-up (either 877/837 or in this case 1721) The config is identical, what is happening is that queueing never happens on the dialer interface under congestion so the voice traffic never gets prioritised and the call gets "choppy".

I am sure I am not the only person who needs QoS working on a dialer interface!

I have attached the relevant bits of the config (minus the VPN stuff) and here is the output of the policy map:-

peter#sh policy-map interface d1

Dialer1

Service-policy output: VOICE-POLICY

Class-map: voice-traffic (match-all)

463726 packets, 98224103 bytes

30 second offered rate 0 bps, drop rate 0 bps

Match: access-group name voice_traffic

Queueing

Strict Priority

Output Queue: Conversation 72

Bandwidth 50 (%)

Bandwidth 128 (kbps) Burst 3200 (Bytes)

(pkts matched/bytes matched) 0/0

(total drops/bytes drops) 0/0

QoS Set

dscp ef

Packets marked 416124

Class-map: voice-signaling (match-all)

42905 packets, 3491605 bytes

30 second offered rate 0 bps, drop rate 0 bps

Match: access-group name voice_control

Queueing

Output Queue: Conversation 73

Bandwidth 8 (kbps) Max Threshold 64 (packets)

(pkts matched/bytes matched) 0/0

(depth/total drops/no-buffer drops) 0/0/0

Class-map: citrix (match-all)

571327 packets, 47176156 bytes

30 second offered rate 0 bps, drop rate 0 bps

Match: access-group name citrix_traffic

Queueing

Output Queue: Conversation 74

Bandwidth 24 (kbps) Max Threshold 64 (packets)

(pkts matched/bytes matched) 0/0

(depth/total drops/no-buffer drops) 0/0/0

Class-map: telnet (match-all)

218 packets, 27700 bytes

30 second offered rate 0 bps

Match: access-group name telnet_traffic

Class-map: class-default (match-any)

7232707 packets, 4460899597 bytes

30 second offered rate 5000 bps, drop rate 0 bps

Match: any

Queueing

Flow Based Fair Queueing

Maximum Number of Hashed Queues 64

(total queued/total drops/no-buffer drops) 0/0/0

As can be seen, it never queues ANY traffic. An adentical config using an ethernet interface works no problem (in that case the Internet connection is presented as Ethernet, but it is not normal to do so now in the UK with ADSL)

Does anyone have a working config?

Thanks,

Peter

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Re: QoS for Voice on an ADSL connection (Dialer interface)

Here is my working 877 QoS configuration.

class-map match-any Call-Signaling

match ip dscp cs3

match ip dscp af31

class-map match-any Routing

match ip dscp cs6

class-map match-any Voice

match ip dscp ef

!

!

policy-map V3PN_Teleworker_Out

class Voice

priority 90

class Routing

bandwidth percent 5

class Call-Signaling

bandwidth percent 5

class class-default

fair-queue

random-detect

interface ATM0

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip route-cache flow

no atm ilmi-keepalive

dsl operating-mode auto

!

interface ATM0.1 point-to-point

no ip redirects

no ip unreachables

no ip proxy-arp

no snmp trap link-status

pvc 0/35

vbr-nrt 384 384

tx-ring-limit 3

service-policy output V3PN_Teleworker_Out

pppoe-client dial-pool-number 1

interface Dialer0

ip address negotiated

ip access-group Outside_Inbound in

no ip redirects

no ip unreachables

no ip proxy-arp

ip mtu 1452

ip nbar protocol-discovery

ip nat outside

ip inspect IOS_FW out

ip ips sdm_ips_rule in

ip virtual-reassembly

encapsulation ppp

ip route-cache flow

dialer pool 1

dialer-group 1

fair-queue

no cdp enable

ppp authentication chap pap callin

ppp chap hostname

ppp chap password

ppp pap sent-username password

dialer-list 1 protocol ip permit

Rate this if it helps.

Matt

6 REPLIES
Bronze

Re: QoS for Voice on an ADSL connection (Dialer interface)

New Member

Re: QoS for Voice on an ADSL connection (Dialer interface)

Here is my working 877 QoS configuration.

class-map match-any Call-Signaling

match ip dscp cs3

match ip dscp af31

class-map match-any Routing

match ip dscp cs6

class-map match-any Voice

match ip dscp ef

!

!

policy-map V3PN_Teleworker_Out

class Voice

priority 90

class Routing

bandwidth percent 5

class Call-Signaling

bandwidth percent 5

class class-default

fair-queue

random-detect

interface ATM0

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip route-cache flow

no atm ilmi-keepalive

dsl operating-mode auto

!

interface ATM0.1 point-to-point

no ip redirects

no ip unreachables

no ip proxy-arp

no snmp trap link-status

pvc 0/35

vbr-nrt 384 384

tx-ring-limit 3

service-policy output V3PN_Teleworker_Out

pppoe-client dial-pool-number 1

interface Dialer0

ip address negotiated

ip access-group Outside_Inbound in

no ip redirects

no ip unreachables

no ip proxy-arp

ip mtu 1452

ip nbar protocol-discovery

ip nat outside

ip inspect IOS_FW out

ip ips sdm_ips_rule in

ip virtual-reassembly

encapsulation ppp

ip route-cache flow

dialer pool 1

dialer-group 1

fair-queue

no cdp enable

ppp authentication chap pap callin

ppp chap hostname

ppp chap password

ppp pap sent-username password

dialer-list 1 protocol ip permit

Rate this if it helps.

Matt

New Member

Re: QoS for Voice on an ADSL connection (Dialer interface)

Thanks for that, I didn't even thnk of using a subinterface! (tried unsucessfully on ATM) Doh!

You are a star.

peter.

New Member

Re: QoS for Voice on an ADSL connection (Dialer interface)

Arrgghh, just tried your config and when entering the service-policy on the subinterface I get much the same error as before :-

peter(config-subif)#service-policy output VOICE-POLICY

CBWFQ : Not supported on subinterfaces

but I just noticed that I have to enter the vbr-nrt command first, however I notice the maximum values appear to change depending on IOS/Router.

Can you explain what this relates to in regard ADSL connection, and ideally what difference it will make in connection? I tried command lookup but it wasn't too helpful.

New Member

Re: QoS for Voice on an ADSL connection (Dialer interface)

What software revision are you running on your routers? I know that there were alot of features, specifically in the 877 line that were only available in the advanced IP services version of the code.

For the 877 I know that both 12.4(4)T2 and 12.4(6)T support the above commands without a problems. As far as the 837, I know that 12.3(11)T10 supports the commands. These are the versions we are running. I am unsure about the 1700 series.

In regards to the vbr-nbt command, from what I understand you are supposed to set this to whatever your upstream bps is. In regards to what it actually does, I honestly cant remember what the instructer stated when he talked about this at networkers in 2004. Maybe someone else can elaborate. I am going to try and dig out my notes to give you a better explanation.

-Matt

New Member

Re: QoS for Voice on an ADSL connection (Dialer interface)

Thanks Matt,

from your reply I investigated further and found this :-

http://www.cisco.com/warp/public/121/atm_vbrshape.shtml

which explains the whole thing.

For some reason the vbr-nrt command needs entered before the service policy command or it does not accept it, which is where I was going wrong.

I found that it works on the ATM0 interface without subinterface for adsl, but the VBR peak value on a WIC1-ADSL can only be set to what the line syncs at (upload), so it is difficult to pre-write a config to give the best attainable value until it's installed..

I have yet to try my QoS config under congestion, but I am considering using the rate-limit command to limit all inbound traffic to =(maxdownloadspeed minus Max upload speed) in order to maximise available bandwidth, but I have no idea if this will work!

Again, thanks for your help here, this has been bugging me for some months now.

Cheers,

Peter.

835
Views
5
Helpful
6
Replies
CreatePlease to create content