Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Qos for Voice over Frame Relay

I have implemented Qos on three of the 3810 router that it supply voice traffic

to remoter site. Each remote sight router is connected to a Mitel pbx. If I do a show

access-list it does not show any matches. Any suggesting will be helpful. Here is how 3810 are configured. Thanks

class-map voip

match access-group 100

!

!

policy-map llq-policy

class voip

bandwidth 128

class class-default

fair-queue

!

interface Serial0:0

description WAN Frame Relay Circuit #2

no ip address

encapsulation frame-relay IETF

service-policy output llq-policy

cdp enable

frame-relay traffic-shaping

frame-relay lmi-type ansi

!

map-class frame-relay 256k

no frame-relay adaptive-shaping

frame-relay cir 256000

frame-relay bc 32000

frame-relay mincir 128000

!

map-class frame-relay VOFR

frame-relay voice bandwidth 256000

frame-relay fragment 320

no frame-relay adaptive-shaping

frame-relay cir 256000

frame-relay bc 2560

frame-relay be 0

frame-relay fair-queue

access-list 100 permit udp any any range 16384 32000

6 REPLIES
Blue

Re: Qos for Voice over Frame Relay

Change your class-map voip so you match on IP precedence, (or DSCP depending on IOS) and you will have better luck. The precedence or DSCP bits should already be set by your dial peers. Your config will be simplier, and even better, it will work.

Dave

Community Member

Re: Qos for Voice over Frame Relay

I posted the full config for both central and remoter router. I had thought about using

DSCP Is there any problem using both in the access-list group.

Community Member

Re: Qos for Voice over Frame Relay

I have looked high and low. The IOS version on the routers are 12.1.13 I see no reference to match ip precedence under a class-map.

Cisco Employee

Re: Qos for Voice over Frame Relay

Just to mention, i think the ip address is missing under the interface, unless you have omitted from the config..

Here is the link which will explain QoS for VoIP over frame-relay.

http://www.cisco.com/warp/public/788/voice-qos/voip-ov-fr-qos.html

Above link also explain how to verify that and troubleshooting.

Community Member

Re: Qos for Voice over Frame Relay

There were subinterfaces that I omitted. Below is the config of the Central Router and remote site

cENTRAL Router

Version 12 .1

clock timezone EDT -4

network-clock base-rate 64k

network-clock-select 1 T1 0

ip subnet-zero

no ip domain-lookup

!

!

controller T1 0

framing esf

linecode b8zs

channel-group 0 timeslots 1-24 speed 64

description WAN Frame Relay Circuit #2

!

controller T1 1

clock source loop-timed

linecode b8zs

mode cas

voice-group 1 timeslots 1-24 type e&m-wink-start

!

!

!

!

interface Ethernet0

description LAN link for Ops Center

ip address 192.168.x.x 255.255.255.0

!

interface Serial0

no ip address

no ip mroute-cache

shutdown

!

interface Serial1

no ip address

shutdown

!

interface Serial0:0

description WAN Frame Relay Circuit #2

no ip address

encapsulation frame-relay IETF

service-policy output llq-policy

cdp enable

frame-relay traffic-shaping

frame-relay lmi-type ansi

!

interface Serial0:0.1 point-to-point

description WAN Link Pasco Branch

ip address 192.168.X.X 255.255.255.252

frame-relay interface-dlci 16

class 256k

!

interface Serial0:0.2 point-to-point

description WAN Link Town & Country Branch

ip address 192.168.X.X 255.255.255.252

frame-relay interface-dlci 17

class 256k

!

interface Serial0:0.3 point-to-point

description WAN Link Largo Branch

ip address 192.168.X.X 255.255.255.252

frame-relay interface-dlci 18

class 256k

!

interface Serial0:0.4 point-to-point

description WAN Link Clearwater Branch

ip address 192.168.X.X 255.255.255.252

frame-relay interface-dlci 19

class 256k

!

interface Serial0:0.5 point-to-point

description WAN Link Temple Terrace Branch

ip address 192.168.X.X 255.255.255.252

frame-relay interface-dlci 20

class 256k

!

interface Serial0:0.6 point-to-point

description WAN Link Bradenton Branch

ip address 192.168.X.X 255.255.255.252

frame-relay interface-dlci 21

class VOFR

vofr cisco

!

interface Serial0:0.7 point-to-point

description WAN Link Spring Hill Branch

ip address 192.168.X.X 255.255.255.252

frame-relay interface-dlci 601

class VOFR

vofr cisco

!

interface BRI0

no ip address

shutdown

!

interface Switch0

no ip address

encapsulation frame-relay

no fair-queue

!

router eigrp 2

network 192.168.x.x

network 192.168.x.x

no auto-summary

no eigrp log-neighbor-changes

!

no ip http server

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.x.x

ip route 192.168.X.X 255.255.255.0 192.168.X.X

!

!

map-class frame-relay 256k

no frame-relay adaptive-shaping

frame-relay cir 256000

frame-relay bc 32000

frame-relay mincir 128000

!

map-class frame-relay VOFR

frame-relay voice bandwidth 256000

frame-relay fragment 320

no frame-relay adaptive-shaping

frame-relay cir 256000

frame-relay bc 2560

frame-relay be 0

frame-relay fair-queue

access-list 100 permit udp any any range 16384 32000

voice-port 1/1

timeouts call-disconnect 0

!

voice-port 1/2

timeouts call-disconnect 0

!

voice-port 1/3

timeouts call-disconnect 0

!

voice-port 1/4

timeouts call-disconnect 0

!

voice-port 1/5

timeouts call-disconnect 0

!

voice-port 1/6

timeouts call-disconnect 0

!

voice-port 1/7

timeouts call-disconnect 0

!

voice-port 1/8

timeouts call-disconnect 0

!

voice-port 1/9

timeouts call-disconnect 0

!

voice-port 1/10

timeouts call-disconnect 0

!

voice-port 1/11

timeouts call-disconnect 0

!

voice-port 1/12

timeouts call-disconnect 0

!

voice-port 1/13

timeouts call-disconnect 0

!

voice-port 1/14

timeouts call-disconnect 0

!

voice-port 1/15

timeouts call-disconnect 0

!

voice-port 1/16

timeouts call-disconnect 0

!

voice-port 1/17

timeouts call-disconnect 0

!

voice-port 1/18

timeouts call-disconnect 0

!

voice-port 1/19

timeouts call-disconnect 0

!

voice-port 1/20

timeouts call-disconnect 0

!

voice-port 1/21

timeouts call-disconnect 0

!

voice-port 1/22

timeouts call-disconnect 0

!

voice-port 1/23

timeouts call-disconnect 0

!

voice-port 1/24

timeouts call-disconnect 0

!

!

dial-peer voice 1 pots

forward-digits all

destination-pattern 42..

port 1/1

!

dial-peer voice 2 pots

forward-digits all

destination-pattern 42..

port 1/2

!

dial-peer voice 3 pots

forward-digits all

destination-pattern 42..

port 1/3

!

dial-peer voice 4 pots

forward-digits all

destination-pattern 42..

port 1/4

!

dial-peer voice 5 pots

forward-digits all

destination-pattern 42..

port 1/5

!

dial-peer voice 6 pots

forward-digits all

destination-pattern 42..

port 1/6

!

dial-peer voice 7 pots

forward-digits all

destination-pattern 42..

port 1/7

!

dial-peer voice 8 pots

forward-digits all

destination-pattern 42..

port 1/8

!

dial-peer voice 9 pots

forward-digits all

destination-pattern 42..

port 1/9

!

dial-peer voice 10 pots

forward-digits all

destination-pattern 42..

port 1/10

!

dial-peer voice 11 pots

forward-digits all

destination-pattern 42..

port 1/11

!

dial-peer voice 12 pots

forward-digits all

destination-pattern 42..

port 1/12

!

dial-peer voice 100 vofr

codec g729ar8

destination-pattern 40..

session target Serial0:0 601

!

dial-peer voice 25 pots

destination-pattern 9

port 1/1

!

dial-peer voice 26 pots

destination-pattern 9

port 1/2

!

dial-peer voice 27 pots

destination-pattern 9

port 1/3

!

dial-peer voice 28 pots

destination-pattern 9

port 1/4

!

dial-peer voice 29 pots

destination-pattern 9

port 1/5

!

dial-peer voice 30 pots

destination-pattern 9

port 1/6

!

dial-peer voice 31 pots

destination-pattern 9

port 1/7

!

dial-peer voice 32 pots

destination-pattern 9

port 1/8

!

dial-peer voice 33 pots

destination-pattern 9

port 1/9

!

dial-peer voice 34 pots

destination-pattern 9

port 1/10

!

dial-peer voice 35 pots

destination-pattern 9

port 1/11

!

dial-peer voice 36 pots

destination-pattern 9

port 1/12

!

dial-peer voice 101 vofr

codec g729ar8

destination-pattern 41..

session target Serial0:0 21

!

remote

version 12.1

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname remote

!

logging buffered 64000 debugging

enable secret 5 1234

!

class-map voip

match access-group 100

!

!

policy-map llq-policy

class voip

bandwidth 128

class class-default

fair-queue

!

network-clock base-rate 64k

network-clock-select 1 T1 0

ip subnet-zero

no ip domain-lookup

!

!

controller T1 0

framing esf

linecode b8zs

channel-group 0 timeslots 1-4 speed 64

description frame relay id# F4QRDA001114

!

controller T1 1

clock source loop-timed

linecode b8zs

mode cas

voice-group 1 timeslots 1-3 type e&m-wink-star

!

!

!

!

bstun peer-name 192.0.X.X

bstun protocol-group 203 bsc-local-ack

bstun remote-peer-keepalive

!

interface Ethernet0

description LAN Interface

ip address 192.0.X.X 255.255.255.0

no ip route-cache

no ip mroute-cache

!

interface Serial0

bandwidth 9

no ip address

encapsulation bstun

no ip route-cache

no ip mroute-cache

delay 1

no keepalive

clockrate 9600

bstun group 203

bsc primary

bstun route address 4D tcp 192.168.X.X

!

interface Serial1

no ip address

no ip route-cache

no ip mroute-cache

shutdown

!

interface Serial0:0

no ip address

encapsulation frame-relay

service-policy output llq-policy

frame-relay traffic-shaping

frame-relay lmi-type ansi

!

interface Serial0:0.1 point-to-point

ip address 192.168.X.X 255.255.255.252

frame-relay interface-dlci 16

class 256k

!

interface Serial0:0.2 point-to-point

ip address 192.168.X.X 255.255.255.252

frame-relay interface-dlci 17

class VOFR

vofr cisco

!

interface Switch0

no ip address

encapsulation frame-relay

no fair-queue

!

router eigrp 2

network 192.0.X.X

network 192.168.X.X

network 192.168.X.X

no auto-summary

no eigrp log-neighbor-changes

!

no ip http server

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.X.X

!

!

map-class frame-relay 256k

no frame-relay adaptive-shaping

frame-relay cir 256000

frame-relay bc 32000

frame-relay mincir 128000

!

map-class frame-relay VOFR

frame-relay voice bandwidth 256000

frame-relay fragment 320

no frame-relay adaptive-shaping

frame-relay cir 256000

frame-relay bc 2560

frame-relay be 0

frame-relay fair-queue

access-list 100 permit udp any any range 16384

!

omitted

!

!

voice-port 1/1

echo-cancel coverage 32

timeouts call-disconnect 0

!

voice-port 1/2

echo-cancel coverage 32

timeouts call-disconnect 0

!

voice-port 1/3

echo-cancel coverage 32

timeouts call-disconnect 0

!

!

dial-peer voice 10 pots

forward-digits all

destination-pattern 41..

port 1/1

!

dial-peer voice 11 pots

forward-digits all

destination-pattern 41..

port 1/2

!

dial-peer voice 12 pots

forward-digits all

destination-pattern 41..

port 1/3

!

dial-peer voice 1 vofr

codec g729ar8

destination-pattern 2...

session target Serial0:0 17

!

dial-peer voice 2 vofr

codec g729ar8

destination-pattern 9

session target Serial0:0 17

!

dial-peer voice 3 vofr

codec g729ar8

destination-pattern 40..

session target Serial0:0 17

!

dial-peer voice 4 vofr

codec g729ar8

destination-pattern 42..

session target Serial0:0 17

!

end

Community Member

Re: Qos for Voice over Frame Relay

I have posted my config. The issue I have right now is echoes. Base on the my config how hard would it be to go Voip instead of using dlci or would it be better to use trunking. Any suggestion would be helpful

184
Views
0
Helpful
6
Replies
CreatePlease to create content