Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

QoS Help Needed

Hello,

can anyone tell me a command that would let me see if the QoS policy is actually working on a router? Also any command to test the connection as a whole for drops, delay, latency etc.

I am having problem with an ATM link between 2 sites. The interface at the remote site looks like this:

interface ATM1/0.40 point-to-point

description << to Warehouse >>

ip address 10.10.3.33 255.255.255.252

ip pim dense-mode

pvc 1/84

service-policy output qos-policy-voice

vbr-nrt 2800 2700 208

broadcast

encapsulation aal5snap

no protocol ip inarp

protocol ipx inarp

My QoS Policy looks like this:

class-map priority-whaaec

match access-group 905

class-map priority-misadmin

match access-group 910

class-map qos-map-Voice

match access-group 170

!

!

policy-map qos-policy-voice

class qos-map-Voice

priority 768

class class-default

fair-queue

policy-map policy-whaaec

class priority-whaaec

priority 768

class class-default

fair-queue

policy-map policy-misadmin

class priority-misadmin

priority 256

class class-default

fair-queue

And my show-policy-map interface looks like this:

MIS-7204-1-West#sh policy-map interface atM 1/0.40

ATM1/0.40: VC 1/84 - output : qos-policy-voice

Weighted Fair Queueing

Class qos-map-Voice

Strict Priority

Output Queue: Conversation 136

Bandwidth 768 (kbps) Packets Matched 95

(pkts discards/bytes discards) 0/0

Class class-default

Flow Based Fair Queueing

Maximum Number of Hashed Queues 128 Max Threshold 64 (packets)

MIS-7204-1-West#sh policy-map interface atM 1/0.72

ATM1/0.72: VC 0/57 - output : qos-policy-voice

Weighted Fair Queueing

Class qos-map-Voice

Strict Priority

Output Queue: Conversation 136

Bandwidth 768 (kbps) Packets Matched 2

(pkts discards/bytes discards) 0/0

Class class-default

Flow Based Fair Queueing

Maximum Number of Hashed Queues 128 Max Threshold 64 (packets)

Are there any glaring problems leaoing out at anyone?

Thanks in advance

16 REPLIES
Hall of Fame Super Silver

Re: QoS Help Needed

You can use "sh policy-map interface x" shows all the policy matching, seems like you tried it and not much matched pockets are seen. You did not post your access-lists, but make sure they are correctly defined. Also, what exactly is the problem?

Chris

Blue

Re: QoS Help Needed

I agree with Chris that it would be interesting to see your access lists.

If your voice endpoints are setting DSCP (Cisco IP phones and gateways do by default) you might consider changing your class qos-map-Voice to match DSCP EF.

My strong preference is to use inbound policy maps with access lists on the LAN interfaces to tag packets with the desired DSCP values and then match those DSCPs in the outbound policy maps on the WAN links. This has always worked consistently well. I have seen instances where your approach has failed to correctly identify traffic, which may be the problem.

New Member

Re: QoS Help Needed

Thanks for the replies. I have made some changes in the remote site router that look like this now:

class-map match-any qos-map-warehouse

match ip dscp ef

match precedence 5

!

!

policy-map qos-policy-warehouse

class qos-map-warehouse

priority 768

class class-default

fair-queue

What should my acces list look like? I do not have one on there right now.

Blue

Re: QoS Help Needed

Does the "show policy-map interface" now show traffic hitting the priority queue (assuming voice traffic is present)?

You need access lists to go with the match access-group command. For IP extended access lists the number must be in a range of 100-199. So your 170 would be OK, but the 905 and 910 cannot be used.

The access list would be written to match whatever traffic you want to identify.

As an example:

access-list 177 permit tcp any any eq www

That would match traffic between any hosts with a destination port of 80.

Your policy map now is set to priority queue 768kb of voice traffic, and will use weighted fair queue for all other traffic.

What traffic were you trying to apply QOS to with your other classes? You can guarantee bandwidth to other classes, but you should only have a single priority queue.

New Member

Re: QoS Help Needed

I am trying to match voice traffic.I am attatching my config as it stands now.

The show policy-map interface is is matching packets but not at the rate that I would think

I really appreciate the hlep!

Blue

Re: QoS Help Needed

Your config should be fine, at least as far as catching voice traffic through the router voice ports. If you have IP phone traffic as well you might have a switch that is overwriting the DSCP if not set to trust.

Add the bolded commands to see if there is voice traffic coming through that is untagged:

class-map match-any qos-map-warehouse

match ip dscp ef

match precedence 5

match access-group 102

!

access-list 102 permit udp any any range 16384 32767

New Member

Re: QoS Help Needed

OK. Do I not need an access list to actually match the traffic?

For the 102 where will those number show up?

Hall of Fame Super Silver

Re: QoS Help Needed

The only policy-map defined that you have is "policy-map qos-policy-warehouse" but your pvc 1/84 interface is referring to policy "qos-policy-anton". When yo run sh policy-map interface command you should see the offered rate for the class, so if you are using G.729 codec you will see ~24000bps offered, 80000 for G.711. The match ef statement should work for you as long as you fix the reference to policy-map, and there is no need for access lists anymore since your markings are done this way.

Chris

New Member

Re: QoS Help Needed

I had corrected that a while back. Sorry for the confusion and thanks again for so much help. I am still not getting any packets matched with this current config

Blue

Re: QoS Help Needed

Chris is right, what happened to interface ATM1/0.40?

Access list 102 will match traffic between any hosts using the UDP ports in the range that are used for voice RTP packets. It will only match voice.

New Member

Re: QoS Help Needed

I fixed that a while back and forgot to upload the corrected config. I am still not geting any packets matched though

New Member

Re: QoS Help Needed

Just found out that the switch that the phones are plugged into is using AutoQoS if that makes any difference

Blue

Re: QoS Help Needed

The AutoQos should ensure that the packets from the IP phones are properly marked.

Can you post your current config?

New Member

Re: QoS Help Needed

Here is the current config. Thanks again for taking the time

Blue

Re: QoS Help Needed

Can you post the show policy-map interface ATM0/IMA1?

I have no experience with IMA, but the only example I can find uses a subinterface under the IMA interface. You might try that. Here's the example.

class-map match-all rtp

match ip rtp 5000 10000

!

policy-map llq

class rtp

priority 1000

!

interface ATM3/0

no ip address

ima-group 0

!

interface ATM3/ima0

no ip address

no atm ilmi-keepalive

!

interface ATM3/ima0.34 point-to-point

ip address 5.0.34.3 255.255.255.0

pvc 0/34

tx-ring-limit 3

vbr-nrt 4000 4000

service-policy output llq

!

interface ATM3/1

no ip address

ima-group 0

!

interface ATM3/2

no ip address

ima-group 0

New Member

Re: QoS Help Needed

The cisco SAA feature can provide the latency , delay and packet drop..

146
Views
24
Helpful
16
Replies
CreatePlease to create content