Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Hall of Fame Super Silver

QoS marking/classification for PSTN traffic

I have a customer with central site and branch sites, all PSTN traffic goes out via the central site over WAN (MPLS). They are expereincing some quality issues, it appears that the traffic from remote site to HQ is marked fine and LLQ works, however the traffic back is not. How do I ensure that traffic from PSTN gets marked properly? Using MGCP GW.

CHris

6 REPLIES
New Member

Re: QoS marking/classification for PSTN traffic

you should be able to setup an outbound interface policy (via mqc) on the pstn gateway at the central site. remember to nest a child policy into a parent policy... so ALL traffic is shaped, and mgcp traffic

is let out first! (This assumes the bandwidth between the central site and the far site is 768000, customize for you needs)

!wan router at main

!

class-map match-all mgcp

match protocol mgcp

!

!

policy-map voip-prioritize

class mgcp

priority percent 30

class class-default

fair-queue

policy-map voip-prioritize-parent

class class-default

shape average 768000

service-policy voip-prioritize

!

int f0/0

desc facing pstn gateway internally

ip nbar protocol-discovery

!

int s0/0

desc interface towards remote site/Call Manager

ip nbar protocol-discovery

service-policy output voip-prioritize-parent

Hall of Fame Super Silver

Re: QoS marking/classification for PSTN traffic

I have LLQ configured properly what I am referring to is to actually mark the RTP traffic accordingly, does CCM take care of it using it's default DSCP setting EF- for RTP, CS3 for SCCP?

Chris

Re: QoS marking/classification for PSTN traffic

Chris,

The RTP stream is between the remote ip phone and central PSTN gateway. So you need to trust the dscp that PSTN gateway marks RTP packets with on the switch port. Map the cos values to internal DSCP properly and on the egress port that your wan gateway is connected, you can enable wrr-queueing (or srr) with priority queue enabled on that port. LLQ should take care of the wan (which you have properly configured).

For marking mgcp control packets with right qos, (control) you need

mgcp ip qos dscp cs3 signalling. (not af31, since your callmanager is possibly 4.1)

I would create a service policy to mark all rtp packets on the Fast E interface of the PSTN switch.

class-map VoiceB

match ip rtp 16384 16383

policy-map MarkRTP

class VoiceB

set ip dscp ef

int fa0/0

service-policy output MarkRTP

On the ingress port on the switch, where the PSTN gateway is connected,

assuming commands are for a 3550:

mls qos

mls qos cos-map 0 8 16 24 34 46 48 56

int fa0/1

switchport mode dynamic desirable

switchport access vlan 20 (this is your voice vlan)

spanning-tree portfast

wrr-queue cos-map 4 5

wrr-queue cos-map 3 3 6 7

wrr-queue cos-map 1 0 1 2 4

priority-queue out

mls qos trust dscp --- trust dscp from the PSTN gateway

On the egress port that goes into the WAN gateway:

int fa0/24

switchport mode dynamic desirable

switchport access vlan 200 (this is your vlan for wan gateway)

spanning-tree portfast

wrr-queue cos-map 4 5

wrr-queue cos-map 3 3 6 7

wrr-queue cos-map 1 0 1 2 4

priority-queue out -- priority queues RTP traffic

mls qos trust dscp --- trust dscp from the packets coming in from WAN

Depending on your switches, WRR may change to SRR.

HTH

Sankar.

Re: QoS marking/classification for PSTN traffic

Chris,

Btw, you with Meridian IT Chicago?

Hall of Fame Super Silver

Re: QoS marking/classification for PSTN traffic

I am, I've been with them for about 5 months now. Why do you ask?

Chris

Re: QoS marking/classification for PSTN traffic

Have a colleague who used to work there and moved to TX few months back..we were talking about Meridian IT over lunch and when I came back i noticed you were working for the same..

Let me know if the qos settings i posted above helps..

326
Views
0
Helpful
6
Replies
CreatePlease to create content