Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

QoS over NAT

I need to apply QoS -LLQ to an subinterface, but is enabled NAT for that subinterface for one of the subnets attached to the router (fa0/0), the QoS must be enabled on s0/0.1

here is the NAT configuration:

interface FastEthernet0/0

ip address 172.17.64.1 255.255.255.0

ip nat inside

no ip mroute-cache

duplex auto

speed auto

!

interface Serial0/0

no ip address

encapsulation frame-relay IETF

no ip mroute-cache

no fair-queue

frame-relay lmi-type ansi

!

interface Serial0/0.1 point-to-point

ip address 150.186.99.18 255.255.255.248

ip nat outside

no ip mroute-cache

frame-relay interface-dlci 101 CISCO

!

interface FastEthernet0/1

ip address 172.17.200.161 255.255.255.224

no ip mroute-cache

duplex auto

speed auto

!

interface Serial0/1

no ip address

no ip mroute-cache

shutdown

!

ip default-gateway 150.186.99.17

ip nat pool Tocuyo 150.186.99.19 150.186.99.20 netmask 255.255.255.248

ip nat inside source list 110 pool Tocuyo overload

ip classless

ip route 0.0.0.0 0.0.0.0 Serial0/0.1

no ip http server

!

access-list 110 permit ip 172.17.64.0 0.0.0.255 any

and this is going to be the configuration with QOS (only QoS configuration presented) :

The Question: I need to permit that traffic matched with ACL 110 be forwarded to "QoS policy" if NAT is working with the same subnet from ACL 110 172.17.64.0?

class-map voz-wan

match access-group 120

class-map datos-wan

match access-group 110

policy-map wan-policy

class voz-wan

priority 33

class datos-wan

bandwidth 31

interface Serial0/0

frame-relay traffic-shaping

frame-relay ip rtp header-compression

!

interface Serial0/0.104 point-to-point

frame-relay interface-dlci 104

class VoIP-64kbps

!

map-class frame-relay VoIP-64kbps

no frame-relay adaptive-shaping

frame-relay cir 64000

frame-relay bc 640

frame-relay be 64000

frame-relay mincir 64000

service-policy output wan-policy

frame-relay fragment 80

access-list 120 permit ip 172.17.200.0 0.0.0.255 any

B.R.

1 REPLY
Silver

Re: QoS over NAT

I haven't seen any documents that talk about QoS over NAT. You might want to take a look at the support page for QoS. http://www.cisco.com/pcgi-bin/Support/browse/index.pl?i=Technologies&f=773

175
Views
0
Helpful
1
Replies
CreatePlease to create content