Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

QoS over PPP link

Hello to everyone,

I have a network with star topology that connects 3660 with multiple sites with 2600 installed. Each of the router is connected to PBX. (MD110 PBX--PRI--3661--2620--BRI-BP250)

Currently the calls from one site to the central site are going well, but when there is traffic on the channel, the quality becames unacceptable, although I've configured LLQ and priority for voice. What could be the problem of this?

Also the calls from one site to the other through central site are not working. From the isdn q931 debug I can see that calls are coming to the destination router, but are released immidiately.The calls from central site to each direction are working.

9 REPLIES
New Member

Re: QoS over PPP link

As for the first problem, have you configured link fragmentation and interleaving on the ppp link yet?

For the second problem, check to make sure you have connectivity between the remote sites' phone subnets using ping. It may be a routing issue.

New Member

Re: QoS over PPP link

Yes, I've configured fragmentation and interleaving.

I have connectivity between remote sites, ping is going everywhere.

Blue

Re: QoS over PPP link

If you do a "show policy interface muX" (where X is the multilink interface number) command does it show that your voice traffic is hitting the priority queue? Posting your config would be helpful. You don't say how much bandwidth you have to each site, what codec you are using or how you are limiting the calls to the number your QOS is set up to support.

If a PBX refuses a call on an PRI it usually means it does not know how to complete the call, or else it is blocked by class of service.

Dave

New Member

Re: QoS over PPP link

It seems that the traffic doesn't hit the priority queue. But I can't understand why.I have 128K to each site, and using the default codec 729r.Currently I'm making only one call on the link, and with traffic on it the QoS is really bad. Below you can find the show commands and a part of show tech, because I think it's to long to post it here

gwcriu#show policy-map inter multilin 1

Multilink1

Service-policy output: voice-policy

Class-map: voice-signaling (match-all)

450 packets, 46125 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: access-group 103

Queueing

Output Queue: Conversation 41

Bandwidth 8 (kbps) Max Threshold 64 (packets)

(pkts matched/bytes matched) 450/46125

(depth/total drops/no-buffer drops) 0/0/0

Class-map: voice-traffic (match-all)

0 packets, 0 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: access-group 102

Queueing

Strict Priority

Output Queue: Conversation 40

Bandwidth 56 (kbps) Burst 1400 (Bytes)

(pkts matched/bytes matched) 0/0

--More-- (total drops/bytes drops) 0/0

Class-map: sgc (match-all)

0 packets, 0 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: access-group 101

Queueing

Output Queue: Conversation 42

Bandwidth 38 (kbps) Max Threshold 64 (packets)

(pkts matched/bytes matched) 0/0

(depth/total drops/no-buffer drops) 0/0/0

Class-map: class-default (match-any)

750803 packets, 62763140 bytes

5 minute offered rate 46000 bps, drop rate 0 bps

Match: any

Queueing

Flow Based Fair Queueing

Maximum Number of Hashed Queues 32

(total queued/total drops/no-buffer drops) 1/0/0

gwcriu# show voice call ?

<1-1> Voice interface slot #

summary Summary of all voice calls

| Output modifiers

gwcriu#show voice call

1/0/0 1 vtsp level 0 state = S_CONNECT

callid 0x804E B01 state S_TSP_CONNECT clld 62004 cllg 61263

1/0/0 2 - - -

1/0/1 1 - - -

1/0/1 2 - - -

gwcriu#show voice call

1/0/0 1 vtsp level 0 state = S_CONNECT

callid 0x804E B01 state S_TSP_CONNECT clld 62004 cllg 61263

1/0/0 2 - - -

1/0/1 1 - - -

1/0/1 2 - - -

gwcriu#show voice call call ?

<1-1> Voice interface slot #

summary Summary of all voice calls

| Output modifiers

gwcriu#show voice call 1 ?

% Unrecognized command

gwcriu#show voice call 1 /0/0 ?

| Output modifiers

gwcriu#show voice call 1/0/0

1/0/0 1 vtsp level 0 state = S_CONNECT

callid 0x804E B01 state S_TSP_CONNECT clld 62004 cllg 61263

1/0/0 2 - - -

gwcriu#show voice call 1/0/0 1

1/0/1 1 - - -

1/0/1 2 - - -

sh tech

------------------ show version ------------------

Cisco Internetwork Operating System Software

IOS (tm) C2600 Software (C2600-IS-M), Version 12.2(12), RELEASE SOFTWARE (fc1)

Copyright (c) 1986-2002 by cisco Systems, Inc.

Compiled Wed 21-Aug-02 03:01 by pwade

Image text-base: 0x8000808C, data-base: 0x810CE168

ROM: System Bootstrap, Version 12.1(3r)T2, RELEASE SOFTWARE (fc1)

gwcriu uptime is 2 days, 20 hours, 38 minutes

System returned to ROM by reload

System image file is "flash:c2600-is-mz.122-12.bin"

cisco 2620 (MPC860) processor (revision 0x600) with 36864K/4096K bytes of memory

.

Processor board ID JAD05390BDL (1566022521)

M860 processor: part number 0, mask 49

Bridging software.

X.25 software, Version 3.0.0.

Basic Rate ISDN software, Version 1.1.

1 FastEthernet/IEEE 802.3 interface(s)

2 Serial(sync/async) network interface(s)

2 ISDN Basic Rate interface(s)

4 Voice TE BRI interface(s)

32K bytes of non-volatile configuration memory.

16384K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

------------------ show running-config ------------------

Building configuration...

Current configuration : 5113 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname gwcriu

!

aaa new-model

aaa authentication login default local group radius

aaa authentication ppp default local group radius

aaa authorization exec default local group radius

aaa authorization network default local group radius

enable secret 5

!

username denis privilege 15 password 7

username tsvet privilege 15 password 7

username vitalii privilege 15 password 7

username Cisco_Cel_Mare password 0

ip subnet-zero

!

!

!

!

class-map match-all voice-signaling

match access-group 103

class-map match-all voice-traffic

match access-group 102

class-map match-all sgc

match access-group 101

!

!

policy-map voice-policy

class voice-signaling

bandwidth 8

class voice-traffic

priority 56

class sgc

bandwidth 38

class class-default

fair-queue

!

isdn switch-type basic-net3

call rsvp-sync

voice rtp send-recv

!

!

!

!

!

!

!

!

interface Multilink1

bandwidth 128

ip address 192.168.100.90 255.255.255.252

ip accounting output-packets

ip tcp header-compression iphc-format

no ip mroute-cache

max-reserved-bandwidth 80

service-policy output voice-policy

compress stac

no cdp enable

ppp multilink

ppp multilink fragment-delay 10

ppp multilink interleave

multilink-group 1

ip rtp header-compression iphc-format

!

interface FastEthernet0/0

ip address 10.248.30.1 255.255.252.0

duplex auto

speed auto

!

interface Serial0/0

bandwidth 128

no ip address

encapsulation ppp

no fair-queue

ppp authentication chap pap

ppp multilink

multilink-group 1

!

interface Serial0/1

no ip address

shutdown

!

interface BRI1/0

no ip address

no logging event link-status

isdn switch-type basic-net3

isdn incoming-voice voice

!

interface BRI1/1

no ip address

isdn switch-type basic-net3

isdn incoming-voice voice

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.100.89

ip route 10.248.0.0 255.255.248.0 192.168.100.89

ip route 192.168.100.126 255.255.255.255 192.168.100.89

ip http server

!

access-list 1 permit 10.248.1.18

access-list 1 permit 10.248.30.10

access-list 1 permit 10.248.4.26

access-list 1 permit 10.248.4.27

access-list 1 permit 10.248.4.25

access-list 1 permit 10.248.1.6

access-list 10 permit 10.248.1.3

access-list 10 permit 10.248.1.2

access-list 10 permit 10.248.1.1

access-list 10 permit 10.248.1.0

access-list 10 permit 10.248.2.10

access-list 100 permit tcp any any established

access-list 100 permit ip any 10.248.1.0 0.0.0.31

access-list 100 permit ip any 10.248.2.0 0.0.0.31

access-list 100 permit ip any 10.248.3.0 0.0.0.31

access-list 100 permit ip any 10.248.4.0 0.0.0.63

access-list 100 permit ip any 10.248.8.0 0.0.0.15

access-list 100 permit icmp any any

access-list 100 deny ip any any

access-list 101 permit ip any host 10.248.1.3

access-list 101 permit ip host 10.248.1.3 any

access-list 101 permit ip any host 10.248.1.2

access-list 101 permit ip host 10.248.1.2 any

access-list 101 permit ip any host 10.248.1.1

access-list 101 permit ip host 10.248.1.1 any

access-list 101 permit ip any host 10.248.1.0

access-list 101 permit ip host 10.248.1.0 any

access-list 101 permit ip any host 10.248.2.10

access-list 101 permit ip host 10.248.2.10 any

access-list 102 permit udp any any range 16384 32767

access-list 103 permit tcp any eq 1720 any

access-list 103 permit tcp any any eq 1720

snmp-server community RO

snmp-server enable traps tty

!

voice-port 1/0/0

echo-cancel coverage 24

compand-type a-law

cptone DE

!

voice-port 1/0/1

echo-cancel coverage 24

compand-type a-law

cptone DE

!

dial-peer cor custom

!

!

!

dial-peer voice 62001 pots

destination-pattern 6200.

direct-inward-dial

port 1/0/1

prefix 6200

!

dial-peer voice 62011 pots

destination-pattern 6201.

direct-inward-dial

port 1/0/1

prefix 6201

!

dial-peer voice 62021 pots

destination-pattern 6202.

direct-inward-dial

port 1/0/1

prefix 6202

!

dial-peer voice 62031 pots

destination-pattern 6203.

direct-inward-dial

port 1/0/1

prefix 6203

!

dial-peer voice 61 voip

destination-pattern 61...

session target ipv4:10.248.0.2

ip precedence 5

!

dial-peer voice 9 voip

destination-pattern 09......

session target ipv4:10.248.0.2

ip precedence 5

!

dial-peer voice 62041 pots

destination-pattern 6204.

direct-inward-dial

port 1/0/1

prefix 6204

!

dial-peer voice 6200 pots

destination-pattern 6200.

direct-inward-dial

port 1/0/0

prefix 6200

!

dial-peer voice 6201 pots

destination-pattern 6201.

direct-inward-dial

port 1/0/0

prefix 6201

!

dial-peer voice 6202 pots

destination-pattern 6202.

direct-inward-dial

port 1/0/0

prefix 6202

!

dial-peer voice 6203 pots

destination-pattern 6203.

direct-inward-dial

port 1/0/0

prefix 6203

!

dial-peer voice 6204 pots

destination-pattern 6204.

direct-inward-dial

port 1/0/0

prefix 6204

!

dial-peer voice 623 voip

destination-pattern 623..

session target ipv4:10.248.8.250

!

dial-peer voice 1 voip

destination-pattern .T

session target ipv4:10.248.0.2

!

!

line con 0

line aux 0

line vty 0 4

password

line vty 5 15

!

end

------------------ show stacks ------------------

Minimum process stacks:

Free/Size Name

7244/12000 Init

5524/6000 AIM_MIB_CREATION

5324/6000 RADIUS INITCONFIG

9528/12000 Exec

7692/12000 Virtual Exec

Interrupt level stacks:

Level Called Unused/Size Name

1 7607195 7548/9000 Network interfaces

2 0 9000/9000 Timebase Reference Interrupt

3 0 9000/9000 PA Management Int Handler

Blue

Re: QoS over PPP link

SInce you are setting the precedence bit to 5 in your VOIP dial peer your voice-traffic class maps should look like this:

class-map match-all voice-traffic

match ip precedence 5

You also should do the signalling the same way, setting the precedence under the dial peer and matching precedence with your class map.

I assume your PBXs are doing the CAC to limit the number of calls to 4?

Regards, Dave

Blue

Re: QoS over PPP link

In order to set the signaling as I suggest you will need to go to T code which has an enhanced command for that "ip qos dscp XX signaling/media".

We have been running 12.2.(11)T, which seems to be very solid.

Dave

New Member

Re: QoS over PPP link

Does it mean that if I'll try to classify voice traffic not with ip precedence, but with access-list, this will fail ? Also another problem is that on the other end of the link I have Cisco3661 with ip qos dscp xx. I assume that the parameter that is equivalent to precedence 5 is cs 5. Should I put it for the signalling or for the media , or both ?

Also, how much memory 12.2.(11)T requires ? I have only 40Mb DRAM on my 2600 router.

Blue

Re: QoS over PPP link

Using the access-list is failing for you now, and I know from experience that setting precedence in the dial peer and matching against precedence in the class map will work, and makes for a cleaner config.

Best practice is to set the signaling to precedence 3 and the media to 5. CS5 is precedence 5, or you can use the recomended DSCP values of ef for media, and af31 for signaling. Using the ip qos command on the 3661 and ip precedence on the 2600 will not cause any problems.

The T code requires 64MB in the 2600, so you either need to add memory or work with what you have. Your show policy int indicates the control queue may be working so just make the changes to the voice class map and see how it works.

Dave

New Member

Re: QoS over PPP link

Great thanks for your answers, you was 100% wright. I followed your advice, and made reconfiguration to match the traffic with ip precedence. Now it seems that everything works perfectly. But I still don't know why access-list doesn't work . I wonder, is this a bug in software or in my head :))

Anyway, thanks for this once again.

Calls from one office to another still doesn't work. This is the last problem for a while that I've got :)

246
Views
0
Helpful
9
Replies