Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

QOS over VPN for VoIP - 827 Router

I'm trying to set up QOS over a VPN running on ADSL in the UK. I'm having a little trouble getting it to work - according to

http://www.cisco.com/en/US/products/hw/routers/ps380/products_qanda_item09186a00800949ec.shtml#q16

I need to set up a priority queue, and set the vbr-rt command on the PVC - how do I determine the appropriate parameters for this command?

My config so far is as follows, and my DSL line is 256K upstream/1Mb down:

827-4V-Easthams#sh run

Building configuration...

Current configuration : 2396 bytes

!

version 12.3

no parser cache

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname 827-4V-Easthams

!

enable secret 5 <pwd>

!

ip subnet-zero

no ip domain lookup

!

!

!

!

!

!

!

!

!

no voice hpi capture buffer

no voice hpi capture destination

!

!

!

!

!

crypto isakmp policy 1

encr 3des

authentication pre-share

crypto isakmp key freglecom address <other end ip>

!

!

crypto ipsec transform-set vpn-test esp-3des esp-sha-hmac

!

crypto map static-map 1 ipsec-isakmp

set peer <other end ip>

set transform-set vpn-test

match address 100

!

!

!

class-map match-all VOICE

match access-group 120

!

!

policy-map POLICY

class VOICE

priority 200

class class-default

fair-queue

!

!

!

!

interface Ethernet0

ip address 10.202.4.1 255.255.255.0

ip nat inside

hold-queue 100 out

!

interface ATM0

mtu 300

no ip address

no atm ilmi-keepalive

pvc 0/38

tx-ring-limit 3

encapsulation aal5mux ppp dialer

dialer pool-member 1

!

bundle-enable

dsl operating-mode auto

!

interface Dialer0

bandwidth 288

ip address negotiated

no ip proxy-arp

ip nat outside

service-policy output POLICY

encapsulation ppp

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication chap callin

ppp chap hostname <username>

ppp chap password 7 <pwd>

crypto map static-map

!

ip nat inside source list 110 interface Dialer0 overload

ip nat inside source static tcp 10.202.4.1 23 interface Dialer0 23

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer0

no ip http server

no ip http secure-server

!

access-list 100 permit ip 10.202.4.0 0.0.0.255 172.16.0.0 0.15.255.255

access-list 100 permit ip 10.202.4.0 0.0.0.255 10.0.0.0 0.255.255.255

access-list 100 permit ip 10.202.4.0 0.0.0.255 192.168.0.0 0.0.255.255

access-list 110 deny ip any 172.16.0.0 0.15.255.255

access-list 110 deny ip any 10.0.0.0 0.255.255.255

access-list 110 deny ip any 192.168.0.0 0.0.255.255

access-list 110 permit ip 10.202.4.0 0.0.0.255 any

access-list 120 permit ip any any precedence critical

access-list 199 permit ip host 10.202.4.101 any

dialer-list 1 protocol ip permit

!

!

voice-port 1

!

voice-port 2

!

voice-port 3

!

voice-port 4

!

!

line con 0

exec-timeout 120 0

stopbits 1

line vty 0 4

exec-timeout 120 0

password 7 <pwd>

login

!

scheduler max-task-time 5000

!

end

Any help/tips would be appreciated...

1 REPLY
New Member

Re: QOS over VPN for VoIP - 827 Router

Another problem I've noticed with this setup is that I can't telnet or ping to the Ethernet interface on the 827-4V at the remote office...

81
Views
0
Helpful
1
Replies
CreatePlease to create content