Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

QOS problems on cisco 2621

please help

i am trying to get QOS working on our network. having major diffculties in doing this.

what i have 2621 with 10mbps link into our core network and 100mbps in to remote lan.

i been playing around with class maps etc.

has anyone got example gonfig i can follow i followed the cisco format it dosent work. when i run a sniffer on phone it see dscp no ip precendence on the ip packet so this adding more to the confusion .

here my config i been using

class-map match-all QOS

match access-group 101

match access-group 102

!

!

policy-map voicetraffic

class QOS

bandwidth percent 25

random-detect

interface FastEthernet0/0

ip address 10.10.10.1 255.255.255.0

duplex auto

speed auto

service-policy output voicetraffic

interface FastEthernet0/1

ip address xxx.xxxx.xxx.xxx 255.255.240.0

duplex auto

speed auto

!

router rip

network 10.0.0.0

network

!

ip classless

ip route 0.0.0.0 0.0.0.0 xxx.xxx.xxx.xxx

ip http server

ip pim bidir-enable

!

access-list 101 permit tcp any range 2000 2002 any

access-list 101 permit tcp any any eq 1720

access-list 101 permit tcp any any range 11000 11999

access-list 101 permit udp any any eq 2427

access-list 102 permit udp any range 16384 32767 any

access-list 103 permit ip any any

!

Also when i do sho ip access-list it doesnt seem to be using access-list 102

Router#show ip access

Extended IP access list 101

permit tcp any range 2000 2002 any (575 matches)

permit tcp any any eq 1720

permit tcp any any range 11000 11999

permit udp any any eq 2427

Extended IP access list 102

permit udp any range 16384 32767 any

Extended IP access list 103

permit ip any any (3629 matches)

very confusing please help me out

1 REPLY
New Member

Re: QOS problems on cisco 2621

Hi Darvin,

Are you spanning the port the IP phone is connected to on one of your switches? By default Cisco IP phones should tag voice packets with TOS 5 and COS 5.

You should use the access lists to re-classify the TOS value for inbound traffic on the ethernet port. You can then create policy maps for outbound traffic on the fast ethernet port to assign priority to voice traffic and bandwidth for signalling given the dscp/IP precedence of the packet going out on this interface.

All you have done in this configuration is create a class that assigns 25 percent of the interface bandwidth (in the event of congestion) for all the traffic defined in the access lists. Are you finding you have congestion on your 100MB link?

441
Views
0
Helpful
1
Replies
CreatePlease login to create content