cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
895
Views
0
Helpful
4
Replies

QoS RDP Microsoft

alexey_punin
Level 1
Level 1

Sorry, somebody know, why when I enable QoS on RDP protocol (TCP 3389) - RDP connection going down?

4 Replies 4

gpulos
Level 8
Level 8

can you supply the configuration of QoS for the devices between your endpoints?

Router A

class-map match-all Intalev

match ip access-group 115

policy-map RDP

class Intalev

priority percent 40

class class-default

fair-queue

!

interface Serial0/0

bandwidth 384

no ip address

no ip proxy-arp

encapsulation frame-relay IETF

ip route-cache flow

no ip mroute-cache

frame-relay traffic-shaping

frame-relay lmi-type ansi

frame-relay interface-queue priority

!

interface Serial0/0.16 point-to-point

description VOICE PVC

ip address 192.168.32.117 255.255.255.252

no ip proxy-arp

no ip mroute-cache

no cdp enable

frame-relay interface-dlci 16 CISCO

class voice

frame-relay ip rtp header-compression

interface Serial0/0.19 point-to-point

description DATA VC

ip address 10.129.1.6 255.255.255.252

no ip proxy-arp

no ip mroute-cache

no cdp enable

frame-relay interface-dlci 19

class data

map-class frame-relay voice

frame-relay cir 312000

frame-relay bc 1000

frame-relay be 0

frame-relay mincir 312000

frame-relay fair-queue

frame-relay interface-queue priority high

!

map-class frame-relay data

frame-relay fragment 160

frame-relay adaptive-shaping becn

frame-relay cir 128000

frame-relay bc 1000

frame-relay be 0

frame-relay mincir 24000

frame-relay interface-queue priority low

service-policy output RDP

access-list 115 permit tcp host any host 10.4.36.11 eq 3389

####################################################

Router B

class-map match-all Intalev

match access-group 120

policy-map RDP

class Intalev

priority percent 40

class class-default

fair-queue

!

interface Serial0/0

bandwidth 128

no ip address

ip audit MNVAudit in

encapsulation frame-relay IETF

no ip route-cache cef

no ip route-cache

no ip mroute-cache

frame-relay traffic-shaping

frame-relay lmi-type ansi

frame-relay interface-queue priority

!

interface Serial0/0.16 point-to-point

description --- VOICE ---

ip address 192.168.32.133 255.255.255.252

no ip route-cache

no ip mroute-cache

frame-relay interface-dlci 16 CISCO

class voice

frame-relay ip rtp header-compression

interface Serial0/0.19 point-to-point

description --- DATA ---

ip address 10.129.1.5 255.255.255.252

no ip route-cache

no ip mroute-cache

frame-relay interface-dlci 19

class data

!

map-class frame-relay voice

frame-relay cir 104000

frame-relay bc 1000

frame-relay be 0

frame-relay mincir 104000

frame-relay fair-queue

frame-relay interface-queue priority high

!

map-class frame-relay data

frame-relay fragment 160

frame-relay adaptive-shaping becn

frame-relay cir 128000

frame-relay bc 1000

frame-relay be 0

frame-relay mincir 24000

frame-relay interface-queue priority low

service-policy output RDP

!

access-list 120 permit tcp host 10.4.36.11 eq 3389 any

can you provide the source & destination addresses of the RDP session your attempting?

Yes 10.4.36.11 this is destination address (Remote server) and 10.0.2.202 source address (Client).