Cisco Support Community
Community Member


I am trying to implement QOS in a network. We want to reserve bandwidth usage for different applications and to prioritize voice traffic.

I have used the following configuration for testing.

access-list 103 permit tcp any any eq smtp

access-list 103 permit tcp any any eq 1326

access-list 104 permit tcp any any eq www

access-list 104 permit tcp any any eq 443

access-list 110 permit udp any any range 16384 32767

access-list 111 permit tcp any eq 2000 any

access-list 111 permit tcp any any eq 2000

Class-map match-all voice-signaling

match access-group 111

class-map match-all voice-traffic

match access-group 110

class-map match-all mail

match access-group 103

class-map match-all web

match access-group 104

policy-map VOICE-POLICY

class voice-traffic

priority 48

class voice-signaling

bandwidth 8

class web

bandwidth 15

class mail

bandwidth 20

class class-default


service-policy output VOICE-POLICY

The traffic flows over 128kbps multilink. The problem I face is that voice quality is too bad. It doesn't matter how much bandwidth I reserve for Voice-traffic.

show policy-map interface command shows drops for a single call with 48 kbps reservation. I increased the bandwidth for voice-traffic to 96kbps. At that time I didn't see any drops but voice quality was still poor.

I am using following configuration on the multilink:

max-reserved-bandwidth 85

service-policy output VOICE-POLICY

ip route-cache flow

ip tcp header-compression iphc-format

ppp multilink

ppp multilink fragment-delay 10

ppp multilink interleave

multilink-group 10

ip rtp header-compression iphc-format

Its true that the link is overutilized and there is lot of traffic causing congestion. But I expect QOS to prioritize and reserve bandwidth for voice during the time of congestion.

In show policy-map interface command it even shows that its reserving the bandwidth for voice traffic.

We have 7902 IP phones with 7800 MCS.

Please suggest.

Thank you




in general VoIP quality can not only be seen as a function of one interface configuration. So also make sure, that your LAN switch environment and all other routers are setup to proritize VoIP.

The observation that voice quality is still poor even if there are no drops on the multilink interface supports the idea somewhere else are additional issues to solve.

With respect to the configuration given I would suggest to modify some classes:

ip cef

Class-map match-any voice-signaling

match access-group 111

match ip dscp cs3

class-map match-all voice-traffic

match protocol rtp audio

This way you will not include other UDP traffic into your voice class.

Community Member


There is no other UDP traffic as found with netflow accounting.

As I mentioned earlior, show policy-map int command show me that there are no drops once i reserve it for 96kbps..but the voice is till poor.

I remember looking at one cisco document that if the link is overutilized then Qos will not perform in the expected manner. And you need to increase the bandwidth.

Now my question is, unfortunately, that i expect QOS to reserve the bandwidth with my configuration. Eventough I reserve the bandwidth and I can see the resevation with show policy-map interface command, i don't get the performance.

i just want to know that if my link is over utilized then will QOS work in the same manner or the router will start behaving weird if there is lot of traffic.

Also if the community confirms that my configuration is correct, and there is nothing to modify, the i can take up the things with cisco asw well to find a resolution.




Few things i can suggest to check here is the bandwidth command configured under the serial interfaces over which your multilink is formed.

Multilink blindly takes the resultant bandwidth of your physical serial interfaces.

Second thing would be the configuration on the other end .do u have the same kinda config on the other end too ? also if possible can you post out tht too ?

finally the kinda connectivity ..

is ur multilink directly connected to the remote lcoation or to the SP ?

if its to the SP then you need to find out whether your SP respects priority settings which you configure up in ur router.


Community Member


ISP is totally TDM so I don't think thay have anything to do with it.

The configuration on the other side is exactly the same as I put in earlier. I see the access-list and show policy-map counter increasing when I make a voice call. so i am sure that I am not missing any voice signalling or traffis Tcp ot UDP port.

I do not even see the router CPU etting exhausted. My concern is:

1. Is my configuration correct?

2. If there are any modificcations required;..please suggest, i will et back to you after testing it out.

3. If the link is really overuitilized then will the QOS work efficiently?/

Thank you.

CreatePlease to create content