Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

question about fxs and fxo hang up problem

ques 1:

we use the following top for voip:

telephone A-----FXS----3600----WAN----2600----FXS----telephone B

3600's ios is 12.0.3T3,2600's ios is 12.0.4T.

when side A is calling side B, and side A hangs up later,side B can't not hang up and continue to ring until you shut down the FXS interface on the 2600.

I'm not sure whether we can resolve it by upgrading ios?or is there any other ways?

ques2:

If the FXS card change to FXO card in the topology above,we met another problem.For example,side A called side B,and the session established.After side A close the session,side B can't hang up until you shut down the FXO interfaceIs.

Is there still an inherent problem with FXO interfaces running loo start, because of no disconnect supervision?Is there any new ways to resolve this?

Thanks.

CX

1 REPLY
New Member

Re: question about fxs and fxo hang up problem

The problem you stated about 3600 with FXS calling 2600 with FXS, and Side A calling Side B, and Side B not hanging up, can be a bug possibly related to hung ports, and we need more info to determine exactly which bug. However, the IOS versions of 12.0T that you mentioned are rather old in terms of voip and it is highly likely that you ran into some VIC hang port problem that we had. This is solved in later IOS.

Regarding your second question of FXS calling FXO side , the only inherent problem is in a condition where:

FXS calls FXO

FXO side does not answer

FXS side hangs up

FXO side continues to ring

If this is the problem you have, this is the FXO disconnect problem, and workarounds are explained in the doc below:

http://www.cisco.com/warp/public/788/signalling/fxo_disconnect.html

However, as far as FXO not releasing the port after a successful call, that could be the very same bug that affects FXS to FXS calls. Again this can be solved by upgrade.

We recommend that you upgrade to the latest mainline of either 12.1 or 12.2 (preferably 12.2) and be sure to put both routers on same IOS to avoid any backward incompatibility.

Hope this helps.

324
Views
0
Helpful
1
Replies