Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

quick qos question....

I am doing LLQ and have applied a policy-map service policy to my serial interface. When I check my policy-map on serial 0, it shows that there have been no matches in the priority queue on the voip port numbers I have defined with my access lists. Everything is going to the class class-default fair queue.

Now...does this mean that i have my access lists wrong? Or has there just not been enough congestion ot necessitate the use of the priority queue?

4 REPLIES
New Member

Re: quick qos question....

Match up your config to this. Also, do a "show policy-map interface XXX" to verify. Doing a "show policy-map " does not show matches on your configuration.

class-map match-any VOICE

match ip dscp ef

match access-group 151

match access-group 152

!

!

policy-map TOWNSQUARE

class VOICE

priority 768

class class-default

fair-queue

access-list 151 permit ip any any precedence critical

access-list 152 permit udp any any range 16384 32768

interface Serial0/0

description T1_to_799

ip address 192.168.111.2 255.255.255.252

service-policy output TOWNSQUARE

service-module t1 timeslots 1-24

Bronze

Re: quick qos question....

Even without congestion on the network, the traffic should be placed in the correct queue and a "show policy int" command should show you the traffic that is being matched. Make sure your policy-map commands have the correct match statements in them ie: "match-any" or "match-all". This can sometimes cause a problem since the "match-all" command is default. Other than that, double check you access list entries. What is the link type?

New Member

Re: quick qos question....

from the CLI router#show access-lists Check to see if you are getting matches first against your ACL. You try to hit a debug on it, becareful of what you debug!

Maybe post your config, so we can see what's up.

New Member

Re: quick qos question....

I am having the same problem where I am not seeing any hits on the "sh policy-map int". I am receiving matches while using the access-lists for DSCP EF and AF31to debug ip packet.

This is a 2621xm platform, following are excerpts from my config:

....

class-map match-all voip-control

match ip dscp af31

class-map match-all voip-rtp

match ip dscp ef

!

policy-map qos-voip

class voip-rtp

priority percent 27

class voip-control

priority percent 7

class class-default

fair-queue

....

interface Serial0/0

description (XXXXX)

bandwidth 1536

ip address X.X.X.X 255.255.255.0

encapsulation ppp

no ip mroute-cache

ipx network XXXXXX

service-policy output qos-voip

compress stac

service-module t1 data-coding inverted

service-module t1 timeslots 1-24

end

Thanks in advance for any assistance!

88
Views
0
Helpful
4
Replies
CreatePlease to create content