Cisco Support Community
Community Member

"Undo" call forward

Hi All,

CCM version 4.0

IP Phone => 7940

I can't undo call forward for the setting i've set using the softkey.

any workaround that can solve this ??

(have upgraded to latest firmware)



Re: "Undo" call forward

Only one phone?

I would check DB replication status, normally CF problems are related to that.

Check this good link:


Re: "Undo" call forward

Gogasca is right. But if the issue is with all the phone you could try restarting Data Base Layer Monitor service. Check this document:

Community Member

Re: "Undo" call forward

I'm just having the problem with an IP Phone, is there any other resolution??

I've trief still cant help.


Re: "Undo" call forward

There was just a little rash of this not too long ago:

Dear All,

I have a weird problem with one of Cisco IP phone 7940 that is registered in CCM 4, the user using this IP phone once made forward to another Cisco IP phone 7940 then he wanted to cancel this forward he is unsuccessful, can anyone help with this problem as I even deleted the 2nd phone and still the 1st phone still forwarding the calls can't stop this forward?!!!

Any help?!!


| Outline |


| E-Mail this Message

Replied by: - Apr 8, 2005, 12:47am PST

We've had the same thing happen. Clearing the phone configuration didn't work either (Settings, 3, 33). We eventually had to delete the device profile and recreate it in CCM to clear it.

| E-Mail this Message

Rate this Post

Replied by: rduenes - May 20, 2005, 9:12am PST

I had the same issue the other day. I tried reseting the phone but it didn't stop the phatom callforward. I forwarded the phone again to voicemail and updated. I then took it off the forward and updated. The line was then able to receive calls.


| E-Mail this Message

Rate this Post

Replied by: king-michael - Network Architect, SOLARCOM LLC, CCIE - May 22, 2005, 3:59pm PST

I've seen this a couple of times and both times it turned out the Publisher and Subscriber CallManagers were out of sync. Check the SQL databases and make sure they are synced up.

| E-Mail this Message

Rate this Post

Replied by: gk9292000 - Sr. Network Engineer, AMERICAN BUSINESS SYSTEMS - May 24, 2005, 4:46am PST

I had a TAC Case open for this same problem, turns out they're known bugs in 4.1(2).

Bug IDs

CSCeg61769: Not able to set or remove CFA

CSCsa64684: Change Notify stops working due to bug in TcpLib

I have heard of people successful with the 'forward again, update, and then remove', I don't know for sure about the device profile trick, you can try deleting and readding the line, but be sure to remove it from the route plan report 'unassigned dns'before readding it.

Mary Beth

Community Member

Re: "Undo" call forward

We used to have this problem all of the time pre-CCM 4.1(3). Ever since we upgraded to 4.1(3)sr2 (I think the bug was fixed in this SR), our CFA has been rock solid. I know this may not help you much, but I just wanted to let you know that it seemed to be a common problem for CCM 3.4, CCM 4.0, and early verisons of CCM 4.1.


Community Member

Re: "Undo" call forward

We shut down the Subscriber to move the server early this morning. Several (probably all) phones which had CFA set when the Subscriber went down were unable to unset it after the Subscriber came back up. If you hit the CFA softkey, the "Forwarded to" message would disappear briefly, then pop back up. CFA was not indicated in either the Subscriber or Publisher Directory Number Configuration pages. None of the fixes suggested in this thread worked. I finally just set a new CFA DN in the Subscriber, then cleared it, and the problem was resolved, but I have no way of knowing if I've gotten all the affected phones or not.

If anyone has any suggestions, I'd love to hear them; we're going to do this again in a few weeks.

CCM 4.1(3)Sr2

P00307020400 in 7960s

Community Member

Re: "Undo" call forward


We had the same issue, it was related to a broken SQL replication, BUT we found a workaround for it. We went into ccmuser page and modified the CFA value and it worked! So for the users who needs to unset the CFA value, go to the ccmuser page and unset it.

CreatePlease to create content