Cisco Support Community
Community Member

Registration problem with Cisco 7960 (SIP firmware)

I had SIP firmware 6.1 on my Cisco 7960.

It was working fine and I was able to register to my SIP provider and make calls.

Last week I tried to upgrade it to 7.5, and it went quite well and was working fine.

But to get familiar with the booting/initliazation/upgrading process I downgraded/upgraded it to 6.1 then to 6.3 and then to 7.5.

Suddenly I saw that the phone is not getting registered with my SIP provider. On capturing packets with Ethereal I found out that once my phone sends the REGISTER to SIP proxy, the SIP proxy returns 401 unauthorised, but then instead of sending REGISTER again with the credentials my phone sends REGISTER with same as the first one without any credentials hence does not get registered. This is repeated all again and again.

Now I have checked with every firmware from 6.1 to 7.5 but the same problem persists. Also I have tried many different SIP accounts.

What you people suggest to solve this problem. Do any of you have encountered same problem before.




Re: Registration problem with Cisco 7960 (SIP firmware)

Cisco IOS devices can calculate the SIP authentication hash using MD5 or MD5-SESS algorithms.

The default method is MD5, so, when the IOS GW receives the challenge without specifying a particular algorithm parameter, it will use by default MD5.

In your case, it looks like the SER doesn't like it, maybe it is expecting a different hash algorithm.

Could you at least check with the SIP provider which digest algorithm are they expecting to receive, and if it is possible to configure the SER to send explicitly in the challenge (401 response) which algorithm are they expecting

CreatePlease to create content