Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

RingBack Problems with CCM 3.3(3) and H323 Gateway

Hi.

I know that is another ringback problem but I already did a search on the forum and the possible suggestion are not working for me so it will be good to ask again to see if someone can help me.

I have an IOS H323 Gateway running 12.2(15)ZJ1 with an FXO connected to the PSTN. If a call comes from the PSTN it terminates on an IP Phone with the connection plar opx command. Then if the IP Phone User transfer the call to another ip phone without consult then the other ip phone start ringing but the PSTN user does not hear ringback..just silence.

Other problem that I am having is that when I also call from the PSTN and the IP Phone user transfer the call to another IP Phone and no one answer the call then the PSTN user hangs the call but the IP Phone keeps ringing forever..

I'm trying all the supervisory disconnect commands on the FXO port without any luck..

Any hints??

Thanks in advance,

-Jose

  • Other Collaboration Voice and Video Subjects
13 REPLIES
New Member

Re: RingBack Problems with CCM 3.3(3) and H323 Gateway

Blue

Re: RingBack Problems with CCM 3.3(3) and H323 Gateway

On your inbound (VOIP) dial peer placed the following command under them:

progress_ind setup enable 3

On your outbound dial peers use the following commands:

progress_ind setup enable 3

progress_ind alert enable 8

progress_ind progress enable 8

progress_ind connect enable 8

In global mode enter the following command:

voice rtp send-recv

That should cover all the bases.

Blue

Re: RingBack Problems with CCM 3.3(3) and H323 Gateway

Strike my reply....that is what I get for not reading the entire post. My reply would assist for ringback problems on a t1/pri.

Cisco Employee

Re: RingBack Problems with CCM 3.3(3) and H323 Gateway

Check this out and try the IOS version reccomended for the version of callmanager that you are using:

http://www.cisco.com/univercd/cc/td/doc/product/voice/c_callmg/ccmcomp.htm

New Member

Re: RingBack Problems with CCM 3.3(3) and H323 Gateway

Hi,

I check the URL but I can't find and IOS listed there that works with my customer because he need backup features that are on SRST 3.0 that is why I'm using 12.2(15)ZJ1 on a 1760 router. For the RingBack problem I found a possible solution on CCO that was posted in this same thread but it doesn't work for me. It says to change the ToSendH225UserInfoMsg to True. On CCM 3.3 there is no True or False but I choose some of the available options without any luck. I'm not sure if after a change I need to restar the CCM service or not. So I didn't restart the service and/or the server but the problem remains the same. PSTN user on FXO port does not hear ringback after beein transfer from an IP Phone to another place.

TIA,

-Jose

New Member

Re: RingBack Problems with CCM 3.3(3) and H323 Gateway

I encountered the same problem. Here is the fix I found:

The fix is documented on pg 309 of the Cisco Press book - Troubleshooting IP Telephony.

By setting "Send H225 User Info Message" to "User Info for Ring Back Tone" will send a message to the gateway via h.323 to play ringback tone.

This can be verified by "debug vtsp tone" on the gateway. You shoudl see:

act_gen_tone: The Ring Back generated in direction Network

I am running CM 3.3.3 SR1 and IOS 12.2(15)ZJ2. I implemented the above fix (without restarting CM) and the "debug vtsp tone" does not output anything. Either it requires a CM restart or there is a bug in 3.3.3 or 12.2(15)ZJ2. If a restart tonight doesn't work I'll throw this to TAC.

New Member

Re: RingBack Problems with CCM 3.3(3) and H323 Gateway

I also found the same "fix" but it is not working for me either. I'm having the same IOS as you are and CCM 3.3.3 without the SR1.

I tried restarting CCM and also the gateway but the results are the same.. No ringback to PSTN user. Please let me know if you open the TAC case because I'm planning to open a case with the TAC as well....

Thanks for your input...

-Jose

Cisco Employee

Re: RingBack Problems with CCM 3.3(3) and H323 Gateway

Do you actually get a ringback, though?

Make sure that you have done term mon and that console logging is enabled on the gateway, otherwise you won't see the debug outputs.

New Member

Re: RingBack Problems with CCM 3.3(3) and H323 Gateway

Calls come into the 2651 gateway via 4 port FXO and is then plar to unity autoattendant. I get:

act_gen_tone: The Ring Back generated in direction Network

when the call is trasfered to unity from CM however when unity transfers the call to an IP phone there is no act_gen_tone message.

I also tested the same call via another h.323 gateway that is running 12.2(15)T5 and a PRI. Ringback comes through fine but no act_gen_tone message either.

Differences between the two boxes is FXO vs PRI & the IOS.

282
Views
0
Helpful
13
Replies
This widget could not be displayed.