Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Router Crash at translation-rule

I've a big problem. Our PRI-Router ( 2621 + Voice-PRI and a CCM 3.08) crashes up to 5 times a day. The crash occurs, when a caller with an unknown caller-id dials an internal number. I suggest, that it is a problem with my translation-rules. Can anybody help me ? The IOS-Version is 12.1.5T6 Here is my config:

!

version 12.1

no service single-slot-reload-enable

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname voicegw

!

logging buffered 4096 debugging

logging rate-limit console 10 except errors

<password removed by moderator>

!

memory-size iomem 10

voice-card 1

!

ip subnet-zero

!

!

no ip finger

no ip domain-lookup

!

!

class-map match-all L3-to-L2_VoIP-Cntrl

match ip dscp 26

class-map match-all L3-to-L2_VoIP-RTP

match ip dscp 46

!

!

policy-map output-L3-to-L2

class L3-to-L2_VoIP-RTP

set cos 5

class L3-to-L2_VoIP-Cntrl

set cos 3

!

isdn switch-type primary-net5

isdn voice-call-failure 0

call rsvp-sync

voice rtp send-recv

!

voice service pots

!

!

!

!

!

!

!

controller E1 1/0

pri-group timeslots 1-31

!

translation-rule 1

Rule 1 ^98331.. 1

Rule 2 ^98332.. 2

Rule 3 ^98333.. 3

Rule 4 ^98334.. 4

Rule 5 ^98335.. 5

Rule 6 ^98336.. 6

!

translation-rule 10

Rule 0 98330 119

!

translation-rule 101

Rule 0 ^.% 00

!

!

interface FastEthernet0/0

description DATA-VLAN

ip address 172.16.0.30 255.255.0.0

speed 100

full-duplex

!

interface FastEthernet0/1

description VOICE-VLAN

ip address 192.168.50.1 255.255.255.0

ip helper-address 172.16.1.100

speed 100

full-duplex

!

interface Serial1/0:15

no ip address

no logging event link-status

isdn switch-type primary-net5

isdn overlap-receiving

isdn incoming-voice voice

no cdp enable

!

ip classless

ip route 0.0.0.0 0.0.0.0 172.16.0.1

no ip http server

!

logging trap debugging

logging 172.16.20.1

access-list 20 permit 192.168.50.10

access-list 20 permit 194.97.118.14

access-list 20 permit 172.16.0.0 0.0.255.255

snmp-server community public RO 20

!

voice-port 1/0:15

translate calling 101

cptone DE

!

dial-peer cor custom

!

!

!

dial-peer voice 100 pots

destination-pattern 0T

progress_ind alert enable 8

progress_ind progress enable 8

progress_ind connect enable 8

direct-inward-dial

port 1/0:15

!

dial-peer voice 2 voip

destination-pattern 98330

progress_ind setup enable 3

translate-outgoing called 10

session target ipv4:192.168.50.10

codec g711alaw

no vad

!

dial-peer voice 30 voip

destination-pattern 9833[1-6][0-9][0-9]

progress_ind setup enable 3

translate-outgoing called 1

session target ipv4:192.168.50.10

codec g711alaw

no vad

!

gateway

!

!

line con 0

transport input none

line aux 0

line vty 0 4

session-timeout 60

access-class 20 in

<password removed by moderator>

login

!

Thanks a lot,

Frank

2 REPLIES
Bronze

Re: Router Crash at translation-rule

I noticed logging buffered 4096 debugging in your config, I’m wondering if you might have console debugging going accidentally too. This could be killing your processor. If that doesn't fix the problem, I would gather a core dump when it crashes and get a hold of Cisco’s TAC.

New Member

Re: Router Crash at translation-rule

Thanks. I'll try it.

Frank

124
Views
0
Helpful
2
Replies