Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

SelectCmDevices Problems with multiple phones

Hi all,i had met this problems with SelectCmDevices. I want to get information of multiple phones in a request, the request is like this:

<soap:Envelope xmlns:soap=\"http://schemas.xmlsoap.org/soap/envelope/\"\n" +

"xmlns:soapenc=\"http://schemas.xmlsoap.org/soap/encoding/\"\n" +

"xmlns:tns=\"http://schemas.cisco.com/ast/soap/\"\n" +

"xmlns:types=\"http://schemas.cisco.com/ast/soap/encodedTypes\"\n" +

"xmlns:xsi=\"http://www.w3.org/2001/XMLSchema-instance\"\n" +

"xmlns:xsd=\"http://www.w3.org/2001/XMLSchema\">\n"+

"<soap:Header>" +

"<tns:AstHeader xsi:type=\"tns:AstHeader\">" +

"<SessionId xsi:type=\"xsd:string\">1234567</SessionId>" +

"</tns:AstHeader>" +

"</soap:Header>" +

"<soap:Body>" +

"<tns:SelectCmDevice>" +

"<StateInfo xsi:type=\"xsd:string\"/>"+

"<CmSelectionCriteria xsi:type=\"tns:CmSelectionCriteria\"/>" +

"</tns:SelectCmDevice>"+

"<tns:CmSelectionCriteria xsi:type=\"tns:CmSelectionCriteria\">"+

"<MaxReturnedDevices xsi:type=\"xsd:unsignedInt\">200</MaxReturnedDevices>"+

"<Class xsi:type=\"tns:DeviceClass\">Phone</Class>" +

"<Model xsi:type=\"xsd:unsignedInt\">255</Model>" +

"<Status xsi:type=\"tns:CmDevRegStat\">Any</Status>" +

"<SelectBy xsi:type=\"tns:CmSelectBy\">Name</SelectBy>" +

"<SelectItems/>" +

"</tns:CmSelectionCriteria>"+

"<soapenc:Array soapenc:arrayType=\"tns:SelectItem[2]\">"+

"<Item href=\"#id3\"/>"+

"</soapenc:Array>"+

"<tns:SelectItem xsi:type=\"tns:SelectItem\">"+

"<Item>SEP001D450BF4CE</Item>"+

"</tns:SelectItem>"+

"<tns:SelectItem xsi:type=\"tns:SelectItem\">"+

"<Item>SEP00131A4D3B34</Item>"+

"</tns:SelectItem>"+

"</soap:Body>" +

"</soap:Envelope>

But is always throw this error: <?xml version="1.0" encoding="UTF-8"?><soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"><soapenv:Body><soapenv:Fault><faultcode>soapenv:Server.generalException</faultcode><faultstring>ERROR: SelectBy is null</faultstring><detail><ns1:hostname xmlns:ns1="http://xml.apache.org/axis/">nltcmpub2.oraclecorp.com</ns1:hostname></detail></soapenv:Fault></soapenv:Body></soapenv:Envelope>

Does somebody know why? Thank you very much!

115
Views
0
Helpful
0
Replies