Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Separate DHCP pools for Voice and Data VLAN's

We are configuring a Cat4500 to support voice and data on the same switch port. The 4500 must provide separate dhcp pools for the voice and data vlans:

ip dhcp pool Data

network 192.168.101.0 255.255.255.0

default-router 192.168.101.1

!

ip dhcp pool Nortel-IP-Phones

network 192.168.120.0 255.255.255.0

default-router 192.168.120.1

!

int vlan101

ip address 192.168.101.0 255.255.255.0

!

int vlan120

ip address 192.168.120.0 255.255.255.0

Would the following port configuration allow the IP phones, and the workstations attached to them, to pick up an IP address from the correct DHCP pool?

interface fas4/1

switchport mode trunk

switchport trunk encapsulation dot1q

switchport nonegotiate

switchport voice vlan 120

spanning-tree portfast

spanning-tree bpduguard enable

Thanks in advance

2 REPLIES
Hall of Fame Super Silver

Re: Separate DHCP pools for Voice and Data VLAN's

You actaully do not need to setup a trunk on the switchport, all you need is the following:

interface fas4/1

switchport nonegotiate

switchport mode access

switchport voice vlan 120

switchport voice vlan 101

spanning-tree portfast

spanning-tree bpduguard enable

Chris

Hall of Fame Super Silver

Re: Separate DHCP pools for Voice and Data VLAN's

Copy and past error, I ment:

interface fas4/1

switchport nonegotiate

switchport mode access

switchport voice vlan 120

switchport access vlan 101

spanning-tree portfast

spanning-tree bpduguard enable

375
Views
5
Helpful
2
Replies
CreatePlease to create content