Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

service URL - location & configuration question

Running CUCM 7.1.3...

Created a service modeled after the SDK 'measurement' example, to be used as a time clock.

It queries a SQL server for validation as well as inputting information to a table.

In development, I'm using a Windows server 2008 R2, with IIS 7.0.

I created the virtual directory on the 'default website', and used the following (example) URL when putting the service into CUCM

A local user was created, an a specialized App Pool (IPTC) was applied at the website level.

http://10.0.0.1/CiscoIPServices/timeclock/menu.asp

The service worked fine.

Transferred it to the Production side, and it doesn't work.

Production side is using Windows server 2003 with IIS 6.0.

App Pool (IPTC) is applied to the Virtual Directory, rather than the website.

We've tried several variations of URL - and each comes up with an error on the phone.

Note: the website it is attached to is the outside corporate website.

It does NOT use http:// - starts straight off with www._______

Using primarily 7942 phones, but some are newer. Doesn't matter which one you're using.

?? Is the http:// a required part of the URL when configuring a service in CUCM?

?? What other possible issues could be causing this to happen?

I've provided examples of my testing, with results.

Any help would be greatly appreciated.

Thanks

Cindy

Examples: Service URL in bold -

http://10.0.x.x/CiscoIPServices/timeclock/menu.asp

Result in Browser -Bad Request (Invalid Hostname)

Result on Phone: Bad Request (Invalid Hostname)

http://www.mycompany.com/CiscoIPServices/timeclock/menu.asp

Result in Browser - Can see the XML of the page (but the http:// is stripped off the URL)

Result on phone - Error: Host Not Found

www.mycompany.com/CiscoIPServices/timeclock/menu.asp

Result in Browser - Can see the XML of the page

Result on Phone: Doesn't find the service at all.

//10.0.x.x/CiscoIPServices/timeclock/menu.asp - Error: Doesn't find the service at all.

Result in Browser -Bad Request (Invalid Hostname)

Result on Phone: Bad Request (Invalid Hostname)

1 ACCEPTED SOLUTION

Accepted Solutions
Bronze

service URL - location & configuration question

Hi Cindy,

Most likely your phones do now have DNS configured and therefore are not able to resolve hostname part of service URL into IP address.

URLs with IP address may not work due to firewall between IP Phones VLAN and your production IIS or IP filters on the IIS server.

You can test the network infrastructure settings by moving your PC into the same VLAN as IP Phones and opening http://10.0.x.x/CiscoIPServices/timeclock/menu.asp   via browser.

Cheers,

Boris

_____ Please rate helpful posts Пожалуйста оценивайте полезные сообщения
1 REPLY
Bronze

service URL - location & configuration question

Hi Cindy,

Most likely your phones do now have DNS configured and therefore are not able to resolve hostname part of service URL into IP address.

URLs with IP address may not work due to firewall between IP Phones VLAN and your production IIS or IP filters on the IIS server.

You can test the network infrastructure settings by moving your PC into the same VLAN as IP Phones and opening http://10.0.x.x/CiscoIPServices/timeclock/menu.asp   via browser.

Cheers,

Boris

_____ Please rate helpful posts Пожалуйста оценивайте полезные сообщения
397
Views
0
Helpful
1
Replies