Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Setting Router LLQ Priority for Picturetel H.323

I need to know what ports I need to assign to an llq QOS priority group on my 3640 routers for H.323 Video Conferencing with 2 Picturetel 970 Video Conferencing units for Voice and Video Priority, also what would you recomend for the amount of bandwidth allocated for voice and video on a point to point T1.

3 REPLIES
Community Member

Re: Setting Router LLQ Priority for Picturetel H.323

Hi , the TCP and UDP ports used by PT 900 Series

is the follow:

TCP traffic (port range: 1700 to 1750)

Call signalling for call establishment: 1720

UDP traffic

UDP audio traffics use port range 17000 to 17050

UDP video traffics use port range 17100 to 17150

Other UDP traffics, such as RAS, use port range: 1700 to 1750

IP Precedence TOS (type of service) byte usage:

UDP audio traffic use TOS byte of 0xA0 (IP Precedence 5)

UDP video traffic use TOS byte of 0 (IP Precedence 0)

I have a very similar equipment, but i don´t know much about llq apply to frame-relay. You can to help me, Because I need to configurate llq for Frame relay .Please

Community Member

Re: Setting Router LLQ Priority for Picturetel H.323

Thank you for your information. In response to your Frame Relay Question I am putting a sample config below. I am using this setup to prioritize voip over a frame relay link. You will have to adjust your port #'s in the access list for video and also will probably have to change the bandwidth settings and CIR settings for your particular frame CIR. I had the TAC help me with this configuration and as you can see it is a little more complex than on a Point to Point Link. Good Luck.

class-map match-all voiceframe

description voice traffic for Frame Relay

match access-group 105

class-map match-all dataframe

description data for frame relay

match access-group 106

!

!

policy-map llqframe

class voiceframe

priority 144

class dataframe

bandwidth 144

class class-default

fair-queue

interface Serial0

bandwidth 384

no ip address

encapsulation frame-relay

no fair-queue

frame-relay traffic-shaping

frame-relay lmi-type ansi

frame-relay ip rtp header-compression

!

interface Serial0.30 point-to-point

bandwidth 384

ip address xxx.xxx.xxx.xxx

frame-relay interface-dlci 30

class llqvoiceframe

map-class frame-relay llqvoiceframe

frame-relay cir 384000

frame-relay bc 3840

frame-relay be 0

frame-relay mincir 384000

no frame-relay adaptive-shaping

service-policy output llqframe

access-list 105 permit udp any any range 16384 32767

access-list 106 permit ip any any

Community Member

Re: Setting Router LLQ Priority for Picturetel H.323

Video conferencing systems use the rtp port range for media communications. This range is 1024 to 32757. Some VC systems allow you to configure a specific rtp port range for use. If so, you can narrow the port range necessary for your purposes. Remember that video calls actually use 2 rtp ports as voice and video are separate streams and both should be funnelled to the same LLQ.

As for b/w, a good formula to calculate necessary b/w - ISDN speed (e.g., 384k) + 10% IP overhead + 5% if encapuslating IP in frame relay or ATM or something.

168
Views
0
Helpful
3
Replies
CreatePlease to create content