Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

SIP and H323 ON SAME VOICE GATEWAY

We have an H323 VoIP working network, but want to migrate to SIP, our voice gateways are Cisco AS5300 with 12.2 IOS.

The question is can coexist in the same interface H323 and SIP??,

or must the gateway have a interface dedicated to just one of them.

or Just can´t we have SIP and H323 configured on the same Gateway?

thanks in advance!

4 REPLIES
New Member

Re: SIP and H323 ON SAME VOICE GATEWAY

Yes any IOS higher the 12.2.XX is supported both H.323 and Sip on the same gateway.

If the GW is for termination only nothing really required to be done, it is automatically synch up according to the protocol which the call originate from

If the GW is originating traffic to the IP side, you can determine the VoIP session control protocol buy assigning matching VoIP dial peer per each SIP or H.323 session.

New Member

Re: SIP and H323 ON SAME VOICE GATEWAY

This is my IOS version and configuration, Could you please take a few moment to feed me back??

Do I need a new RADIUS configuration for using SIP????; Do I need to configure in the as-5300 the SIP-UA anyway??? or Where do I configure the gateway for using SIP in the latest 2.2.xx IOS release?

I put some comments in the configuration below to verify if that would be the required configurations. Please take a moment to feed me back, ok? Thanks in advance for your help!!!!!!!

#show ver

Cisco Internetwork Operating System Software

IOS (tm) 5300 Software (C5300-IS-M), Version 12.2(6a), RELEASE SOFTWARE (fc1)

Copyright (c) 1986-2001 by cisco Systems, Inc.

Compiled Sat 01-Dec-01 11:05 by pwade

Image text-base: 0x600089B0, data-base: 0x60F10000

ROM: System Bootstrap, Version 12.0(2)XD1, EARLY DEPL

1)

uptime is 16 hours, 23 minutes

System returned to ROM by reload at 02:10:53 UTC Sat Aug 3 2002

System restarted at 18:20:43 central Mon Aug 26 2002

System image file is "flash:c5300-is-mz.122-6a.bin"

cisco AS5300 (R4K) processor (revision A.32) with 131072K/16384K bytes of memory

.

Processor board ID 18267500

R4700 CPU at 150Mhz, Implementation 33, Rev 1.0, 512KB L2 Cache

Bridging software.

X.25 software, Version 3.0.0.

SuperLAT software (copyright 1990 by Meridian Technology Corp).

Primary Rate ISDN software, Version 1.1.

Backplane revision 2

Manufacture Cookie Info:

EEPROM Type 0x0001, EEPROM Version 0x01, Board ID 0x30,

Board Hardware Version 3.1, Item Number 73-2414-05,

Board Revision D0, Serial Number 18267500,

PLD/ISP Version , Manufacture Date 25-Feb-2000.

1 Ethernet/IEEE 802.3 interface(s)

1 FastEthernet/IEEE 802.3 interface(s)

100 Serial network interface(s)

4 Channelized T1/PRI port(s)

60 DSP(s), 120 Voice resource(s)

128K bytes of non-volatile configuration memory.

32768K bytes of processor board System flash (Read/Write)

8192K bytes of processor board Boot flash (Read/Write)

Configuration register is 0x2102

----------------------------------------------------------------------------------------------------

#Show run

Current configuration : 5460 bytes

!

! Last configuration change at 19:55:01 central Wed Aug 21 2002

! NVRAM config last updated at 16:22:22 central Thu Aug 8 2002

!

version 12.2

no service single-slot-reload-enable

service timestamps debug uptime

service timestamps log uptime

!

hostname xxxx

!

logging rate-limit console 10 except errors

no logging monitor

aaa new-model

aaa group server radius xxxx1

server xxx.xxx.xxx.xxx auth-port 1645 acct-port 1646

!

aaa group server radius xxxx2

server xxx.xxx.xxx.xxx auth-port 1645 acct-port 1646

!

aaa authentication login default local

aaa accounting connection h323 stop-only broadcast group xxxx1 group xxxx2

################new aaa accounting for SIP?????? is this correct???##################

!

resource-pool disable

!

call rsvp-sync

clock timezone central -6

clock summer-time central recurring

ip subnet-zero

no ip finger

no ip domain-lookup

ip domain-name xxxx

ip name-server xxx.xxx.xxx.xxx

!

no ip dhcp-client network-discovery

!

voice class codec 1

codec preference 1 g729r8

codec preference 2 g729br8

codec preference 3 g723r53

codec preference 4 g723ar53

codec preference 5 g723r63

codec preference 6 g723ar63

!

!

!

!

!

fax interface-type vfc

mta receive maximum-recipients 0

!

!

controller E1 0

framing NO-CRC4

clock source line primary

line-termination 75-ohm

ds0-group 1 timeslots 1-15,17-31 type r2-digital r2-compelled

cas-custom 1

country telmex

category 2

answer-signal group-b 1

dnis-digits min 4 max 20

ani-digits min 0 max 10

dnis-complete

groupa-callerid-end

!

controller E1 1

framing NO-CRC4

clock source line secondary 1

line-termination 75-ohm

ds0-group 1 timeslots 1-15,17-31 type r2-digital r2-compelled

cas-custom 1

country telmex

category 2

answer-signal group-b 1

dnis-digits min 4 max 20

ani-digits min 0 max 10

dnis-complete

groupa-callerid-end

!

controller E1 2

framing NO-CRC4

clock source line secondary 2

line-termination 75-ohm

ds0-group 1 timeslots 1-15,17-31 type r2-digital r2-compelled

cas-custom 1

country telmex

category 2

answer-signal group-b 1

dnis-digits min 4 max 20

ani-digits min 0 max 10

dnis-complete

groupa-callerid-end

!

controller E1 3

shutdown

framing NO-CRC4

clock source line secondary 3

line-termination 75-ohm

ds0-group 1 timeslots 1-15,17-31 type r2-digital r2-compelled

cas-custom 1

country telmex

category 2

answer-signal group-b 1

dnis-digits min 4 max 20

ani-digits min 0 max 10

dnis-complete

groupa-callerid-end

!

gw-accounting h323 ###############gw-accounting for SIP??? is this correct?###########

gw-accounting h323 vsa ##########gw-accounting vsa for SIP????########

gw-accounting voip

translation-rule 1

Rule 0 any xxxxxxxxxxx

!

translation-rule 2

Rule 0 any xxxxxxxxxxx

!

translation-rule 3

Rule 0 any xxxxxxxxx

!

translation-rule 4

Rule 0 any xxxxxxxxxxxx

!

translation-rule 5

Rule 0 any xxxxxxxxxxx

!

!

interface Ethernet0

no ip address

no ip route-cache

no ip mroute-cache

shutdown

!

interface FastEthernet0

ip address xxx.xxx.xxx.xxx xxx.xxx.xxx.xxx

duplex full

speed 10

h323-gateway voip interface

h323-gateway voip id xxxx ipaddr priority 120

h323-gateway voip id xxxx ipaddr xxxx

h323-gateway voip h323-id

h323-gateway voip tech-prefix 1#

###########SIP-gateway voip interface on the same interface that H323????is this correct????##############

###########SIP-gateway voip id ipaddr ????#########

###########SIP-gateway voip ???????###########

dialer-list 1 protocol ip permit

dialer-list 1 protocol ipx permit

!

radius-server host xxx.xxx.xxx.xxx auth-port 1645 acct-port 1646 key xxx

radius-server host xxx.xxx.xxx.xxx auth-port 1645 acct-port 1646 key xxx

radius-server retransmit 10

radius-server timeout 60

radius-server vsa send accounting

!

voice-port 0:1

cptone MX

timing digit 0

timing inter-digit 0

!

voice-port 1:1

cptone MX

timing digit 0

timing inter-digit 0

!

voice-port 2:1

cptone MX

timing digit 0

timing inter-digit 0

!

voice-port 3:1

cptone MX

timing digit 0

timing inter-digit 0

!

dial-peer voice 1 pots

destination-pattern 01..........

translate-outgoing calling 1

direct-inward-dial

port 0:1

forward-digits 10

prefix 01

!

dial-peer voice 10 voip

destination-pattern 20..........

voice-class codec 1

session target ras

#####Can I have a voip dial-peer for SIP with the same destination-pattern than the one for h323...?????#####

!

dial-peer voice 2 pots

destination-pattern 01..........

translate-outgoing calling 2

direct-inward-dial

port 1:1

forward-digits 10

prefix 01

!

dial-peer voice 3 pots

destination-pattern 01..........

translate-outgoing calling 3

direct-inward-dial

port 2:1

forward-digits 10

prefix 01

!

dial-peer voice 4 pots

destination-pattern 01..........

translate-outgoing calling 4

direct-inward-dial

port 3:1

forward-digits 10

prefix 01

!

dial-peer voice 5 pots

destination-pattern 01..........

translate-outgoing calling 5

direct-inward-dial

translate-outgoing calling 5

direct-inward-dial

forward-digits 10

prefix 01

!

gateway

timer receive-rtcp 6

!

!

line con 0

logging synchronous

transport input none

line aux 0

line vty 0 4

!

scheduler interval 1000

ntp clock-period 17208026

ntp server 204.123.2.72

ntp server 128.9.176.30

ntp server 192.6.38.127

end

New Member

Re: SIP and H323 ON SAME VOICE GATEWAY

You at least have to create the sip-ua entry under the conf terminal section.

As for accounting the same definition that works for H.323 will apply for SIP as well, no specific configuration is required.

See my specific reference to each of you question below:

#Show run

Current configuration : 5460 bytes

!

! Last configuration change at 19:55:01 central Wed Aug 21 2002

! NVRAM config last updated at 16:22:22 central Thu Aug 8 2002

!

version 12.2

no service single-slot-reload-enable

service timestamps debug uptime

service timestamps log uptime

!

hostname xxxx

!

logging rate-limit console 10 except errors

no logging monitor

aaa new-model

aaa group server radius xxxx1

server xxx.xxx.xxx.xxx auth-port 1645 acct-port 1646

!

aaa group server radius xxxx2

server xxx.xxx.xxx.xxx auth-port 1645 acct-port 1646

!

aaa authentication login default local

aaa accounting connection h323 stop-only broadcast group xxxx1 group xxxx2

################new aaa accounting for SIP?????? is this correct???##################

==„» Answer: Leave intact

!

resource-pool disable

!

call rsvp-sync

clock timezone central -6

clock summer-time central recurring

ip subnet-zero

no ip finger

no ip domain-lookup

ip domain-name xxxx

ip name-server xxx.xxx.xxx.xxx

!

no ip dhcp-client network-discovery

!

voice class codec 1

codec preference 1 g729r8

codec preference 2 g729br8

codec preference 3 g723r53

codec preference 4 g723ar53

codec preference 5 g723r63

codec preference 6 g723ar63

!

!

!

!

!

fax interface-type vfc

mta receive maximum-recipients 0

!

!

controller E1 0

framing NO-CRC4

clock source line primary

line-termination 75-ohm

ds0-group 1 timeslots 1-15,17-31 type r2-digital r2-compelled

cas-custom 1

country telmex

category 2

answer-signal group-b 1

dnis-digits min 4 max 20

ani-digits min 0 max 10

dnis-complete

groupa-callerid-end

!

controller E1 1

framing NO-CRC4

clock source line secondary 1

line-termination 75-ohm

ds0-group 1 timeslots 1-15,17-31 type r2-digital r2-compelled

cas-custom 1

country telmex

category 2

answer-signal group-b 1

dnis-digits min 4 max 20

ani-digits min 0 max 10

dnis-complete

groupa-callerid-end

!

controller E1 2

framing NO-CRC4

clock source line secondary 2

line-termination 75-ohm

ds0-group 1 timeslots 1-15,17-31 type r2-digital r2-compelled

cas-custom 1

country telmex

category 2

answer-signal group-b 1

dnis-digits min 4 max 20

ani-digits min 0 max 10

dnis-complete

groupa-callerid-end

!

controller E1 3

shutdown

framing NO-CRC4

clock source line secondary 3

line-termination 75-ohm

ds0-group 1 timeslots 1-15,17-31 type r2-digital r2-compelled

cas-custom 1

country telmex

category 2

answer-signal group-b 1

dnis-digits min 4 max 20

ani-digits min 0 max 10

dnis-complete

groupa-callerid-end

!

gw-accounting h323 ###############gw-accounting for SIP??? is this correct?###########

gw-accounting h323 vsa ##########gw-accounting vsa for SIP????########

==„» Answer: Nothing required to be added for SIP

gw-accounting voip

translation-rule 1

Rule 0 any xxxxxxxxxxx

!

translation-rule 2

Rule 0 any xxxxxxxxxxx

!

translation-rule 3

Rule 0 any xxxxxxxxx

!

translation-rule 4

Rule 0 any xxxxxxxxxxxx

!

translation-rule 5

Rule 0 any xxxxxxxxxxx

!

!

interface Ethernet0

no ip address

no ip route-cache

no ip mroute-cache

shutdown

!

interface FastEthernet0

ip address xxx.xxx.xxx.xxx xxx.xxx.xxx.xxx

duplex full

speed 10

h323-gateway voip interface

h323-gateway voip id xxxx ipaddr priority 120

h323-gateway voip id xxxx ipaddr xxxx

h323-gateway voip h323-id

h323-gateway voip tech-prefix 1#

###########SIP-gateway voip interface on the same interface that H323????is this correct????##############

###########SIP-gateway voip id ipaddr ????#########

###########SIP-gateway voip ???????###########

==„» Answer Nothing required to be added here, the SIP referral will be done below under the VoIP dila-peer section

dialer-list 1 protocol ip permit

dialer-list 1 protocol ipx permit

!

radius-server host xxx.xxx.xxx.xxx auth-port 1645 acct-port 1646 key xxx

radius-server host xxx.xxx.xxx.xxx auth-port 1645 acct-port 1646 key xxx

radius-server retransmit 10

radius-server timeout 60

radius-server vsa send accounting

!

voice-port 0:1

cptone MX

timing digit 0

timing inter-digit 0

!

voice-port 1:1

cptone MX

timing digit 0

timing inter-digit 0

!

voice-port 2:1

cptone MX

timing digit 0

timing inter-digit 0

!

voice-port 3:1

cptone MX

timing digit 0

timing inter-digit 0

!

dial-peer voice 1 pots

destination-pattern 01..........

translate-outgoing calling 1

direct-inward-dial

port 0:1

forward-digits 10

prefix 01

!

dial-peer voice 10 voip

destination-pattern 20..........

voice-class codec 1

session target ras

#####Can I have a voip dial-peer for SIP with the same destination-pattern than the one for h323...?????#####

==„» Answer: No, that the place to determine if you want to use H.323 or SIP. The option has we can call it call signaling negation doesn¡¦t exist.

==„» Answer: In SIP case you have to define

session protocol sipv2

session target dns:

dial-peer voice ce 2 pots

destination-pattern 01..........

translate-outgoing calling 2

direct-inward-dial

port 1:1

forward-digits 10

prefix 01

!

dial-peer voice 3 pots

destination-pattern 01..........

translate-outgoing calling 3

direct-inward-dial

port 2:1

forward-digits 10

prefix 01

!

dial-peer voice 4 pots

destination-pattern 01..........

translate-outgoing calling 4

direct-inward-dial

port 3:1

forward-digits 10

prefix 01

!

dial-peer voice 5 pots

destination-pattern 01..........

translate-outgoing calling 5

direct-inward-dial

translate-outgoing calling 5

direct-inward-dial

forward-digits 10

prefix 01

!

gateway

timer receive-rtcp 6

!

!

line con 0

logging synchronous

transport input none

line aux 0

line vty 0 4

!

scheduler interval 1000

ntp clock-period 17208026

ntp server 204.123.2.72

ntp server 128.9.176.30

ntp server 192.6.38.127

end

New Member

Re: SIP and H323 ON SAME VOICE GATEWAY

YARON

I really apreciate your help, for taking the time and reply for my questions.

178
Views
0
Helpful
4
Replies
CreatePlease to create content