Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

SoftKeyItem Problem

I have a problem with the SoftKeyItem, when I had this element to my XML page the phone give this error "ERROR: Could not find token SoftKeyItem in current element table."

I use the firmware P0M3-04-4-00.bin

Thanks for your help

18 REPLIES
New Member

Re: SoftKeyItem Problem

How is it that you are using the SoftKeyItem?

New Member

Re: SoftKeyItem Problem

This is an example of my CMXML:

Renvoi vers Desactive

Choisissez votre renvoi d'appel

Boite vocal

http://1.2.3.4/79xx//services/followme.php

Mobile

http://1.2.3.4/79xx//services/followme.php

Sur le poste

http://1.2.3.4/79xx//services/followme.php

Menu

http://1.2.3.4/79xx//services/index.php

Silver

Re: SoftKeyItem Problem

Is that a typo, or did you repeat the tag by mistake on a few lines?

Replace with just and you should have better luck...

New Member

Re: SoftKeyItem Problem

Also add tag after the tag in SoftKeyItem

New Member

Re: SoftKeyItem Problem

This is my new XML file, but I always receive "XML Parse ERROR"

Renvoi vers Desactive

Choisissez votre renvoi d'appel

Boite vocal

http://1.2.3.4/79xx//services/followme.php

Mobile

http://1.2.3.4/79xx//services/followme.php

Sur le poste

http://1.2.3.4/79xx//services/followme.php

Menu

4

http://1.2.3.4/79xx//services/index.php

New Member

Re: SoftKeyItem Problem

You have used URL tag twice

please reomove that and check on a browser first like internet explorer

it will tell you where the error is.

Regards

Shyamal

New Member

Re: SoftKeyItem Problem

I don't find where I have user URL tag twice.

And IE don't found error on my XML.

Thanks.

New Member

Re: SoftKeyItem Problem

Try using this

Renvoi vers Desactive

Choisissez votre renvoi d'appel

Boite vocal

http://1.2.3.4/79xx/services/followme.php

Mobile

http://1.2.3.4/79xx/services/followme.php

Sur le poste

http://1.2.3.4/79xx/services/followme.php

Menu

4

http://1.2.3.4/79xx/services/index.php

Thanks

Shyamal

New Member

Re: SoftKeyItem Problem

Sorry but it doesn't work.

Thanks.

Silver

Re: SoftKeyItem Problem

Examine the code that you posted both times, and note the double usage. IE may not complain about that, but the IP Phone will.

The code that Shyamal posted should work for you.

New Member

Re: SoftKeyItem Problem

Sorry but the code work only when I remove:

Menu

4

http://1.2.3.4/79xx/services/index.php

Re: SoftKeyItem Problem

Hi,

I think you need a different Firmware for your phone to support these tags.

regards,

Sascha

New Member

Re: SoftKeyItem Problem

Yes, but which MGCP firmware?

Re: SoftKeyItem Problem

Hi,

I think it doesn't work on a mgcp IPPhone;

quote: The Cisco MGCP IP phone supports Cisco CallManger XML up to version 3.0. It does not support the XML objects added in Cisco CallManager XML version 3.1......

Sascha

New Member

Re: SoftKeyItem Problem

I have this same problem on a 7940 running POS3-06-0-00.

Can anyone tell me why adding the following to a valid element gives xml parse error? It works fine on the colour 7970 phones:

Control

Choose an option

Item One

http://someserver/somepage

Custom

http://someserver/someotherpage

4

Silver

Re: SoftKeyItem Problem

Are both phones running SIP loads (including the color phone)?

Try removing the SoftkeyItem element, and see if that resolves the issue. If it does, then the problem is similar to the above problem, though in this case you seem to be using the SIP load rather than the MGCP load.

Not all features are supported in non-SCCP loads, though that may be changing. It looks like you are using a 4.0-based load on your phone, so you have some room to upgrade and see if that resolves the problem. If it works on your 7970 and not the other phone, you may want to try upgrading the load on your other phone, though theres no guarantee that will work..

New Member

Re: SoftKeyItem Problem

Thanks for your reply:

The 7940 are on our production SIP phone system (3rd party hosted), while I run the 7970s locally for development work with CISCO Call Manager/SCCP.

All works fine without the sokfKeyItems. The 7970s have the latest firmware and no issues.

I'll enquire if we can upgrade our 7940s' internal load. Do you know the latest SIP load number?

In the meantime I've got someone going on to the Customers site so I'll get them to make a note of the firmware version there, and test out the xml sofkeyItem tags at the same time.

Thanks. TBC.

Silver

Re: SoftKeyItem Problem

The reason the 7970 works is because it is connected to CallManager using SCCP. The 7940 is connected to a different softswitch (asterisk?) using the SIP load. The SCCP loads provide full XML functionality, while the SIP and MGCP loads provide reduced XML functionality, as per this document:

http://www.cisco.com/en/US/products/sw/voicesw/ps4967/products_administration_guide_chapter09186a00801727e9.html#1024548

The above link describes MGCP support, though it is similar to the SIP loads.

You can try upgrading the 7940's load, but that is no guarantee, as that feature might still not be supported on SIP/MGCP loads, even in the latest versions.

This link describes CCM version 3.0 XML, which is what the SIP/MGCP loads support (as per the documentation):

http://www.cisco.com/en/US/products/sw/voicesw/ps556/products_programming_usage_guide09186a00800d6a67.html

517
Views
0
Helpful
18
Replies